[needs-packaging] GNOME-colors icon theme

Bug #261988 reported by Vincent
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
gnome-colors (Ubuntu)
Wishlist
GNOME-Colors Packagers
Nominated for Jaunty by Charlie Kravetz

Bug Description

URL:
http://www.gnome-look.org/content/show.php/GNOME-colors?content=82562
License: GNU LGPL 3
Notes: To make Jozsef happy and to make Xubuntu look very nice, but mostly to make Jozsef happy, the GNOME-colors icon theme should be packaged for Xubuntu 8.10 :)

Vincent (vinnl)
description: updated
Changed in xubuntu-meta:
assignee: nobody → cody-somerville
Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

This should really be packaged in its own package.

Changed in xubuntu-artwork:
importance: Undecided → Wishlist
status: New → Triaged
Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Hi all,

Has there been any progress on this package?

I'm generally interested in getting some of the more popular themes in the repositories. To that goal I've worked on the community-themes package, getting it updated to the newest versions of Dust and New Wave. I've also been watching this bug for awhile as I'd like to see the Shiki-Colors themes in the archive, and they use the GNOME-Colors icons. I've packaged both GNOME-Colors and Shiki-Colors in my PPA. As Feature Freeze is nearly on us, I'm wondering if I should submit my package to REVU. Please feel free to test and review my packages.

https://edge.launchpad.net/~andrewsomething/+archive/ppa

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

As Cody removed himself from the assignee field, I guess he's no longer interested. I've uploaded my work to REVU:

http://revu.ubuntuwire.com/p/gnome-colors

Revision history for this message
Benjamin Drung (bdrung) wrote :

Nice work, Andrew. Here are some suggestions (see debdiff):

* Switch to debhelper 7 (compat, rules, control).
* debian/rules:
  - I have tuned get-orig-source (saver than the previous, you have to recreate your source tarball)
  - Removed all unneeded quotation marks
  - Removed unneeded configure target
  - Empty build target and removed unneeded build-stamp target
* debian/contol:
  - http://code.google.com/p/gnome-colors/ looks like the upstream homepage
  - Split depends line
  - changed short description (not optimal, but better)

I have two questions:

1. Should we rename the binary package names and putting something like icon and theme in the name?

2. How do we implement the bugfix described in the README file:

Due to a bug in Nautilus, you may have to run the following commands for drag n' drop/visiting-folders to look correctly (replace sudo for its equivalent in other linux distros):

sudo rm -f /usr/share/icons/gnome*/*/places/inode-directory.*g
sudo gtk-update-icon-cache -qf /usr/share/icons/gnome/
sudo gtk-update-icon-cache -qf /usr/share/icons/gnome-brave/
sudo gtk-update-icon-cache -qf /usr/share/icons/gnome-human/
sudo gtk-update-icon-cache -qf /usr/share/icons/gnome-noble/
sudo gtk-update-icon-cache -qf /usr/share/icons/gnome-wine/
sudo gtk-update-icon-cache -qf /usr/share/icons/gnome-wise/

Revision history for this message
Benjamin Drung (bdrung) wrote :
Revision history for this message
perfectska04 (perfectska04-deactivatedaccount) wrote :

@Benjamin Drung
Hey, I'm the creator of the GNOME-Colors project.

The bugfix mentioned in the README should only be applied by an user who willingly wants to use this workaround and fix the nautilus bug, rather than done by a package. The reasoning is that the command deletes the inode-directory icon from gnome-icon-theme as well, since that is the icon which causes the Nautilus bug.

It'd be best to promote the Nautilus patch available in this bug's page, so none of those icons need to be removed - and all other Linux/GNOME icon themes are fixed as well.

The page for this bug is:
http://bugzilla.gnome.org/show_bug.cgi?id=567254

Revision history for this message
Benjamin Drung (bdrung) wrote :

To shorten the get-orig-source target you can replace get-orig-source with $@ (patch attached).

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

@Benjamin

Thanks so much for the review and suggestions!

I incorporated all your changes except for the short descriptions. I'm still not satisfied with them nor mine. Debian policy (3.4.1) explicitly states "Do not include the package name in the synopsis line. The display software knows how to display this already, and you do not need to state it." So I don't think that your descriptions work. Mine are also problematic, not least of all because lintian complains about them being the same. Need to think about this some more...

Did you look at debian/copyright? I'm not sure if I need to list Tango, ect in there or if pointing to the AUTHORS file is enough.

I went ahead and renamed the binaries to *-icon-theme as that seems to be the standard in the archive (i.e human-icon-theme, gnome-icon-theme). Maybe I should leave the meta-package simply gnome-colors though? I'm not sure whats best, sicking closer to the upstream name or following the general pattern of naming GNOME icon themes in the archive.

Also I went ahead and put this into a bzr branch. I had been meaning to do this already, but as someone else has taken an interest I figure I should do it now.

bzr branch lp:gnome-colors-pkg

or:

https://code.edge.launchpad.net/~gnome-colors-packagers/gnome-colors-pkg/debian

Also just a general update for all who are interested in the status of this.... As this missed Jaunty's feature freeze and Debian is now unfrozen, I am now aiming to submit the package directly to Debian. This way it will be synced into Karmic automatically. The Debian ITP has been linked above. The same goes for Shiki-Colors. See: Bug #328667

Also, my PPA package has diverged some what from the real packaging some what in order to make sure people with my PPA in their sources can upgrade cleanly.

@perfectska04 - Thanks so much for creating such a nice theme! Now I'm off to file a bug in your tracker about shiki-colors not having an explicit copyright notice. Having one will make it much easier to get into Debian. They can be pretty strict about such things. =)

Revision history for this message
perfectska04 (perfectska04-deactivatedaccount) wrote :

Ok, I've added "COPYING" files to all the artwork and updated them to GPL v3. I've also moved all the downloads to the google code page and renamed them "project-version.tar.gz".

Hopefully with these changes, it should be much easier to manage packages and keep hosting older revisions, even if newer versions are uploaded.

Revision history for this message
Benjamin Drung (bdrung) wrote :

I would prefer to leave the meta-package simply gnome-colors. For the meta-package it would be better to be closer to upstream. Otherwise we may use the plural form: gnome-colors-icon-themes.

I did not review debian/copyright, I only fixed the obvious mistakes there.
@perfectska04: Do you use GPLv3 or GPLv3+ (GPLv3 or later)? You modified some GNOME icons. You are only allowed to relicense it under GPLv3 if they used GPLv2+ or GPLv3.

On the todo list: Find a solution for the short descriptions.

BTW we should package Arc-Colors, too.

Revision history for this message
perfectska04 (perfectska04-deactivatedaccount) wrote :

@Benjamin Drung
All the icons based on gnome-icon-theme should retain their license. All I've been able to find is that gnome-icon-theme is GPL, but the exact version Is not specified, so I imagine it's GPLv2+.

Then again, I'm not too knowledgeable when it comes to licensing or possible conflicts, so let me know if there's a license that suits the project better, or if there is something else I can do. For the most part, I just want both the gnome-based icons and my own original ones to share the same free licenses.

There are a few icons that are either Tango or Tango-based, so the license is CC-by-SA 2.5 and is included in the COPYING file as well for these icons.

Revision history for this message
Jonathan Davies (jpds) wrote :

This is too late for Jaunty as we are now in feature/beta freeze. However I will try to help get it into Karmic.

Andrew: Could you possibly fix the duplicate-short-description lintian warning in the source package? Having: 'a set of GNOME icon themes (Brave variation)', etc, ought to do it.

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

RE: Copyright

I'm investigating this more. Tango seems to have been relicensed under the public domain. This is good news as Debian legal has issues with mixing CC below 3.0 and the GPL.

From tango-icon-theme- 0.8.90/debian/copyright:

  In the preparation of the 0.8.90 release Novell took care of tracking
  down all the contributors to get them to relicense their artwork
  into Public Domain.

  The COPYING file of the tarball states the following:
  | The icons in this repository are herefore released into the Public Domain.

Still trying to figure out if gnome-icon-theme is GPL-2 or GPL-2+

@perfectska04

Thanks for those changes. They will definitely make it easier to maintain a package from a distro perspective.

@Benjamin Drung

Thanks again for all the help. If you're interested in being a co-maintainer, feel free to add yourself in debian/control. If not, credit your self in the changelog.

@Jonathan Davies

Thanks. See above in the thread. We're aiming for Debian so it can just get synced in. That lintian warning has been fixed in the packaging branch (lp:gnome-colors-pkg). Any further review would be helpful, but I think we're almost ready. Know any DDs that would be willing to upload?

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Another update for anyone interested:

A package has been submitted for review to Debian Mentors:

http://mentors.debian.net/cgi-bin/sponsor-pkglist?action=details;package=gnome-colors

Ubuntu packages are availiable in this PPA for Hardy, Intrepid, and Jaunty:

https://edge.launchpad.net/~gnome-colors-packagers/+archive/ppa

Changed in ubuntu:
assignee: Andrew Starr-Bochicchio (andrewsomething) → GNOME-Colors Packagers (gnome-colors-packagers)
Revision history for this message
Arnaud Jeansen (ajeans) wrote :

Hi Andrew,

I tried to install the gnome colors package from your PPA, but it failed with the following line:
E: /var/cache/apt/archives/gnome-brave-icon-theme_3.2-0~ppa1_all.deb: trying to overwrite `/usr/share/icons/gnome-brave/48x48/animations/process-working.png', which is also in package xubuntu-artwork

It seems that xubuntu-artwork ships all the icons of gnome-brave, so this should be sorted out if the package is to be accepted.

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

This was temporary, because we were too late for jaunty to pass through NEW.

For karmic, we'll remove them as soon as the 'real' icon theme package is in the archive. You just need to add a versioned Conflicts & Replaces on xubuntu-artwork, for example (<< 0.27~), to provide a flawless upgrade path.

Revision history for this message
Arnaud Jeansen (ajeans) wrote :

OK I couldn't say whether this was known already, no problem then. It would be nice to apply this change in the PPA though, as I'm pretty sure some other users will get the same problem.

It is a very nice theme by the way, it would be a great addition to ubuntu, so thanks to all working on this.

Revision history for this message
Daniel Hurtado (dhurtado) wrote :

Hi there

I'm sorry, but I can't get the thing with the "versioned Conflicts & Replaces" sorted out - any hint there? That would be great!

Thanks

Revision history for this message
Hans Rødtang (hansrodtang) wrote :

Has it been confirmed which version of the GPL the included Elementary icons are released under? All sources I have seen tell that they are under the GPL, but fail to mention which version. If they are GPLv3, it would mean that they are not compatible with the other icons in the theme (most importantly, if not only gnome-icon-themes GPLv2-only).

That said, GPL is a really, really bad artwork license.

Revision history for this message
Benjamin Drung (bdrung) wrote :

They are GPLv2, too. Which files claim to be licensed under GPL without giving a version?

Revision history for this message
Benjamin Drung (bdrung) wrote :

gnome-colors 4.5-0ubuntu1 is now in karmic.

affects: ubuntu → gnome-colors (Ubuntu)
Changed in gnome-colors (Ubuntu):
status: In Progress → Fix Released
Changed in debian:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.