Display calibration hangs

Bug #1310388 reported by dot-borg on 2014-04-20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-color-manager (Ubuntu)

Bug Description

After performing a display calibration, the "continue" button remains grayed-out. Clicking the arrow to show the output reveals that all the patches were checked and everything looks OK with the message "The instrument can be removed from the screen". However, no further action can be taken other than clicking the back button or the cancel button.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gnome-color-manager 3.8.3-1ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Apr 20 13:56:21 2014
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gcm-calibrate
InstallationDate: Installed on 2014-04-19 (1 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
 PATH=(custom, no user)
SourcePackage: gnome-color-manager
UpgradeStatus: No upgrade log present (probably fresh install)

dot-borg (itrombley) wrote :
dot-borg (itrombley) wrote :

I was able to get past this by downgrading argyll to 1.4.0-8ubuntu5 but then I got a segfault when the profile was to be written out.

dot-borg (itrombley) wrote :

I ran dispcal from the terminal

    dispcal -v -q l -t 6500 -H -P 0.5,0.5,0.8 display

and it got stuck at the message "The instrument can be removed from the screen", so this is definitely an argyll issue.

Pedro Côrte-Real (pedrocr) wrote :

I hit this issue as well. I fixed it by upgrading colord, gnome-color-manager and argyll from this PPA:


dot-borg (itrombley) wrote :

Thanks for the link. I'll give the PPA a try.

F (francie) wrote :

I have encountered an issue that is the same or similar to this on two different machines running ubuntu 14.04. (Using a Colormunki photo).
Colour calibration hangs with the "Continue" button grayed-out when the progress indicator is finished at the "Getting default parameters" stage. I calibrated my screen without any issue using the same set up 10 months ago.

F (francie) wrote :

I can confirm that using Pascal's PPA https://launchpad.net/~pmjdebruijn/+archive/gnome-color-manager-release solved the problem for me.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-color-manager (Ubuntu):
status: New → Confirmed
Ul. Vo. (ulrich-voosholz) wrote :

Issue same to me. (Trusty, AMD64). The PPA solved the problem.

Alfred15 (vincent-raspal) wrote :

I have the same problem (Ubuntu 14.04, AMD 64)
I'm gonna try Pascal's PPA

dot-borg (itrombley) wrote :

This is still an issue in 14.10.

Chelmite (steve-kelem) wrote :

This is still an issue in 14.10, even after installing the PPA. I am running the app from Systems Settings/Color on an x86-64 system. I have a colormunki photo.

Also, there is an error in the illustration when it says to switch from Calibrate to Screen, the illustration shows the calibration orientation for both of them. Do I file a bug here, or with Pascal de Bruijn?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers