rhythmbox can't find ID3 tag muxer for MP3 support

Bug #888847 reported by Matt Hanyok on 2011-11-11
80
This bug affects 16 people
Affects Status Importance Assigned to Milestone
gnome-codec-install (Ubuntu)
Undecided
Unassigned

Bug Description

When using Rhythmbox and changing the preferred file format to MP3, a button labeled "install additional software required to use this format" appears. Clicking the button brings up a "search for suitable plugins" for an "ID3 tag muxer" but one cannot be found.

This is an excerpt created by running the command " rhythmbox --debug &> rhythmbox-debug.txt" from when I changed the preferred format.

(20:44:03) [0x9500c0] [library_settings_changed_cb] rb-library-source.c:529: preferred media type changed
(20:44:03) [0x9500c0] [impl_get_missing_plugins] rb-encoder-gst.c:750: trying to check profile mp3 for missing plugins
(20:44:03) [0x9500c0] [impl_get_missing_plugins] rb-encoder-gst.c:770: didn't get request pad, profile mp3 doesn't work
(20:44:03) [0x9500c0] [rb_library_source_format_changed_cb] rb-library-source.c:787: additional plugins are required to encode audio/mpeg

Revision history for this message
Matt Hanyok (matthew-hanyok) wrote :

Funny enough, just after I reported this, I looked in the software center and saw it mentioning the gstreamer "bad" plugins set as not installed.

Installing it made the problem go away.

MP3 support is installed via the "ugly" plugins set, I thought... shouldn't this ID3 tag muxer be installed with that, and not "bad"?

Alternately... why couldn't it figure out it just needed that set of plugins?

affects: rhythmbox (Ubuntu) → gnome-codec-install (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-codec-install (Ubuntu):
status: New → Confirmed
Revision history for this message
Jbyvosges (j-lbarbry) wrote :

Its the same with Rhythmbox, Banshee or Clementine. It works with Audacity.
I tried to uninstall / reinstall some Gstreamer paquages : no change.

Revision history for this message
Justin Hahn (jeh) wrote :

The problem appears to be that you need to install gstreamer0.10-plugins-ugly (or so reports one of our internal users) However the gnome-codec-installer still fails in that case.

Revision history for this message
panmari (panmari) wrote :

Installing gstreamer0.10-plugins-ugly didn't resolve the error for me.

Revision history for this message
Adam Novak (interfect) wrote :

You need gstreamer1.0-plugins-ugly and/or gstreamer1.0-plugins-bad. Not the 0.10 versions. I installed them both and it started working for me.

Revision history for this message
whochismo (whochismo) wrote :

I confirm that by installing both packages (gstreamer1.0-plugins-ugly and gstreamer1.0-plugins-bad) worked for me. I can now save CDs in mp3 format in rhythmbox.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers