gnome-codec-install crashed with Depends in _run(): libstdc++6 (>= 4.1.1) but 4.6.1-7ubuntu2 is to be installed

Bug #834133 reported by Ken Pratt on 2011-08-25
218
This bug affects 32 people
Affects Status Importance Assigned to Milestone
gnome-codec-install (Ubuntu)
Medium
Canonical Desktop Team

Bug Description

Tried to play an MP3 using Banshee. It prompted for me to download CODECS. I said yes and got the crash.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gnome-codec-install 0.4.7+nmu1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
Date: Thu Aug 25 16:54:28 2011
ExecutablePath: /usr/bin/gnome-codec-install
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gstreamer-codec-install --transient-for=56623121 gstreamer|0.10|Banshee|MPEG-1\ Layer\ 3\ (MP3)\ decoder|decoder-audio/mpeg,\ mpegversion=(int)1,\ mpegaudioversion=(int)1,\ layer=(int)3,\ parsed=(boolean)true
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/gstreamer-codec-install', '--transient-for=56623121', 'gstreamer|0.10|Banshee|MPEG-1 Layer 3 (MP3) decoder|decoder-audio/mpeg, mpegversion=(int)1, mpegaudioversion=(int)1, layer=(int)3, parsed=(boolean)true']
SourcePackage: gnome-codec-install
Title: gnome-codec-install crashed with Depends in _run(): libstdc++6 (>= 4.1.1) but 4.6.1-7ubuntu2 is to be installed
UpgradeStatus: Upgraded to oneiric on 2011-08-23 (2 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Ken Pratt (kenpratt) wrote :
tags: removed: need-duplicate-check
Changed in gnome-codec-install (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
visibility: private → public
tags: removed: bugpattern-needed
tags: added: bugpattern-written
Jan Rathmann (kaiserclaudius) wrote :

I was able to track down the problem a bit, the unmet dependencies error only happens if the :i386-versions of the Gstreamer codec packages (ffmpeg and ugly) are also selected beside the native (amd64) ones in gnome-code install (which is currently the default). If I manually deselect the :i386-versions, gnome-codec-install works properly.

Kind regards,
Jan

tags: added: iso-testing
Changed in gnome-codec-install (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → Medium
status: Confirmed → Triaged
jura (zinlun) on 2013-01-06
Changed in gnome-codec-install (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers