Unsatisfied dependency: Handy

Bug #1919081 reported by Vitaliy Kanev
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-characters (Ubuntu)
High
Gunnar Hjalmarsson

Bug Description

Steps to reproduce this bug:
1. Update the version of `gnome-characters` on Ubuntu Hirsute to `40~beta-1` (`gnome-characters --version` doesn't work and yields the same error relating to Handy)
2. Run `gnome-characters` from terminal (Note: DO NOT run Characters from application launcher because it will not work!)
3. Check the output of command

Expected behavior:
`gnome-characters` should open, should yield some warnings in the terminal

Actual behavior:
`gnome-characters` will simply yield `Unsatisfied dependency: Handy` to the terminal, even when supplying `--help` or `--version` to the command.

Additional information:
Installed from Hirsute Daily image, current as of Mar 14 2021 17:00 UTC+3

$ uname -a && echo && lsb_release -idrc && echo && apt policy gnome-characters
Linux hirsute-vm-ubuntu 5.10.0-14-generic #15-Ubuntu SMP Fri Jan 29 15:10:03 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Distributor ID: Ubuntu
Description: Ubuntu Hirsute Hippo (development branch)
Release: 21.04
Codename: hirsute

gnome-characters:
  Installed: 40~beta-1
  Candidate: 40~beta-1
  Version table:
 *** 40~beta-1 500
        500 http://ru.archive.ubuntu.com/ubuntu hirsute/main amd64 Packages
        100 /var/lib/dpkg/status

Also to note, all those `libhandy` packages (except `dev`) are installed on the VM.

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: gnome-characters 40~beta-1
ProcVersionSignature: Ubuntu 5.10.0-14.15-generic 5.10.11
Uname: Linux 5.10.0-14-generic x86_64
ApportVersion: 2.20.11-0ubuntu60
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: ubuntu:GNOME
Date: Sun Mar 14 18:48:33 2021
InstallationDate: Installed on 2021-03-14 (0 days ago)
InstallationMedia: Ubuntu 21.04 "Hirsute Hippo" - Alpha amd64 (20210123)
SourcePackage: gnome-characters
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Vitaliy Kanev (vitalkanev) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-characters (Ubuntu):
status: New → Confirmed
Revision history for this message
Rik Mills (rikmills) wrote :

In Kubuntu build (so not huge amounts of gnome already):

gnome-characters confirmed to fail to start after install.

However, after installing the package 'gir1.2-handy-1' package, it seems to start as ok and as intended.

Changed in gnome-characters (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → High
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-characters - 40~beta-2

---------------
gnome-characters (40~beta-2) experimental; urgency=medium

  [ Gunnar Hjalmarsson ]
  * debian/control.in: Depends on gir1.2-handy-1
    - Thanks to Joakim Walldén for pointing it out! (lp: #1919081)

 -- Sebastien Bacher <email address hidden> Mon, 22 Mar 2021 09:53:05 +0100

Changed in gnome-characters (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers