org.gnome.Characters.desktop untranslated

Bug #1767549 reported by Gunnar Hjalmarsson on 2018-04-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-characters (Ubuntu)
Medium
Gunnar Hjalmarsson
Bionic
Medium
Jeremy Bicha

Bug Description

[Impact]

The version of dh_translations, which was present when gnome-characters was last uploaded, resulted in a .desktop file with the wrong gettext domain, so the name of the application in e.g. the Activities overview is always shown in English.

Meson support has been added to dh_translations since, so a no-change rebuild is sufficient to fix the issue.

We can drop the dh_translations overrides since dh_translations correctly handles meson in this case.

Also, we are updating gnome-characters to 3.28.2

https://gitlab.gnome.org/GNOME/gnome-characters/commits/master
https://gitlab.gnome.org/GNOME/gnome-characters/blob/master/NEWS

[Test Case]

On a system with some other language but English:

* Install the gnome-characters .deb package (Note that in a new 18.04 LTS install, the Snap is installed instead of the .deb.)

-> find that its name is "Characters".

* Install the rebuilt version of gnome-characters

* Relogin

-> find that its name is the translation of "Characters"

[Regression Potential]

There is a micro-release exception for GNOME:
https://wiki.ubuntu.com/StableReleaseUpdates#GNOME

[Original description]

$ tail -n1 /usr/share/applications/org.gnome.Characters.desktop
X-Ubuntu-Gettext-Domain=$PACKAGE_NAME

dh_translations is confused by files in the source package belonging to the old build system. configure.ac contains this line:

GETTEXT_PACKAGE=$PACKAGE_NAME

and dh_translations happily uses it to do its things.

The gnome-characters source package should apparently be cleaned up, but I think that dh_translations should also be changed to not accept a domain starting with '$'.

Changed in pkgbinarymangler (Ubuntu):
importance: Undecided → Medium
Gunnar Hjalmarsson (gunnarhj) wrote :

A no-change rebuild in bionic of gnome-characters should fix this, since the package was last uploaded before meson support had been added to dh_translations.

Changed in gnome-characters (Ubuntu):
status: New → In Progress
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
description: updated
Jeremy Bicha (jbicha) on 2018-05-04
no longer affects: gnome-characters (Ubuntu Cosmic)
no longer affects: pkgbinarymangler (Ubuntu)
no longer affects: pkgbinarymangler (Ubuntu Bionic)
no longer affects: pkgbinarymangler (Ubuntu Cosmic)
Changed in gnome-characters (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-characters - 3.28.0-4

---------------
gnome-characters (3.28.0-4) unstable; urgency=medium

  * Recommends fonts-noto-color-emoji since it's the only color
    emoji font in Debian currently
  * Drop obsolete dh_translations overrides (LP: #1767549)

 -- Jeremy Bicha <email address hidden> Fri, 04 May 2018 18:36:18 -0400

Changed in gnome-characters (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2018-05-23
description: updated
Jeremy Bicha (jbicha) on 2018-05-23
description: updated
Changed in gnome-characters (Ubuntu Bionic):
assignee: Gunnar Hjalmarsson (gunnarhj) → Jeremy Bicha (jbicha)

Hello Gunnar, or anyone else affected,

Accepted gnome-characters into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-characters/3.28.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-characters (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Gunnar Hjalmarsson (gunnarhj) wrote :

Test case verified with gnome-characters 3.28.2-0ubuntu1 from bionic-proposed.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-characters - 3.28.2-0ubuntu1

---------------
gnome-characters (3.28.2-0ubuntu1) bionic; urgency=medium

  * New upstream release
  * Drop obsolete dh_translations overrides and fix .desktop translations
    (LP: #1767549)

 -- Jeremy Bicha <email address hidden> Wed, 23 May 2018 09:47:53 -0400

Changed in gnome-characters (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-characters has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers