Characters Snap doesn't have color emoji

Bug #1753146 reported by Jeremy Bicha on 2018-03-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-platform-snap
Undecided
Ken VanDine
gnome-characters (Ubuntu)
High
Ken VanDine
Bionic
High
Ken VanDine

Bug Description

The GNOME Characters snap doesn't have color emoji. This is a regression compared to the .deb.
This week, the snap replaced the .deb in the default install.

Maybe you need to build this snap using bionic's cairo?

$ snap info gnome-characters
name: gnome-characters
summary: A character map application
publisher: canonical
license: unknown
description: |
  Characters is a simple utility application to find and
  insert unusual characters.
snap-id: qJcS3UjpF9AMJKWAiKwA5EWbm0y6Uduw
commands:
  - gnome-characters
tracking: stable
installed: 3.26.2 (50) 12MB -
refreshed: 2018-01-30 17:02:22 -0500 EST
channels:
  stable: 3.26.2 (50) 12MB -
  candidate: 3.26.2 (50) 12MB -
  beta: ↑
  edge: v3.26.2+git15.c29237e (58) 13MB -

Jeremy Bicha (jbicha) on 2018-03-05
tags: added: rls-bb-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-characters (Ubuntu):
status: New → Confirmed
Changed in gnome-characters (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
Will Cooke (willcooke) on 2018-03-06
tags: removed: rls-bb-incoming

problem solved with recent updates

Jeremy Bicha (jbicha) wrote :

This is fixed in the edge channel for the gnome-3-26-1604 snap and will be promoted to stable soon.

It required backporting cairo, freetype, and fontconfig from bionic.

Thanks!

Changed in gnome-characters (Ubuntu Bionic):
status: Confirmed → Fix Released
Ken VanDine (ken-vandine) wrote :

I've fixed this in gnome-3-26-1604 in the edge channel. After a round of testing of apps I'll resolve this.

Changed in gnome-platform-snap:
status: New → Fix Committed
Changed in gnome-platform-snap:
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gnome-platform-snap:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers