[focal] gnome-calendar crashes when moving it full screen to another screen (SIGSEGV in gdk_rgba_to_string())

Bug #1868940 reported by Trent Lloyd on 2020-03-25
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-calendar (Ubuntu)
Medium
Unassigned

Bug Description

I can consistently crash gnome-calendar by dragging it from one monitor over to the other monitor at the top of the screen so that it moves into full screen. It seems to move to that screen with the window resized but the contents not redrawn.

Focal with all updates as of 25-mar. Reproducible multiple times.

ProblemType: Crash
DistroRelease: Ubuntu 20.04
Package: gnome-calendar 3.36.0-1
ProcVersionSignature: Ubuntu 5.4.0-18.22-generic 5.4.24
Uname: Linux 5.4.0-18-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu21
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Mar 25 15:56:02 2020
ExecutablePath: /usr/bin/gnome-calendar
ProcCmdline: /usr/bin/gnome-calendar --gapplication-service
ProcEnviron:
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/bash
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f3696bd795d <gdk_rgba_to_string+13>: movsd 0x18(%rdi),%xmm0
 PC (0x7f3696bd795d) ok
 source "0x18(%rdi)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%xmm0" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-calendar
StacktraceTop:
 gdk_rgba_to_string () at /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
 ()
 ()
 () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new_valist () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-calendar crashed with SIGSEGV in gdk_rgba_to_string()
UpgradeStatus: Upgraded to focal on 2019-07-08 (261 days ago)
UserGroups: adm cdrom dip docker libvirt lpadmin lxd plugdev sambashare sbuild sudo wireshark
separator:

Trent Lloyd (lathiat) wrote :
information type: Private → Public

StacktraceTop:
 gdk_rgba_to_string () from /tmp/apport_sandbox_t8ek7h3c/usr/lib/x86_64-linux-gnu/libgdk-3.so.0
 update_color (self=0x5587392d9c10) at ../src/gui/gcal-event-widget.c:281
 gcal_event_widget_set_event_internal (event=0x0, self=0x5587392d9c10) at ../src/gui/gcal-event-widget.c:499
 gcal_event_widget_set_property (object=<optimized out>, property_id=4, value=0x7fff454b0180, pspec=<optimized out>) at ../src/gui/gcal-event-widget.c:802
 g_object_new_internal () from /tmp/apport_sandbox_t8ek7h3c/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0

Changed in gnome-calendar (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-calendar (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, upstream reports indicates it's fixed in 3.36.1 which is the version included in focal, closing but feel free to reopn if you still have the issue with that update

Changed in gnome-calendar (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers