gnome-calendar segfaults on invalid locations

Bug #1824699 reported by Oliver Ritter on 2019-04-14
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-calendar (Ubuntu)
Low
Unassigned

Bug Description

Hello,
my calendar does not start anymore. I have Ubuntu 18.10.

olli@T470:~/.local/share$ gnome-calendar

(gnome-calendar:8982): Pango-CRITICAL **: 14:08:31.426: pango_font_description_set_size: assertion 'size >= 0' failed

(gnome-calendar:8982): GcalWeatherSettings-WARNING **: 14:08:31.589: Unknown location 'dorsten' selected
Speicherzugriffsfehler (Speicherabzug geschrieben)

Does anybody have an idea how to solve this?
Thanks!

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-calendar (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Oliver Ritter (ziltoidium) wrote :

I found a solution:
i startet dconf editor and resetted everything in org/gnome/calendar/weather-settings.

Now calendar is starting again. There was something with this weather plugin.

Sebastien Bacher (seb128) wrote :

can you maybe figure out/try to remember what setting you had which created the issue?

John (behpo) wrote :

I have the same issue with gnome-calendar 3.28.2, installed as default in Linux Mint Cinnamon 19.1 (Ubuntu 18.04)

I was trying to find a location for the weather, it crashed, but saved the location I typed in (which is not compatible), preventing me to open gnome-calendar again

(gnome-calendar:2076): GcalWeatherSettings-WARNING **: 18:30:13.529: Unknown location 'Laguépie' selected
Segmentation fault (core dumped)

John (behpo) wrote :

*preventing me from opening

How do I edit a comment?

Sebastien Bacher (seb128) wrote :

@John, can you get a backtrace of the issue (https://wiki.ubuntu.com/Backtrace)?

John (behpo) wrote :

@Sebastien Bacher, I can't install debug symbols. There are no -dbg for gnome-calendar so I added the ppa for -dbgsym but it won't update

Ign :11 http://ddebs.ubuntu.com tessa InRelease
Ign :12 http://ddebs.ubuntu.com tessa-updates InRelease
Ign :13 http://ddebs.ubuntu.com tessa-proposed InRelease
Err :15 http://ddebs.ubuntu.com tessa Release
  404 Not Found [IP : 91.189.94.8 80]
Err :16 http://ddebs.ubuntu.com tessa-updates Release
  404 Not Found [IP : 91.189.94.8 80]
Err :17 http://ddebs.ubuntu.com tessa-proposed Release
  404 Not Found [IP : 91.189.94.8 80]
Lecture des listes de paquets... Fait

I can ping 91.189.94.8 normally; might it be because I use Linux Mint?

Oliver Ritter (ziltoidium) wrote :

I tried to add my hometown Dorsten to weather inside calendar again.
When i enter Dorsten (this is in germany), the search does not find or offer my city. When i press enter, this setting is set. I checked in dconf editor, there was the default value

org.gnome.calendar weather-settings (true, false, '', nothing)

And now there is the value

org.gnome.calendar weather-settings (true, false, 'Dorsten', nothing)

So calendar weather accepted my town Dorsten and now crashes after that.

When i enter for example Berlin, the search offers this city and calendar is fine. The problem is when cities are entered, that are not found in search

Dennis Baudys (thecondordb) wrote :

I can confirm this bug. Same problem here with Ubuntu 18.04.2 LTS (Kernel 4.18.0-18-generic #19~18.04.1-Ubuntu SMP). gnome-calendar crashes after entering a city in the calendar weather plugin for the first time:

(gnome-calendar:12200): GcalWeatherSettings-WARNING **: 11:22:20.176: Unknown location 'Düsseldorf' selected
Speicherzugriffsfehler (Speicherabzug geschrieben)

gnome-calendar:
  Installiert: 3.28.2-0ubuntu0.18.04.1

The above mentioned workaround by Oliver Ritter seems to work to get the calendar started again: I removed "Düsseldorf" from:

org.gnome.calendar weather-settings (true, false, 'Düsseldorf', nothing)

and voila. Just for fun I tried to enter a city name in the weather plugin of the calendar again. And this time the calendar crashed already when entering the german Umlaut "ü" (second letter in my city name "Düsseldorf").

Changed in gnome-calendar (Ubuntu):
status: Incomplete → New
Sebastien Bacher (seb128) wrote :

Indeed that's an issue with those locations, thanks for the details

Changed in gnome-calendar (Ubuntu):
status: New → In Progress
summary: - gnome-calendar pango critical
+ gnome-calendar segfaults on invalid locations
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers