Cannot import calendar from PagerDuty URL

Bug #1732496 reported by Domagoj Tršan on 2017-11-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Calendar
Expired
Medium
gnome-calendar (Ubuntu)
Low
Unassigned

Bug Description

I noticed I cannot import a calendar from PagerDuty (https://www.pagerduty.com).

When I try to add online calendar (Settings -> Add -> From Web) in "Add calendar" dialog, button "Add" stays disabled when I enter URL.
If I download the calendar and add it via "From file" method, everything works.

When I ran gnome-calendar with debug option (--debug) the following was logged to the console (I removed all sensitive information).

15:00:04.0161 GcalSourceDialog: DEBUG: Detected host: '<REMOVED>.pagerduty.com', path: '/<REMOVED>'
15:00:04.0162 GcalSourceDialog: DEBUG: Trying to connect without credentials...
15:00:04.0912 GcalSourceDialog: DEBUG: [source-dialog] error: Failed to get properties: HTTP error code 404 (Not Found): The server responded with an HTML page, which can mean there’s an error on the server or with the client request. The used URI was: https://<REMOVED>.pagerduty.com/<REMOVED>

Unfortunately, I cannot post PagerDuty URL here because it contains sensitive information.

I can normally download the calendar via curl. It does not require any credentials. I'm also importing it into Google Calendar without any issues. If I create a dummy calendar in Google Calendar and I try to import it via public URL everything works as expected. I'm having issues only with importing of the PagerDuty calendar.

I tried to sniff traffic with mitmproxy but I don't see any requests logged to mitmproxy of URLs I entered to "Add calendar" dialog. Is it possible that "Add calendar" dialog does not respect proxy configuration? I wanted to compare what's different in curl vs gnome-calendar request/response.

Any suggestions how to debug it?

Thanks!

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-calendar 3.26.2-1
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Nov 15 16:40:36 2017
InstallationDate: Installed on 2017-10-21 (25 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
SourcePackage: gnome-calendar
UpgradeStatus: No upgrade log present (probably fresh install)

Domagoj Tršan (domagoj.trsan) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Unsure about specific debugging tips but upstream (who writes the software) might have more clues if you want to report the bug to them as well on https://bugzilla.gnome.org/enter_bug.cgi?product=gnome-calendar

Changed in gnome-calendar (Ubuntu):
importance: Undecided → Low
Domagoj Tršan (domagoj.trsan) wrote :

The bug is submitted to Gnome Bugzilla: https://bugzilla.gnome.org/show_bug.cgi?id=790503

Thanks @Sebastien!

Sebastien Bacher (seb128) wrote :

Thanks for sending to GNOME

Changed in gnome-calendar (Ubuntu):
status: New → Triaged
Changed in gnome-calendar:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gnome-calendar:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.