Unable to schedule "PM" events in Gnome Calendar 3.20.2

Bug #1621539 reported by Sam Williams on 2016-09-08
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Calendar
Fix Released
Medium
gnome-calendar (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

Impact
======
Users who have their computer time set to 12-hour time (AM/PM) instead of 24-hour are unable to schedule PM events in gnome-calendar. 12-hour time is the default in the United States.

The update fixes this issue and a few more.

https://git.gnome.org/browse/gnome-calendar/tree/NEWS?h=gnome-3-20
https://git.gnome.org/browse/gnome-calendar/log/?h=gnome-3-20

Test Case
=========
1. Open the Calendar app.
2. Click on a date to schedule a new event. Click Edit Details.
3. Are you able to set an event that starts and ends in the afternoon?

Open the System Settings app. Click Time & Date. Switch time from 12-hour to 24-hour (or the opposite). Repeat steps 1-3.

4. Schedule a new event that starts on one day and ends on the next. Click the all-day box and hit Done.

The event should span both days on the calendar.

Regression Potential
====================
Low. This is a new upstream stable bugfix release and is recommended for all distros shipping GNOME 3.20.

The 3.20.3 release was insufficient and might have made things worse ( https://bugzilla.gnome.org/770679 ), but for 3.20.4 I helped identify the git commits already applied in the 3.21 series to fix this issue.

Original Bug Report
===================
The bug is 100% reproducible. I can schedule "AM" events and all day events, but no "PM" events. I would expect the part of to advance after I had passed noon, but I can keep cycling through the first 12 hours of the day.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-calendar 3.20.2-0ubuntu0.1
ProcVersionSignature: Ubuntu 4.4.0-36.55-generic 4.4.16
Uname: Linux 4.4.0-36-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Sep 8 10:56:05 2016
InstallationDate: Installed on 2013-04-26 (1231 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
SourcePackage: gnome-calendar
UpgradeStatus: Upgraded to xenial on 2016-04-02 (159 days ago)

Sam Williams (sam-williams) wrote :
Jeremy Bicha (jbicha) on 2016-09-08
Changed in gnome-calendar (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in gnome-calendar (Ubuntu Xenial):
importance: Undecided → High
status: New → Triaged
Changed in gnome-calendar:
importance: Unknown → Medium
status: Unknown → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you give some extra details?

- how do you add the event (using the menu, clicking on a day)
- what view mode do you use?
- do you get the issue in a guest session?

 I can't reproduce it using the en_US locale ...

Changed in gnome-calendar (Ubuntu):
status: Triaged → Incomplete
Sebastien Bacher (seb128) wrote :

what's the value of "gsettings get org.gnome.desktop.interface clock-format"? Could be https://bugzilla.gnome.org/show_bug.cgi?id=765370

Sam Williams (sam-williams) wrote :

Hey Sebastien! Thanks for looking into this problem.

When I run gsettings get org.gnome.desktop.interface clock-format I get:
'12h'

Hope that helps!

Sam Williams (sam-williams) wrote :

Sebastien I have some other information for you.

- how do you add the event (using the menu, clicking on a day)
I am adding the day directly from the Calendar interface. I click on a day and add it that way. It appears I see the same problem from the menu too.

- what view mode do you use?
Not sure what you mean by view mode, but the Calendar is display a Month at a time

- do you get the issue in a guest session?
I have tried the guest session and another account on the current machine and both work, but both are set to a 24h clock. They don't have the "AM/PM" indicator displayed.

Good Luck!

Jeremy Bicha (jbicha) on 2016-09-11
Changed in gnome-calendar (Ubuntu Xenial):
status: Triaged → In Progress
Jeremy Bicha (jbicha) on 2016-09-11
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-calendar - 3.20.3-0ubuntu1

---------------
gnome-calendar (3.20.3-0ubuntu1) yakkety; urgency=medium

  * New upstream bugfix release
  * Backport patches from 3.22 to fix multiple issues with scheduling
    PM events (LP: #1621539):
    - git_fix-12-hour-format.patch
    - git_fix-am-pm-logic.patch
    - git_set-time-format-unconditionally.patch
  * Drop debian/patches/use_gtk_318.patch:
    - Unneeded since Ubuntu 16.10 has GTK 3.20
  * debian/control.in:
    - Bump minimum GTK to 3.20

 -- Jeremy Bicha <email address hidden> Sun, 11 Sep 2016 17:28:56 -0400

Changed in gnome-calendar (Ubuntu):
status: Incomplete → Fix Released
Jeremy Bicha (jbicha) on 2016-09-14
description: updated

Hello Sam, or anyone else affected,

Accepted gnome-calendar into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-calendar/3.20.4-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-calendar (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in gnome-calendar:
status: Confirmed → Fix Released
Sam Williams (sam-williams) wrote :

Hey Jeremy and Chris!

Just download and checked your Gnome calendar fix and it now works as I would expect. Before I wasn't seeing an "AM/PM" indicator and just assumed it would change as you advanced time. Now I see it and have the ability to use it without issue.

I also have the ability to created a calendar entry that spans multiple days, but starting and ending at a particular time.

I just noticed one thing that I missed before. It may not have been included in this version of the calendar application. I don't see the ability to set a repeating or recurring event. So for now it looks like I would need to go and manually set the recurrence.

Otherwise you definitely fixed the problem that was causing me issues. Thanks for all your work and effort.

All the best!
Sam Williams

Jeremy Bicha (jbicha) wrote :

Sam, thanks for your feedback. I'm going to go ahead and mark this bugfix as verified.

gnome-calendar does not support creating recurring events but you can use evolution to do that. Since evolution and gnome-calendar support the same backend, you'll see the repeated events in gnome-calendar. I opened bug 1623675 for adding that feature to gnome-calendar directly.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-calendar - 3.20.4-0ubuntu0.1

---------------
gnome-calendar (3.20.4-0ubuntu0.1) xenial; urgency=medium

  [ Jeremy Bicha ]
  * New upstream bugfix release (LP: #1621539)
    - Fixes multiple issues with scheduling PM events
    - Include the final day in all-day multi-day events

  [ Iain Lane ]
  * debian/patches/0001-Hide-GOA-sources-on-Unity.patch:
    correctly en/disable GNOME Online Accounts based on XDG_CURRENT_DESKTOP

 -- Jeremy Bicha <email address hidden> Wed, 14 Sep 2016 11:56:41 -0400

Changed in gnome-calendar (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-calendar has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Alan Van Art (alanv73) wrote :

This is still broken as of 3.20.4. I am linked to Google Calendars and seeing 24hr format regardless of time format setting.

Jeremy Bicha (jbicha) wrote :

Alan, please open a new bug. You can run this command to include useful information for the bug triagers:

ubuntu-bug gnome-calendar

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.