Gnome Calendar has white corners

Bug #1565267 reported by motang on 2016-04-02
104
This bug affects 20 people
Affects Status Importance Assigned to Milestone
GNOME Calendar
Fix Released
Medium
Ubuntu theme
Undecided
Unassigned
gnome-calendar (Ubuntu)
Low
Unassigned
Xenial
Low
Unassigned

Bug Description

* Impact

the gnome-calendar window corners don't look right (white squares instead of rounded)

* Test case
start gnome-calendar under unity and look at the windows corner, they should be rounded. The update also include a bugfix new revesion so make sure calendar events are correctly listed and that the calendar works correctly

* Regression potential
the update has only small bugfixes and should be safe but keep an eye for new issues

------

Gnome Calendar still looks like it is not using the proper CSD that other Gnome apps do (maps, weather, etc.) nor does it look like a patched Unity app.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: gnome-calendar 3.19.92-0ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-17.33-generic 4.4.6
Uname: Linux 4.4.0-17-generic x86_64
ApportVersion: 2.20.1-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Apr 2 07:12:41 2016
InstallationDate: Installed on 2016-03-27 (6 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-calendar
UpgradeStatus: No upgrade log present (probably fresh install)

motang (mohan-ram) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-calendar (Ubuntu):
status: New → Confirmed

Please:

1. Include a screen-shot of the bug.
2. Set this bug status back to confirmed.

Thank you.

Changed in gnome-calendar (Ubuntu):
status: Confirmed → Incomplete
motang (mohan-ram) wrote :

Attached a screenshot.

Xavier L. (xav0989) wrote :

Screenshot was uploaded

Changed in gnome-calendar (Ubuntu):
status: Incomplete → Confirmed
Changed in gnome-calendar (Ubuntu):
importance: Undecided → Medium
summary: - Gnome Calendar does not use Light theme title bar
+ Gnome Calendar does not use Unity decorations

This should be fixed in Xenial. An LTS should look more polished!

Will Cooke (willcooke) wrote :

White corners are, I think, because g-cal has it's own CSS file "gtk-styles.css". Line 5 of this file sets .views to have a background colour of @theme_base_color.

Our CSS tries to override this on the GcalWindow object and set the colour to transparent. I think this is being over-ridden in turn by the hard-coded (?) gtk-styles.css. Setting our override CSS to GcalWindow.views is not effective.

In gcal-applicaiton.c:

#define CSS_FILE "resource:///org/gnome/calendar/gtk-styles.css"

Khurshid Alam (khurshid-alam) wrote :

Why are we using CSD at all? With gtk3-nocsd (https://github.com/PCMan/gtk3-nocsd) it works quite well. Screenshot: http://i.imgur.com/bb4EfOU.png

Why should disable headerbar under unity and patch menubar just like we do for gedit and other apps.

Will Cooke (willcooke) wrote :

Applying this patch to gtk-styles.css in gnome-calendar and then adding the corresponding patch to the theme "fixes" the issue.

Will Cooke (willcooke) wrote :

Removing the .views CSS from the gtk-styles.css in Calendar and moving it to our Ubuntu theme's calendar.css. This needs to be applied in conjunction with the patch to gnome-calendar's gtk-styles.css

Changed in gnome-calendar:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-calendar:
status: New → Fix Released
Amr Ibrahim (amribrahim1987) wrote :

Fixed in gnome-calendar 3.20.2.

Changed in gnome-calendar (Ubuntu):
status: Confirmed → Fix Committed
summary: - Gnome Calendar does not use Unity decorations
+ Gnome Calendar has white corners
description: updated
Amr Ibrahim (amribrahim1987) wrote :

The yakkety changelog has a wrong LP bug number,

gnome-calendar (3.20.2-0ubuntu1) yakkety; urgency=medium

  * New upstream version
    - Use the theme's CSS instead of our custom one (lp: #565267)

It should be 1565267.

Amr Ibrahim (amribrahim1987) wrote :

The changelog missed Bug #1573636. It is fixed in 3.20.2.

Leopoldo Pena (leopenausa) wrote :

Bug still present in Xenial. 3.20.1 is the default installation in the LTS.

Sebastien Bacher (seb128) wrote :
Changed in gnome-calendar (Ubuntu Xenial):
importance: Undecided → High
status: New → In Progress
importance: High → Low
Changed in gnome-calendar (Ubuntu):
importance: Medium → Low
status: Fix Committed → Fix Released

Hello motang, or anyone else affected,

Accepted gnome-calendar into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-calendar/3.20.2-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-calendar (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed

Actually I'm not sure if it should be marked as verification-done.

That's because as far as I can see it only resolves the problem for Ubuntu default themes Ambiance and Radiance all the other 3rd party themes still render incorrectly. Even Adwaita the default GNOME theme renders incorrectly.

Sebastien Bacher (seb128) wrote :

Well, no plan to block something which is better just because it's not perfect. We can do another update to fix remaining issues later

motang (mohan-ram) wrote :

I have been testing it on one of my install that pre-release updates enabled and so far it has been good.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-calendar - 3.20.2-0ubuntu0.1

---------------
gnome-calendar (3.20.2-0ubuntu0.1) xenial; urgency=medium

  * New upstream version
    - Use the theme's CSS instead of our custom one (lp: #1565267)
  * debian/patches/use_gtk_318.patch:
    - refreshed for the new version
  * debian/patches/dont_require_schemas.patch:
    - restore upstream commit which was reverted to not depends
      on a schemas that doesn't exist under Unity

 -- Sebastien Bacher <email address hidden> Thu, 12 May 2016 09:18:36 +0200

Changed in gnome-calendar (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-calendar has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.