gnome-calendar crashed with SIGSEGV in g_type_check_instance_cast()

Bug #1551406 reported by Dirk Eickhoff on 2016-02-29
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
GNOME Calendar
Fix Released
Unknown
gnome-calendar (Ubuntu)
Medium
Unassigned

Bug Description

Calendar crashes when I try to take a Ical calendar in.

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: gnome-calendar 3.18.2.1-2
ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
Uname: Linux 4.4.0-8-generic x86_64
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Feb 29 20:49:54 2016
ExecutablePath: /usr/bin/gnome-calendar
InstallationDate: Installed on 2016-02-29 (0 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160228)
ProcCmdline: /usr/bin/gnome-calendar --gapplication-service
ProcEnviron:
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/bash
 LANGUAGE=de_DE
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f00cb89d8f0 <g_type_check_instance_cast+32>: mov (%r10),%rbp
 PC (0x7f00cb89d8f0) ok
 source "(%r10)" (0x00000410) not located in a known VMA region (needed readable region)!
 destination "%rbp" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-calendar
StacktraceTop:
 g_type_check_instance_cast () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? ()
 ffi_call_unix64 () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 ffi_call () from /usr/lib/x86_64-linux-gnu/libffi.so.6
 g_cclosure_marshal_generic () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-calendar crashed with SIGSEGV in g_type_check_instance_cast()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Dirk Eickhoff (eickhoff-dirk) wrote :

StacktraceTop:
 g_type_check_instance_cast () from /tmp/apport_sandbox_60dy6K/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 GCAL_SOURCE_DIALOG (ptr=0xd63c00) at gcal-source-dialog.h:36
 add_source (manager=<optimized out>, source=0x7f00a80628a0, enabled=<optimized out>, user_data=0xd63c00) at gcal-source-dialog.c:283
 ffi_call_unix64 () from /tmp/apport_sandbox_60dy6K/usr/lib/x86_64-linux-gnu/libffi.so.6
 ffi_call () from /tmp/apport_sandbox_60dy6K/usr/lib/x86_64-linux-gnu/libffi.so.6

Changed in gnome-calendar (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
tags: added: bionic
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-calendar (Ubuntu):
status: New → Confirmed
information type: Private → Public
Sebastien Bacher (seb128) wrote :
Changed in gnome-calendar (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-calendar:
status: Unknown → New
Changed in gnome-calendar:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.