gcalctool window is not resizable

Bug #647466 reported by waspinator on 2010-09-25
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
GNOME Calculator
Invalid
Medium
gnome-calculator (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gcalctool

The main window of gcalctool 5.31.91 is not resizable. This makes it very difficult to press the buttons if using a touch screen, as they are very small.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gcalctool 5.31.91-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic-pae 2.6.35.4
Uname: Linux 2.6.35-22-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sat Sep 25 08:09:15 2010
ExecutablePath: /usr/bin/gcalctool
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
ProcEnviron:
 LANG=en_CA.utf8
 SHELL=/bin/bash
SourcePackage: gcalctool
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1842): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1821): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (process:2091): Gtk-CRITICAL **: set_table: assertion `buffer->tag_table == NULL' failed
 (process:2145): Gtk-CRITICAL **: set_table: assertion `buffer->tag_table == NULL' failed
 (process:2156): Gtk-CRITICAL **: set_table: assertion `buffer->tag_table == NULL' failed

waspinator (patrickwasp) wrote :
summary: - window is not resizable
+ gcalctool window is not resizable
bbordwell (benbordwell) on 2010-09-25
Changed in gcalctool (Ubuntu):
status: New → Confirmed
status: Confirmed → Triaged
importance: Undecided → Low
Changed in gcalctool:
importance: Unknown → Medium
status: Unknown → New
Robert Ancell (robert-ancell) wrote :

Thanks for the bug report, could you describe more how you use gcalctool in a touchscreen mode?

The buttons are the same size as in any other application, though I suspect the number of buttons makes in hard in a touchscreen environment. There were a number of issues with them being resizable (i.e. changing between modes and keeping them consistent).

Did you make gcalctool slightly larger or use it fullscreen when using touch?

One thing I have been considering is if there should be a "large button" mode (like the large button calculators that you can buy). This would probably only work in basic mode though as the other modes would be too big.

Changed in gcalctool (Ubuntu):
status: Triaged → Incomplete
waspinator (patrickwasp) wrote :

When I'm using the calculator on my touchscreen I maximize it. It doesn't look pretty, but at least it's easy to press the buttons. I like your idea of having a "large button" mode. Maybe it could be renamed to "touch" mode though. All applications should start preparing for being used with touch, since it's the direction we seem to be going in.

For illustration purposes here is the difference in button sizes of the 2 versions.
http://imgur.com/t5RTq.png

bbordwell (benbordwell) wrote :

Returning to triaged since the requested information has been provided.

Also I marked bug 665328 as a duplicate of this one, another use case for having the window be re-sizable is to allow long operations to fit on the screen (see attached screenshot in dup report).

Changed in gcalctool (Ubuntu):
status: Incomplete → Triaged
Bob (bbrazie) wrote :

Maybe this is a duplicate of this one and not the other way around?

Ubuntu 10.10 using gcalctool 5.30.0.

Is it possible to roll back to version 5.28.2 from version 5.32.0?

I need to be able to resize the window as adding or subtracting many entry's the entry's get lost from sight so it is impossible to check before totalling in version 5.30.0. They just get lost from view.

Any ideas?

Thanks in advance, Bob.

tags: added: amd64

Yes, as a workaround for this issue, you can downgrade to 5.28.2. Lucid Lynx provides a package for that version, which can be installed in Maverick. These instructions assume you're using the Ubuntu Software Center.

First, uninstall the current package version. In the Ubuntu Software Center, search for "gcalctool". One result, called "Calculator", will come up. Click Remove. Assume you're using regular Ubuntu (rather than Kubuntu, Xubuntu, etc.), you will be asked to uninstall the ubuntu-desktop package. You must click "Remove Anyway" to uninstall gcalctool (since gcalctool is a dependency of ubuntu-desktop). In the future, when the latest version of gcalctool again meets your needs, you should reinstall ubuntu-desktop.

Once the removal operation completes, get this package if your architecture is i386:
https://launchpad.net/ubuntu/+archive/primary/+files/gcalctool_5.30.0.is.5.28.2-0ubuntu2_i386.deb

Or this package if your architecture is amd64:
https://launchpad.net/ubuntu/+archive/primary/+files/gcalctool_5.30.0.is.5.28.2-0ubuntu2_amd64.deb

(These links can be found manually, if you wish, by going to https://launchpad.net/ubuntu/+source/gcalctool and expanding "5.30.0.is.5.28.2-0ubuntu2" under "The Lucid Lynx (supported)".)

Open it in the Ubuntu Software Center. It will say "Please install 'Gcalctool' via your normal software channels. Only install this file if you trust the origin." Click Install.

Gcalctool 5.28.2 is now installed. Note that you can reinstall ubuntu-desktop now if you wish (since the gcalctool package you just installed fulfills the dependency). Doing so would ensure that you are automatically presented with new packages that become part of the Ubuntu Desktop system (which is the behavior of a properly functioning Ubuntu system). However, you would also be automatically presented with the current version of gcalctool, so you'd have to unselect it every time you do an update, or you'd end up going back to the newer version that does not meet your needs.

thanks for this assistance.

On 13/01/11 07:39, Eliah Kagan wrote:
> Yes, as a workaround for this issue, you can downgrade to 5.28.2. Lucid
> Lynx provides a package for that version, which can be installed in
> Maverick. These instructions assume you're using the Ubuntu Software
> Center.
>
> First, uninstall the current package version. In the Ubuntu Software
> Center, search for "gcalctool". One result, called "Calculator", will
> come up. Click Remove. Assume you're using regular Ubuntu (rather than
> Kubuntu, Xubuntu, etc.), you will be asked to uninstall the ubuntu-
> desktop package. You must click "Remove Anyway" to uninstall gcalctool
> (since gcalctool is a dependency of ubuntu-desktop). In the future, when
> the latest version of gcalctool again meets your needs, you should
> reinstall ubuntu-desktop.
>
> Once the removal operation completes, get this package if your architecture is i386:
> https://launchpad.net/ubuntu/+archive/primary/+files/gcalctool_5.30.0.is.5.28.2-0ubuntu2_i386.deb
>
> Or this package if your architecture is amd64:
> https://launchpad.net/ubuntu/+archive/primary/+files/gcalctool_5.30.0.is.5.28.2-0ubuntu2_amd64.deb
>
> (These links can be found manually, if you wish, by going to
> https://launchpad.net/ubuntu/+source/gcalctool and expanding
> "5.30.0.is.5.28.2-0ubuntu2" under "The Lucid Lynx (supported)".)
>
> Open it in the Ubuntu Software Center. It will say "Please install
> 'Gcalctool' via your normal software channels. Only install this file if
> you trust the origin." Click Install.
>
> Gcalctool 5.28.2 is now installed. Note that you can reinstall ubuntu-
> desktop now if you wish (since the gcalctool package you just installed
> fulfills the dependency). Doing so would ensure that you are
> automatically presented with new packages that become part of the Ubuntu
> Desktop system (which is the behavior of a properly functioning Ubuntu
> system). However, you would also be automatically presented with the
> current version of gcalctool, so you'd have to unselect it every time
> you do an update, or you'd end up going back to the newer version that
> does not meet your needs.
>

Dave (dv1) wrote :

I've upgraded to maverick, and that for the above reasons, and also because the old version of gcalctool reads from the numeric keypad without you having to have numlock on, have downgraded to the lucid version as described above.

For anyone else who has done (or is doing this) I've found that, after installation, running

echo "gcalctool hold" | dpkg --set-selections

as root solves the problem of automatic updates trying to re-'upgrade' it back to the more modern, but less functional version.

Changed in gcalctool:
status: New → Confirmed
Adolfo Jayme (fitojb) on 2013-04-08
affects: gcalctool → gnome-calculator
affects: gcalctool (Ubuntu) → gnome-calculator (Ubuntu)
dino99 (9d9) on 2013-05-29
tags: added: lucid raring
removed: maverick
Grzegorz G. (grzesiek1e5) wrote :

It is marked as solved in the Gnome Bugzilla. Can someone verify that and mark as fix released or fix committed?

tags: added: maverick
removed: amd64 lucid raring
Changed in gnome-calculator:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.