Calculator (snap) is slow to start on a freshly installed Cosmic machine

Bug #1794951 reported by Will Cooke on 2018-09-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-calculator (Ubuntu)
High
Ken VanDine
Cosmic
High
Ken VanDine

Bug Description

Steps to reproduce:

 * Install a Cosmic machine in a VM (note, you might need to set nomodeset while the bugs are being worked out)
 * Log in
 * Start GNOME Calculator
 * Note the long start up time (circa 20 seconds)

I expect this is the same for all the other snaps that are preinstalled.

Will Cooke (willcooke) on 2018-09-28
Changed in gnome-calculator (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Ken VanDine (ken-vandine)
tags: added: rls-cc-tracking
Will Cooke (willcooke) on 2018-10-02
tags: removed: rls-cc-tracking
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1794951

tags: added: iso-testing
Will Cooke (willcooke) wrote :

Latest platform snap fixed this in my testing.

Didier Roche (didrocks) wrote :

I tried with gnome-3-26-1604 rev 74 is still slow fo me at first gnome-calculator application startup (with no ~/snap)

Ken VanDine (ken-vandine) wrote :

@willcooke just tested again and confirmed it launches in about 2 seconds with rev 74. It should be more like 25 seconds with the fontconfig cache misses. I suspect @didrocks' issue is unrelated as he was seeing more like 10 seconds. Perhaps just slower disk access under qemu.

Changed in gnome-calculator (Ubuntu Cosmic):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers