[SRU] 3.22.0 wont allow cut&paste in history pane

Bug #1633408 reported by bojam on 2016-10-14
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Calculator
Fix Released
Medium
gnome-calculator (Ubuntu)
Low
Unassigned
Yakkety
Low
FanJun Kong - ( BH1SCW )

Bug Description

Impact
======
This update includes the new upstream bugfix 3.22.1 and 3.22.2 releases.

https://git.gnome.org/browse/gnome-calculator/tree/NEWS?h=gnome-3-22
https://git.gnome.org/browse/gnome-calculator/log?h=gnome-3-22

Overview of changes in gnome-calculator 3.22.2:

Fix reusing results from the history stack #766155
Ctrl+Backspace should deletes only last number, not everything (bgo#725114)
Fixed possible errors on currency conversion (bgo#750672)
Fixed first expression with parentheses (bgo#700617)
Fixed conversion unit switch, fixes #748732.

Test Case
=========
*Fix reusing results from the history stack #766155
 - A click on the equation would replace the current expression
 - A click on the result would append it to the current expression
* Ctrl+Backspace should deletes only last number, not everything (bgo#725114)
 - input some expression, press Ctrl+Backspace it will delete last number instead of clear everything.
* Fixed possible errors on currency conversion (bgo#750672)
 - gnome-calculator --solve '1500 EUR in USD' you will get just result, no more spamming stderr
* Fixed first expression with parentheses (bgo#700617)
 - 3(7) you will get result: 21
* Fixed conversion unit switch, fixes #748732
 - Be in Financial mode, choose "Botswana Pula" on the left side and "Algerian Dinar" on the right side
2. Type 1
3. Click Switch conversation units
the displayed number will change correctly as long as the currencies switched

Regression Potential
====================
The uploads are happening under the GNOME Micro Release Exception.

Paul White (paulw2u) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:

apport-collect 1633408

Please then change the bug status back to "New"

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in gnome-calculator (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected yakkety
description: updated

apport information

bojam (tlunn) wrote : ProcEnviron.txt

apport information

Changed in gnome-calculator (Ubuntu):
status: Incomplete → New

Incidentally I recompiled the 3.22.0 from source and the bug was still there.

I also saw a bug in the conversions in that kg->pounds is not possible as pounds was not available on right hand side. This bug disappeared in my recompiled 3.22 and also after downloading a few dev libs the original Ubuntu 16.10 version also started working.

Jeremy Bicha (jbicha) wrote :

The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-calculator (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2016-10-25
Changed in gnome-calculator (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
tags: added: regression-release
Changed in gnome-calculator:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gnome-calculator:
status: Confirmed → Fix Released
Changed in gnome-calculator (Ubuntu):
status: Triaged → Fix Committed
Jeremy Bicha (jbicha) on 2016-12-10
Changed in gnome-calculator (Ubuntu Yakkety):
status: New → In Progress
importance: Undecided → Low
Jeremy Bicha (jbicha) on 2016-12-10
Changed in gnome-calculator (Ubuntu Yakkety):
status: In Progress → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-calculator - 1:3.22.2-1ubuntu1

---------------
gnome-calculator (1:3.22.2-1ubuntu1) zesty; urgency=medium

  * Merge with Debian (LP: #1648992, LP: #1633408). Remaining changes:
    - Add epoch
    - debian/patches/git_no_headerbars_in_unity.patch:
      + Don't use HeaderBars in Unity

gnome-calculator (3.22.2-1) unstable; urgency=medium

  * New upstream release.

gnome-calculator (3.22.1-1) unstable; urgency=medium

  * New upstream release.

 -- Jeremy Bicha <email address hidden> Sat, 10 Dec 2016 12:44:22 -0500

Changed in gnome-calculator (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-calculator (Ubuntu Yakkety):
assignee: nobody → FanJun Kong - ( BH1SCW ) (fjkong)

same with lp:#1648992

here is the branch that need sponsor:

 * Yakkety: master branch

https://code.launchpad.net/~fjkong/+git/gnome-calculator

summary: - 3.22.0 wont allow cut&paste in history pane
+ [SRU] 3.22.0 wont allow cut&paste in history pane
description: updated
Iain Lane (laney) wrote :

Uploaded, thanks!

Brian Murray (brian-murray) wrote :

Given that this particular bug is about fixing a crash, the SRU team would like to have Test Case to confirm that the bug is in fact fixed. Could you please add one?

Changed in gnome-calculator (Ubuntu Yakkety):
status: Triaged → Incomplete

Test Case updated

description: updated
Changed in gnome-calculator (Ubuntu Yakkety):
status: Incomplete → In Progress

Hello bojam, or anyone else affected,

Accepted gnome-calculator into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-calculator/1:3.22.2-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-calculator (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Jeremy Bicha (jbicha) wrote :

I verified the test cases on yakkety-proposed.

By the way, this update also fixes bug 1566513.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-calculator - 1:3.22.2-1ubuntu0.1

---------------
gnome-calculator (1:3.22.2-1ubuntu0.1) yakkety; urgency=medium

  * New upstream release.
  * Merge with Debian (LP: #1648992, LP: #1633408). Remaining changes:
    - Add epoch
    - debian/patches/git_no_headerbars_in_unity.patch:
      + Don't use HeaderBars in Unity

 -- FJKong <email address hidden> Wed, 04 Jan 2017 01:29:43 +0800

Changed in gnome-calculator (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-calculator has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

bojam (tlunn) wrote :

Thanks I can confirm the fix is now live in my ubuntu 16.10 ... and the calculator does what it used to do.
Thanks Toby

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.