Theming issues with yakkety gnome-calculator in Unity

Bug #1615408 reported by Jeremy Bicha on 2016-08-21
48
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-calculator (Ubuntu)
Low
Unassigned
Yakkety
Low
Unassigned

Bug Description

There are some UI problems with yakkety's gnome-calculator. I'm attaching a screenshot taken with yesterday's daily live Ubuntu image.

1. The title bar says 'gnome-calculator' but it should say Calculator
2. The Mode menu has an ugly light-colored border around it instead of being integrated into either the title bar (like gnome-calculator 3.18.3 in Ubuntu 16.04 LTS) or in to Unity's menu bar. This happens when gnome-calculator is run from a terminal instead of from the Unity Dash.

These issues affect both gnome-calculator 1:3.20.1-0ubuntu1 and 1:3.21.90-0ubuntu1 but do not affect 1:3.18.3-0ubuntu1 on yakkety.

I think this was caused by the refresh of debian/patches/git_no_headerbars_in_unity.patch in the 3.20 update.

Screenshots attached.

Jeremy Bicha (jbicha) wrote :
tags: added: yakkety
Jeremy Bicha (jbicha) on 2016-08-21
description: updated
David R. Hedges (p14nd4) wrote :

I have these two problems on two machines as well (both after upgrading to 16.10). One machine exhibits *just* the two symptoms you describe, while another also has an odd bug making the numeric/formula entry text box transparent (see attached).

Interestingly (/frustratingly, confusingly), the menu and transparency issues are not present when running a guest session on that machine, but the menu remains an issue in the guest session on the other machine.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-calculator (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Hmm, I don't have the extra Mode menu when I run gnome-calculator from the Unity Dash but I do see it when I run gnome-calculator from a terminal.

David R. Hedges (p14nd4) wrote :

I can confirm the menu behaves as expected when launching from Unity Dash. Launching gnome-calculator from a terminal or from the 'calculator' key on my keyboard exhibits the displaced menu symptom.

Jeremy Bicha (jbicha) on 2016-10-27
description: updated
SilvioBandeira (silviobandeira) wrote :

In my machines (3) the same bug occurs and it doesn't matter if I use calculator key or Unity Dash. It happens either way.

Jeremy Bicha (jbicha) on 2017-02-06
description: updated
Jeremy Bicha (jbicha) wrote :

Actually, I'm no longer able to duplicate part 2 of this bug at all on Ubuntu 16.10 or 17.04 Alpha. The only bug I still see is the 'gnome-calculator' in the titlebar instead of 'Calculator'.

Same for me on Ubuntu 16.10.

Everything is working fine except for the wrong title that says
"gnome-calculator".

Robert

On Mon, Feb 6, 2017 at 2:59 PM Jeremy Bicha <email address hidden> wrote:

> Actually, I'm no longer able to duplicate part 2 of this bug at all on
> Ubuntu 16.10 or 17.04 Alpha. The only bug I still see is the 'gnome-
> calculator' in the titlebar instead of 'Calculator'.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1658664).
> https://bugs.launchpad.net/bugs/1615408
>
> Title:
> Theming issues with yakkety gnome-calculator in Unity
>
> Status in gnome-calculator package in Ubuntu:
> Confirmed
>
> Bug description:
> There are some UI problems with yakkety's gnome-calculator. I'm
> attaching a screenshot taken with yesterday's daily live Ubuntu image.
>
> 1. The title bar says 'gnome-calculator' but it should say Calculator
> 2. The Mode menu has an ugly light-colored border around it instead of
> being integrated into either the title bar (like gnome-calculator 3.18.3 in
> Ubuntu 16.04 LTS) or in to Unity's menu bar. This happens when
> gnome-calculator is run from a terminal instead of from the Unity Dash.
>
> These issues affect both gnome-calculator 1:3.20.1-0ubuntu1 and
> 1:3.21.90-0ubuntu1 but do not affect 1:3.18.3-0ubuntu1 on yakkety.
>
> I think this was caused by the refresh of
> debian/patches/git_no_headerbars_in_unity.patch in the 3.20 update.
>
> Screenshots attached.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-calculator/+bug/1615408/+subscriptions
>

Jeremy Bicha (jbicha) wrote :

The titlebar is correct in gnome-calculator 3.23.4 in Unity.

Changed in gnome-calculator (Ubuntu Yakkety):
importance: Undecided → Low
status: New → Triaged
Changed in gnome-calculator (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Committed

Is the numeric/formula entry text box transparent in 3.23.4 (as showed in picture by David Hedges) ?

Jeremy Bicha (jbicha) wrote :

Silvio, I haven't been able to reproduce the transparent bug. Could you please file a different bug for that issue? I'm going to focus this bug on just the wrong app name in the titlebar on Unity.

On the new bug, please indicate what graphics drivers you are using.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-calculator - 1:3.23.4-0ubuntu1

---------------
gnome-calculator (1:3.23.4-0ubuntu1) zesty; urgency=medium

  * New upstream release.
    - Complex numbers are handled more accurately using mpc (LP: #1566513)
    - Titlebar now displays correct app name in Unity (LP: #1615408)
  * debian/control.in:
    - Build-depend on libmpc-dev
    - Bump minimum libgtk-3-dev
  * Refreshed git_no_headerbars_in_unity.patch
  * Add git_fix_ans_value_in_popup.patch:
    - Display 'ans' value correctly in variable list

 -- Jeremy Bicha <email address hidden> Mon, 06 Feb 2017 14:41:00 -0500

Changed in gnome-calculator (Ubuntu):
status: Fix Committed → Fix Released
Or Schiro (orschiro) wrote :

Will this be backported to Ubuntu 16.10?

On Mon, Feb 6, 2017 at 10:54 PM Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package gnome-calculator - 1:3.23.4-0ubuntu1
>
> ---------------
> gnome-calculator (1:3.23.4-0ubuntu1) zesty; urgency=medium
>
> * New upstream release.
> - Complex numbers are handled more accurately using mpc (LP: #1566513)
> - Titlebar now displays correct app name in Unity (LP: #1615408)
> * debian/control.in:
> - Build-depend on libmpc-dev
> - Bump minimum libgtk-3-dev
> * Refreshed git_no_headerbars_in_unity.patch
> * Add git_fix_ans_value_in_popup.patch:
> - Display 'ans' value correctly in variable list
>
> -- Jeremy Bicha <email address hidden> Mon, 06 Feb 2017 14:41:00 -0500
>
> ** Changed in: gnome-calculator (Ubuntu)
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1658664).
> https://bugs.launchpad.net/bugs/1615408
>
> Title:
> Theming issues with yakkety gnome-calculator in Unity
>
> Status in gnome-calculator package in Ubuntu:
> Fix Released
> Status in gnome-calculator source package in Yakkety:
> Triaged
>
> Bug description:
> There are some UI problems with yakkety's gnome-calculator. I'm
> attaching a screenshot taken with yesterday's daily live Ubuntu image.
>
> 1. The title bar says 'gnome-calculator' but it should say Calculator
> 2. The Mode menu has an ugly light-colored border around it instead of
> being integrated into either the title bar (like gnome-calculator 3.18.3 in
> Ubuntu 16.04 LTS) or in to Unity's menu bar. This happens when
> gnome-calculator is run from a terminal instead of from the Unity Dash.
>
> These issues affect both gnome-calculator 1:3.20.1-0ubuntu1 and
> 1:3.21.90-0ubuntu1 but do not affect 1:3.18.3-0ubuntu1 on yakkety.
>
> I think this was caused by the refresh of
> debian/patches/git_no_headerbars_in_unity.patch in the 3.20 update.
>
> Screenshots attached.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-calculator/+bug/1615408/+subscriptions
>

Jeremy Bicha (jbicha) wrote :

> Will this be backported to Ubuntu 16.10?

I think the fix for 17.04 Alpha was accidental when the .desktop was renamed. That change is not suitable for a Stable Release Update so a more minimal fix will have to be identified first.

https://bugzilla.gnome.org/778228 might be related.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers