Ubuntu

Unable to browse bluetooth device: Connection refused (111)

Reported by Rafael Belmonte on 2011-11-17
118
This bug affects 24 people
Affects Status Importance Assigned to Milestone
GNOME Bluetooth
New
Medium
blueman (Ubuntu)
Medium
Unassigned
gnome-bluetooth (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu 11.10, fresh install.
When I try to browse a mobile phone via Bluetooth, I see this error: "Connection refused (111)", and the device cannot be browsed.
I think the same error happened when I tried in Xubuntu (XFCE with blueman).
But Bluetooth works very well in Kubuntu (KDE with Bluedevil) where I can browse, send and receive files from the mobile phone via Bluetooth, therefore something regarding bluetooth is broken in distributions based on Gnome/Gtk.

Please try to work in this issue in Ubuntu, because nowadays there is a lot of devices using Bluetooth: mobile phones, earphones, laptop mouse, etc.

Rafael Belmonte (eaglescreen) wrote :

The only idea I have is that gnome-bluetooth and blueman may be using the wrong channel to connect with the device. How do they know about the right channel to use?
If I mount my device filesystem with obexfs, I need to manually set the channel 10.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in blueman (Ubuntu):
status: New → Confirmed
Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Changed in gnome-bluetooth (Ubuntu):
importance: Undecided → Low
Rafael Belmonte (eaglescreen) wrote :

Having a working Bluetooth in 12.04 LTS is a low priority feature?

tags: added: bluetooth gnome3 oneiric precise regresion
summary: - Unable to browse bluetooh device: Connection refused (111)
+ Unable to browse bluetooth device: Connection refused (111)
Omer Akram (om26er) wrote :

I have the very same issue. I can't even send a file/

Changed in blueman (Ubuntu):
importance: Undecided → Medium
Changed in gnome-bluetooth (Ubuntu):
importance: Low → Medium

I've seen this problem with two different phones (one BlackBerry, one Bluetooth). It worked in 11.10, and works if I boot the system to Knoppix (proving it's not a new hw issue), but doesn't work at all in 12.04.

^* "one BlackBerry, one Android"

Changed in gnome-bluetooth:
importance: Unknown → Medium
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.