Graphical glitch in Bluetooth applet on "Browse files on device" window

Bug #875370 reported by soundconjurer on 2011-10-15
78
This bug affects 18 people
Affects Status Importance Assigned to Milestone
gnome-bluetooth (Ubuntu)
Low
Unassigned

Bug Description

Graphical bug in the "Select device to browse" window when selecting the "Browse files on device" option from the bluetooth applet menu. The space displaying the devices connected to the computer is too small in height thus preventing from reading and selecting a device. See screenshot in comment #11.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-bluetooth 3.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Sat Oct 15 19:10:34 2011
ExecutablePath: /usr/bin/bluetooth-applet
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: gnome-bluetooth
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed

It is not a duplicated bug. Essentially I get the same problem with my Nokia phone and Bluetooth (Lenovo T400 laptop). Worked like a charm with 10.04, 10.10, 11.04, then I did the upgrade to 11.10 and while I *can* send/receive files from either my laptop or the phone (bi-directional) I *cannot* browse the device. After the second attempt, entire Bluetooth applet crashes on Unity and to re-open it I have to restart the computer.

Log maybe useful to you guys.

This is what is giving me while pairing my mobile phone:
Oct 28 09:23:26 simone-ThinkPad-T400 bluetoothd[1266]: Discovery session 0x22902cd8 with :1.121 activated
Oct 28 09:23:34 simone-ThinkPad-T400 bluetoothd[1266]: Stopping discovery
Oct 28 09:23:47 simone-ThinkPad-T400 bluetoothd[1266]: input-headset driver probe failed for device 00:1C:35:AA:A7:5F

And this is what happen when I try to browse:
Oct 28 10:24:40 simone-ThinkPad-T400 obex-data-server: sdp_extract_seqtype: Unexpected end of packet

This bug is terribly similar to the GVFS related bug I had once I tried to upgrade my libimobiledevice on my 10.04 Lucid installation. At the time, I upgraded an iPhone OS and wasn't unable to connect anymore. Found a fix for the library, but it required to upgrade also GVFS. After I did, I got exactly that problem and that error. Seems a "reincarnated" bug...

Indra Ginanjar (indraginanjar) wrote :

Agree with simone, this is not a duplicated bug.
I've upgraded all bluetooth and nautilus stuffs to see if it's works after upgraded, but still
The bluetooth applet crash, syslog said it's come from libgnome-bluetooth.so.8.0.0.

This is from my /var/log/syslog

Oct 28 16:42:48 the-pooh bluetoothd[4402]: Discovery session 0x2152d8e0 with :1.126 activated
Oct 28 16:43:20 the-pooh bluetoothd[4402]: Discovery session 0x2152d8e0 with :1.127 activated
Oct 28 16:43:28 the-pooh bluetoothd[4402]: Stopping discovery
Oct 28 16:43:37 the-pooh bluetoothd[4402]: input-headset driver probe failed for device 00:1D:FD:91:1A:EA
Oct 28 16:48:09 the-pooh kernel: [ 5938.783445] bluetooth-apple[4736]: segfault at 40 ip 00ec9a4e sp bfcb4a30 error 4 in libgnome-bluetooth.so.8.0.0[eba000+1a000]

Indra Ginanjar (indraginanjar) wrote :

I've installed blueman (bluetooth-manager) package.
I just found that i CAN send and receive files SUCCESSFULLY while the bluetooth-manager (blueman) active.

The received files is goes to ~/Public (= /home/<username>/Public)

Next is the syslog:

19:48:10 the-pooh dbus[847]: [system] Activating service name='org.blueman.Mechanism' (using servicehelper)
Oct 28 19:48:10 the-pooh blueman-mechanism: Starting blueman-mechanism
Oct 28 19:48:10 the-pooh dbus[847]: [system] Successfully activated service 'org.blueman.Mechanism'
Oct 28 19:48:10 the-pooh blueman-mechanism: loading Config
Oct 28 19:48:10 the-pooh blueman-mechanism: loading Network
Oct 28 19:48:10 the-pooh blueman-mechanism: loading RfKill
Oct 28 19:48:10 the-pooh blueman-mechanism: loading Ppp
Oct 28 19:48:40 the-pooh blueman-mechanism: Exiting
Oct 28 19:49:32 the-pooh goa[3998]: goa-daemon version 3.2.0.1 starting [main.c:112, main()]
Oct 28 19:49:33 the-pooh bluetoothd[3905]: Discovery session 0x21fb3bf8 with :1.84 activated
Oct 28 19:49:43 the-pooh obex-client[4074]: obex-client daemon 0.42
Oct 28 19:49:43 the-pooh bluetoothd[3905]: Mode session 0x21fb3bf8 with :1.87 activated

then if i close the bluetooth-manager, the sending/receiving is failing.

Rafael P. (rafael-p) wrote :

Same symptoms are experienced here. I have 3 important comments to make on this bug:
-Please note that graphical bug is also reported in the bug description, which I also experience on my system.
-The bluetooth applet crashes when the "Browse files..." option is selected from the notification area, after pressing the "browse files.." button in the window that appears (with the graphical bug)
- Bugs 872044 and 879923 report similar issues and seems to be overlapping. Furthermore, this bug has features that can't make it a duplicate. Some order needs to be made in order to focus the efforts in one direction and fix the issue.

Ursula Junque (ursinha) wrote :

Hi all!

I'm investigating bug 872044 and I'd like to know what operating systems your mobiles are running. I've tried to send files to an E71 (symbian) and it worked fine, I wasn't able to browse files on device though. /var/log/syslog shows the error:

"Failed to mount OBEX volume: volume doesn't implement mount"

I too think this is not a duplicate; I'll be glad if you could provide me a bit extra info here so I can proceed unduping this bug (or not :))

Cheers!

Rafael P. (rafael-p) wrote :

I suggest this bug should be marked as Invalid and that a new bug is opened for the graphical issue, which seems unrelated to the file transfer problem (reported in bug #872044. )

Ursula Junque (ursinha) wrote :

Rafael,

Why not unmark the duplicate and just update the title to reflect the issue? :) I'll unmark the dupe, do you mind updating the title accordingly, and adding relevant information in the description? That would be much appreciated, thanks!

Changed in gnome-bluetooth (Ubuntu):
importance: Undecided → Low
Rafael P. (rafael-p) on 2012-02-12
summary: - Bluetooth doesn't allow files to transfer and won't allow browsing of
- device
+ Graphical glitch in Bluetooth applet on "Browse files on device" window
Rafael P. (rafael-p) wrote :
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers