Install gnome-bluetooth by default to enable receiving files via bluetooth

Bug #72033 reported by Alessandro Colaci
80
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-bluetooth (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Սահակ
ubuntu-meta (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Սահակ

Bug Description

Receiving files via bluetooth doesn't work unless gnome-obex-server is running, which is provided by the gnome-bluetooth package. This package itself is in Universe. The package should be promoted to main, and installed by default (atleast if bluetooth hardware is detected, as suggested in bug 120865).

Also, whenever bluetooth is enabled (as when pressing the bluetooth button on the laptop), gnome-obex-server should be run automatically so that file receiving can work seamlessly.

Currently, a user has to enable Universe, install gnome-bluetooth and then every time run gnome-obex-server (Accessories > Bluetooth File Sharing) before they can receive files. These steps can be eliminated for a smoother experience.

Revision history for this message
Alessandro Colaci (alessandro-colaci-deactivatedaccount) wrote :
Revision history for this message
Robert Hrovat (robi-hipnos) wrote :

If you want to transfer files from mobile phone to PC via bluetooth, you should have installed gnome-obex-server (package gnome-bluetooth). After installing you will have Bluetooth File Sharing under Accessories menu. As long as this service is started, you will be able to receive files send via bluetooth.

Revision history for this message
Basilio Kublik (sourcercito) wrote :

Hi Alessandro
You reported this bug a while ago and there has been many software upgrades since then. We were wondering is this still an issue for you? Thanks in advance.

Changed in gnome-bluetooth:
status: New → Incomplete
Revision history for this message
Robert Hrovat (robi-hipnos) wrote :

This didn't change with Gutsy. Still need to install gnome-blueooth and run Bluetooth file sharing to make it work.

Revision history for this message
Uphaar Agrawalla (uphaar) wrote :

Changed the summary and description, and set the status to New. This issue is present in Gutsy.

description: updated
Changed in gnome-bluetooth:
status: Incomplete → New
Revision history for this message
Uphaar Agrawalla (uphaar) wrote :

This is from bug 160022:
If the user installs a Bluetooth hardware (for example, the user plugs an USB Bluetooth adapter), the system must installs the gnome-bluetooth package automatically, if it's not already installed.

Changed in ubuntu-meta:
status: New → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

Why was the release team subscribed? It's not immediately clear what needs to be decided here.

In current hardy, is it enough to have gnome-bluetooth installed by default, or do you still need to manually start the daemon? If so, that should be fixed upstream maybe? Is there a patch to review and decide on for ubuntu-release?

Revision history for this message
Marcel Holtmann (holtmann) wrote :

If you have obex-data-server-0.3 and bluez-gnome-0.23 then you don't need gnome-bluetooth. You can enable OBEX Push and FTP services via bluetooth-properties and use bluetooth-sendto to actually send files.

Revision history for this message
Robert Hrovat (robi-hipnos) wrote :

Marcel, I guess the main talk was vice versa. To send files from phone to computer. This doesn't work without having bluetooth file sharing install and running.

Revision history for this message
Marcel Holtmann (holtmann) wrote :

It will work with obex-data-server-0.3 and bluez-gnome-0.23. Check out the code!

Revision history for this message
Matti Lindell (mlind) wrote :

Hardy has obex-data-server 0.3 in universe and there's an effort for getting bluez-gnome-0.23 in bug #190405. This setup should obsolete gnome-bluetooth and make BT file transfers bit easier.

Revision history for this message
Stephen Irons (stephen-irons) wrote :
Revision history for this message
Matti Lindell (mlind) wrote :

This bug is fixed in Hardy as obex-data-server, which provides the obex functionality, was promoted to main and made dependency of bluez-gnome. Obex filetransfers now work without gnome-bluetooth in the default desktop install.

Changed in gnome-bluetooth:
status: New → Invalid
Changed in ubuntu-meta:
status: Confirmed → Won't Fix
Revision history for this message
Neal McBurnett (nealmcb) wrote :

Updating to fix released according to note by matti

Changed in ubuntu-meta:
status: Won't Fix → Fix Released
Revision history for this message
matthias (one-matthias) wrote :

Hi

Yesterday, november 9 2008 i installed ubuntu 8.10 intrepid ibex

I hade to install Bluetooth File sharing program before i could use bluetooth to recieve files from phone.

Should be installed along with bluetooth ...

Revision history for this message
Pelládi Gábor (pelladigabor) wrote :

Setting this to confirmed, because intrepid install does not include gnome-bluetooth by default. So receiving files via bluetooth does not work by default.

Changed in ubuntu-meta:
status: Fix Released → Confirmed
Revision history for this message
Jaap Haitsma (jaap) wrote :

gnome-bluetooth is now a fork of bluez-gnome and received quite a bit of development to have it better integrated in the GNOME desktop. Furthermore it received quite some extra features: among others integration with network manager and pulse audio. It is being proposed for inclusion in the desktop of GNOME 2.28.

In my opinion ubuntu should replace bluez-gnome with gnome-bluetooth

Revision history for this message
Przemysław Kochański (kochas315) wrote :

gnome-bluetooth solves bug https://bugs.launchpad.net/ubuntu/+source/bluez-gnome/+bug/368500

IMHO gnome-bluetooth should be default bluetooth manager.

Revision history for this message
Jaap Haitsma (jaap) wrote :

Is it planned for Karmic tp use gnome-bluetooth by default?

Revision history for this message
Id2ndR (id-2ndr) wrote : Re: [Bug 72033] Re: Install gnome-bluetooth by default to enable receiving files via bluetooth

Jaap Haitsma a écrit :
> Is it planned for Karmic tp use gnome-bluetooth by default?
>
>
gnome-bluetooth and libgnome-bluetooth7 packages just appears in todays updates in karmic so I think it will be used by default.

Revision history for this message
Սահակ (petrosyan) wrote :

I installed Ubuntu-9.10's daily build today (20090812.2) from
http://cdimage.ubuntu.com/daily-live/20090812.2/

and it comes with gnome-bluetooth installed and enabled by default.

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Onkar Shinde (onkarshinde) wrote :

bluez-gnome is dead upstream. Latest gnome-bluetooth is very improved fork of bluez-gnome. And yes, gnome-bluetooth will be installed by default in karmic.

Revision history for this message
Matteo (matteo-vannucchi) wrote :

gnome-bluetooth doesn't contain gnome-obex-server anymore in karmic.
How can I transfer files from my phone to my notebook?
Is there a different package to install? Seems like gnome-user-share does the trick, but it install Apache, too, and I don't want it.

Revision history for this message
Id2ndR (id2ndr) wrote :

You may pair your computer with your phone and then browse the device with a click on the bluetooth applet.

Revision history for this message
Compist (compist) wrote :

@ld2ndR; I'm afraid that solution isn't good enough. I own a Cybershot 5MP Camera phone which has a very large directory. When trying to browse it to transfer files to the PC, ubuntu panics and can't display the folder contents. Is there any way of enabling the much simpler way of just sending the file from your phone and having the PC accept it?

Error message received is;

Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

I don't receive this message when browsing smaller directories

Revision history for this message
viperhr (viperhr) wrote :

@Compist - you can also install the gnome-user-share package which includes the functionality you desire (can then be configured under System -> Preferences -> Personal File Sharing)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers