unable to send/receive files via bluetooth

Bug #709310 reported by weeix on 2011-01-28
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-bluetooth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-bluetooth

My laptop is ASUS EeePC 1000H and my cellphone is Samsung E2152.

Send file problem step:
  1. Enable bluetooth for both device
  2. Click on the bluetooth applet icon -> [My Device's Name] -> Send files...
  3. Choose my cell phone, then press "Send to" button
  4. Choose any file
  5. Confirm the PIN number by pressing "Matches" button
But I failed to send that file, got the "Connection refused (111) error" instead.

Observations:
  1) In the File Transfer window, the is no physical address specified after "From:"
  2) E2152's physical address in the File Transfer window and the PIN Confirmation window doesn't matches

Temporary solution for sending files:
  Click on the bluetooth applet icon and choose "Send files to device..." instead.

Receive file problem step:
  1. Enable bluetooth for both device
  2. Click on the bluetooth applet icon and then toggle Visible ON
  3. From the cellphone, choose any file to send via bluetooth
  4. Search for the laptop
My cellphone found nothing.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-bluetooth 2.32.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-25.44-generic 2.6.35.10
Uname: Linux 2.6.35-25-generic i686
Architecture: i386
Date: Fri Jan 28 21:25:47 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-bluetooth

weeix (weeaix) wrote :
Dmitry Gribanov (turies) wrote :

I confirm this. Cannot send files to bt device too.

Matthew Woerly (nattgew) wrote :

iTux, what kind of laptop/phone are you having issues with?
I have a Dell Inspiron 1525 to Droid Incredible phone (Android).
I've been sending files with Blueman to my phone just fine. It never worked with my old phone (G'zone Boulder), and last night I tried to send a large file and had some issues. But other than that it's been fine for me.

Dmitry Gribanov (turies) wrote :

My phone is SonyEricsson K750i and my bt module is ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle. I use this in 9.10 and win and osx and it was just fine.

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Julian (jukliazzzn) wrote :

Same here.
Laptop: Lenovo T400.
Cel: Motorola Defy.

can receive but can't send to phone.

newbe (newbe) wrote :

Almost the same on Ubuntu 12.04 x64 on Lenovo IdeaPad Z 560 and Samsung GT-5510 (Android2.2)

I can send files the Phone but not recive files form the Phone.

The Error say`s:
"Remote-Gerät hat Ihre Anfrage abgewiesen."
Remote-Device has denied your request. - or so.

hciconfig --all
hci0: Type: BR/EDR Bus: USB
 BD Address: F0:7B:CB:C6:8A:3E ACL MTU: 1021:8 SCO MTU: 64:1
 UP RUNNING PSCAN ISCAN
 RX bytes:3253 acl:42 sco:0 events:108 errors:0
 TX bytes:11724 acl:53 sco:0 commands:53 errors:0
 Features: 0xff 0xff 0x8f 0xfe 0x9b 0xff 0x79 0x87
 Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
 Link policy: RSWITCH HOLD SNIFF PARK
 Link mode: SLAVE ACCEPT
 Name: 'mint-0'
 Class: 0x6e0100
 Service Classes: Networking, Rendering, Capturing, Audio, Telephony
 Device Class: Computer, Uncategorized
 HCI Version: 3.0 (0x5) Revision: 0x1d8
 LMP Version: 3.0 (0x5) Subversion: 0x4203
 Manufacturer: Broadcom Corporation (15)

 gnome-bluetooth 3.2.2-0ubuntu5
 indicator-datetime 0.3.94-0ubuntu2

Kernel: 3.2.0-23.36

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers