Can't send files to a device (a mobile) via bluetooth

Bug #451835 reported by Michał Gołębiowski-Owczarek on 2009-10-15
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-bluetooth (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-bluetooth

I cannot send files to my mobile (Sony Ericsson K800i) via Bluetooth. A mobile doesn't seem to know that something is trying to send a file to it.

While browsing a device I also can't create new files, getting an error:
There was an error creating the directory in obex://[XX:XX:XX:XX:XX:XX]/STH
Operation not supported by backend.

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: b35340b6290029563207fd4b2aa461a1
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Thu Oct 15 04:01:17 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Alpha amd64 (20091008)
Package: gnome-bluetooth 2.28.1-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
SourcePackage: gnome-bluetooth
Uname: Linux 2.6.31-14-generic x86_64

It can be somehow connected to Bug #294617, but I'm not sure.

OK, I can make it both work and fail.

Steps to reproduce:
0) Click on a Bluetooth icon, choose a device (You can set it up earlier) and choose "Browse device". It works like a charm.
1) Try to create a file, You'll get an error:
There was an error creating the directory in obex://[XX:XX:XX:XX:XX:XX]/STH
Operation not supported by backend.
2) Click on a Bluetooth icon, choose a device and choose "Send file..." - it stucks at "Connecting", displaying a yellow triangle indicating sth went wrong - at this moment sending files *doesn't work*
3) Click on a Bluetooth icon, turn off and on Bluetooth
4) Now try to send a file again (in the same way as in (3)) - now it *does work*

It seems this creating-file error has further consequences and it causes sending to not work until Bluetooth connection is restarted.

Achim (ach1m) wrote :

I was able to reproduce that problem with the steps from Michał Gołębiowski.

gnome-bluetooth:
  Installiert: 2.28.1-0ubuntu2
  Kandidat: 2.28.1-0ubuntu2
  Versions-Tabelle:
 *** 2.28.1-0ubuntu2 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

Linux achim-laptop.local 2.6.31-14-generic #46-Ubuntu SMP Tue Oct 13 16:47:59 UTC 2009 i686 GNU/Linux

This used to work in Jaunty.

tags: added: regression-potential
Steve Langasek (vorlon) on 2009-10-18
Changed in gnome-bluetooth (Ubuntu):
importance: Undecided → Medium
Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Onkar Shinde (onkarshinde) wrote :

I can confirm the file send issue. But the workaround of switching bluetooth off and then on doesn't work for me. My mobile is a Sony Ericsson K320i.

I mostly get a progress dialog with simply yellow triangle. But at some point of time I got this dialog with some error text. Hope it will be useful.

VPablo (villumar) wrote :

Try to delete the device and re-configure it. I have this problem too but I think is caused by the update to karmic, I have deleted mi phone and re-configured and now works perfect.

@VPablo
This is NOT caused by update to Karmic. I did a clean installation.

And, by the way, I created a new device a minute ago and still result is the same - it fails.

VPablo (villumar) wrote :

Ok, then it is not the same error that I had. I'm sorry.

tags: added: regression-release
removed: regression-potential
Naruhiko Ogasawara (naruoga) wrote :

Just a comment.
I have same problem with Polaroid PoGo in Karmic.
This small printer accept JPEG data via Bluetooth with BIP. It works perfectly in Jaunty or Windows XP, but wrong output caused in Karmic.
I think my problem seems to relate this bug.

If some information is needed, please let me know.

Naruhiko,

I would prefer that you open a specific bug, where you state what is the problem precisely.

thanks

Michał,

Could you test to send file in terminal using:
/usr/share/doc/obexd-client/examples/send-files <device address> <file>
and tell here it works the same way?

Thanks.

Naruhiko Ogasawara (naruoga) wrote :

Baptiste,

Thanks for your suggestion.
I tried my issue with latest Lucid but still no good, so I'll open new bug about the issue.

@Baptiste Mille-Mathias:
An error happens also when using a terminal:

$ /usr/share/doc/obexd-client/examples/send-files XX:XX:XX:XX:XX:XX /home/mgol/Desktop/Screenshot.png
Traceback (most recent call last):
  File "/usr/share/doc/obexd-client/examples/send-files", line 65, in <module>
    client.SendFiles({ "Destination": sys.argv[1] }, sys.argv[2:], path)
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.openobex.Error.Failed:

Ville Ranki (ville-ranki) wrote :

"Me too" here with Lucid x86_32 and Nokia N900 phone. Operation not supported by backend.

+1

Ubuntu 10.04 LTS 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 07:54:58 UTC 2010 i686 GNU/Linux

on acer aspire 4720z

and Bluetooth dongle Bus 005 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

thanks

I've tried to pair my N900 and a E71 with my Lucid x86_64 and i get "Impossible to associate". I see on the phone and seems that there isn't any bluetooth connection when try to pairing.

Well, this is not a fix, because it doesn't use gnome-bluetooth. But I think it can help people having this problem. What I did to make Polaroid Pogo work under my Ubuntu 10.04 64-bit installation is to replace gnome-bluetooth with blueman. Under blueman everything seems to work properly.

Oscar Duarte (ogduartev) wrote :

Same message here as in #14 ... Nokia 5800 + Lucid 64bits, kernel 2.6.32-24-generic

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers