Sending files fails because obex not loaded

Bug #1645631 reported by Iiro Laiho
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
High
Sebastien Bacher
gnome-bluetooth (Ubuntu)
High
Unassigned

Bug Description

If I run bluetooth-sendto from command line and try to send the file, it quits after selecting the target device with following command line output:

"Acquiring proxy failed: Error calling StartServiceByName for org.bluez.obex: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.bluez.obex.service not found."

After I run "systemctl --user start obex", it proceeds to send the file. Even then it for some reason gets stuck, but I do not know what causes it and it is probably a different problem.

This system is upgraded from xenial.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: gnome-bluetooth 3.20.0-1ubuntu1
ProcVersionSignature: Ubuntu 4.8.0-27.29-generic 4.8.1
Uname: Linux 4.8.0-27-generic x86_64
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
Date: Tue Nov 29 11:04:11 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-09-12 (77 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
ProcEnviron:
 LANGUAGE=fi
 TERM=xterm
 PATH=(custom, no user)
 LANG=C
 SHELL=/bin/bash
SourcePackage: gnome-bluetooth
UpgradeStatus: Upgraded to yakkety on 2016-11-01 (27 days ago)

Revision history for this message
Iiro Laiho (iiro) wrote :
Iiro Laiho (iiro)
tags: added: systemd-boot
tags: removed: systemd-boot
Martin Pitt (pitti)
no longer affects: systemd (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Revision history for this message
Dimitrij Mijoski (dimztimz) wrote :

Happens in Zesty too. Updated from previous distribution versions 16.04->16.10->17.04. Manually starting the service fixes the problem until reboot.

Revision history for this message
Øyvind Stegard (oyvinst) wrote :

Thanks for reporting, I was just struck by this bug on 17.04.

For a fix which lasts across reboots, run as normal user:
systemctl --user enable obex

This permanently enables OBEX service for your user sessions.

Changed in bluez (Ubuntu):
importance: Undecided → High
Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → Invalid
importance: Undecided → High
Changed in bluez (Ubuntu):
assignee: nobody → Sebastien Bacher (seb128)
Revision history for this message
Sebastien Bacher (seb128) wrote :

Enable the unit so dbus activation is working

Revision history for this message
Sebastien Bacher (seb128) wrote :

Daniel, what do you think about that change?

tags: added: patch
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

I think I have no idea :)
I'm not familiar enough with the bluez code to judge that.

tags: added: zesty
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez - 5.45-0ubuntu4

---------------
bluez (5.45-0ubuntu4) artful; urgency=medium

  * Drop deprecated rfcomm.conf and upstart config. (LP: #1674680)

 -- Dariusz Gadomski <email address hidden> Mon, 07 Aug 2017 13:29:41 +0200

Changed in bluez (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
jeremy-list (quick-dudley) wrote :

Not fixed in bluez 5.46-0ubuntu2

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

This bug is now closed so if you have any more problems, please open a new one with this command:

  ubuntu-bug bluez

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions