bluetooth problems due to gsd/g-b mismatched versions

Bug #1384437 reported by David on 2014-10-22
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Bluetooth
Unknown
Unknown
Ubuntu GNOME
Undecided
Unassigned
gnome-bluetooth (Ubuntu)
Low
Unassigned
gnome-settings-daemon (Ubuntu)
Low
Unassigned

Bug Description

After booting up the computer the GNOME bluetooth applet is not able to turn on bluetooth (the slider slides, for an instance of a second my paired devices show up, and then the slider is on OFF again). The error is the same when:
- closing and opening the lid
- Turning BT off and trying to turn it on again using the applet

WORKAROUND: The blueman-applet allows me to turn on and off bluetooth without any modifications.

WORKAROUND: Execute:
rfkill unblock all

(im in the bluetooth group) the bluetooth applet displays bluetooth being on and Im able to connect to my BT devices.

Im using 'rfkill unblock all' in /etc/rc.local before the 'exit 0' line s.t. I have BT always on after starting up the system.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: linux-image-3.16.0-23-generic 3.16.0-23.31
ProcVersionSignature: Ubuntu 3.16.0-23.31-generic 3.16.4
Uname: Linux 3.16.0-23-generic x86_64
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0p: david 2549 F...m pulseaudio
 /dev/snd/controlC0: david 2549 F.... pulseaudio
CurrentDesktop: X-Cinnamon
Date: Wed Oct 22 22:06:15 2014
EcryptfsInUse: Yes
MachineType: ASUSTeK COMPUTER INC. UX32VD
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-23-generic.efi.signed root=UUID=d8d7556a-05ca-4e18-899c-52b7cfd06204 ro quiet splash pcie_aspm=force rootfstype=ext4 vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.16.0-23-generic N/A
 linux-backports-modules-3.16.0-23-generic N/A
 linux-firmware 1.138
SourcePackage: linux
UpgradeStatus: Upgraded to utopic on 2014-10-15 (7 days ago)
dmi.bios.date: 01/29/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX32VD.214
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX32VD
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX32VD.214:bd01/29/2013:svnASUSTeKCOMPUTERINC.:pnUX32VD:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX32VD:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: UX32VD
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

David (dtschaefer) wrote :

David, thank you for reporting this and helping make Ubuntu better. Could you please test the latest upstream kernel available from the very top line at the top of the page (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested exactly shown as:
kernel-fixed-upstream-3.18-rc1

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: latest-bios-214
Changed in linux (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
summary: - bluetooth problems
+ 8086:088e [Asus UX32VD] bluetooth problems
description: updated
David (dtschaefer) on 2014-10-23
tags: added: kernel-bug-exists-upstream-3.18-rc1

Hi Christopher,

thanks for your good will to help.
I installed and booted

linux-headers-3.18.0-031800rc1_3.18.0-031800rc1.201410192135_all.deb
linux-headers-3.18.0-031800rc1-generic_3.18.0-031800rc1.201410192135_amd64.deb
linux-image-3.18.0-031800rc1-generic_3.18.0-031800rc1.201410192135_amd64.deb

uname -a
Linux UX32VD 3.18.0-031800rc1-generic #201410192135 SMP Mon Oct 20 01:37:04 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

The bug persists.

During testing I spottet that blueman-applet is able to turn bluetooth on and off, the default ubuntu-desktop and gnome-shell-desktop bluetooth manager/applet is not.

Please tell me how I can further help you.

Thanks,
David

David, just to clarify, does using the blueman-applet allow you to use bluetooth with the default Ubuntu kernel, without any WORKAROUNDs?

David (dtschaefer) wrote :

Yes!
To verify this I rebooted into.

 Linux UX32VD 3.16.0-23-generic #31-Ubuntu SMP Tue Oct 21 17:56:17 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

The only modification is

rfkill unblock all

in rc.local. Thats it.

David, to further clarify, no WORKAROUNDs means not using any modifications (ex. rfkill).

David (dtschaefer) wrote :

I dont see a connection between rc.local and my problem but anyway:

I removed the fix,
rebooted,
problem remains.

David, so to pull it all together, does using the blueman-applet allow you to use bluetooth with the default Ubuntu kernel, without any WORKAROUNDs?

David (dtschaefer) wrote :

Christopher, yes:

The blueman-applet allows me to turn on and off bluetooth without any modifications. The gnome applet does not.

See the pictures attached taken showing cimmamon:

David, if other applets allow you to use bluetooth but the GNOME applet doesn't, then this would be an issue with gnome-bluetooth.

affects: linux (Ubuntu) → gnome-bluetooth (Ubuntu)
Changed in gnome-bluetooth (Ubuntu):
status: Incomplete → New
David (dtschaefer) wrote :

Hey Christopher,

I knew that this is a gnome problem, but how shall I continue. Is this the wrong place now? What do you recommend me doing?

Best,
David

David, you would want to report it upstream via https://bugzilla.gnome.org/enter_bug.cgi?product=gnome-bluetooth . Once a report is generated, please post the URL to this report.

Changed in gnome-bluetooth (Ubuntu):
status: New → Triaged
description: updated
David (dtschaefer) wrote :

Thanks for the link Christopher. The gnome-bugtracker now has this item:

https://bugzilla.gnome.org/show_bug.cgi?id=740063

Cheers,
David

David (dtschaefer) wrote :

The problem is Ubuntu using different versions of gnome at the same time:
gnome-bluetooth 3.8.2.1-0ubuntu9
gnome-settings-daemon 3.12.2-1ubuntu2

or to be more precise: gnome-bluetooth is too old to communicate with gnome-settings-daemon.

Bastien Nocera from the gnome team quickly found the issue:
> Get the distribution to fix this. GNOME 3.12 (when both g-s-d and
> gnome-bluetooth 3.12 are used) will talk to rfkill directly to fix such
> problems. Your mismatched version won't (older gnome-bluetooth doesn't know how
> to talk to the newer gnome-settings-daemon).

David (dtschaefer) wrote :

Hey Christopher,

whats the status regarding this bug? Is there anyhing we can do? The bug is clear by now, isnt it?

Best,

David

David, as per https://launchpad.net/ubuntu/+source/gnome-bluetooth the maintainers are the Ubuntu Desktop team. You would want to ping them about it.

David (dtschaefer) wrote :

Christopher,

I may have misunderstood this but I have created a new bugreport about it.

https://bugs.launchpad.net/ubuntu/+source/gnome-bluetooth/+bug/1398132

David, just to clarify, you do not have to create another bug report unless specifically asked to.

What was suggested in https://bugs.launchpad.net/ubuntu/+source/gnome-bluetooth/+bug/1384437/comments/18 was to contact the maintainers. Making another bug report doesn't achieve this.

David (dtschaefer) wrote :

Sorry for that. The term "ping" is not something that I have found on any launchpad site. Now I have sent a mail via "Contact this team's admins" of the “Ubuntu Desktop” team. Hope thats the way to go.

Thanks,
David

summary: - 8086:088e [Asus UX32VD] bluetooth problems
+ bluetooth problems due to gsd/g-b mismatched versions
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Robert Ancell (robert-ancell) wrote :

It's not clear to me what you're doing here.

You appear to be running Cinnamon? In comment #10 you show a control centre (GNOME control centre?).

What are the exact steps required to reproduce this.

David (dtschaefer) wrote :

Hi Robert,

Im using Cinnamon now as a workaround. To reproduce this

- gnome only is sufficient
- boot up the computer
- the GNOME bluetooth applet is not able to turn on bluetooth (the slider slides, for an instance of a second my paired devices show up, and then the slider is on OFF again)

OR

- gnome only is sufficient
- Running gnome
- with running bluetooth closing and opening the lid. Bluetooth will not work anymore

OR

- gnome only is sufficient
- Running gnome
- with running bluetooth turn off bluetooth using the applet and try to turn it on again (the slider slides, for an instance of a second my paired devices show up, and then the slider is on OFF again)

David (dtschaefer) wrote :

Rephrased second reproduction alternative:

...
OR

- gnome only is sufficient
- Running gnome
- with running bluetooth closing and opening the lid. Try to turn Bluetooth on again using the applet will fail (the slider slides, for an instance of a second my paired devices show up, and then the slider is on OFF again)
OR
---

Tim Lunn (darkxst) on 2014-12-10
Changed in ubuntu-gnome:
milestone: none → vivid
Tim Lunn (darkxst) on 2014-12-26
Changed in ubuntu-gnome:
status: New → Triaged
Changed in ubuntu-gnome:
milestone: vivid → xenial
Tim Lunn (darkxst) wrote :

This was fixed in 15.10

Changed in gnome-settings-daemon (Ubuntu):
status: Triaged → Invalid
Changed in gnome-bluetooth (Ubuntu):
status: Triaged → Fix Released
Changed in ubuntu-gnome:
milestone: xenial → vivid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.