Microsoft bluetooth mobile keyboard 6000 cannot be used

Bug #1312349 reported by Anthony Wong on 2014-04-24
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
HWE Next
Medium
Unassigned
gnome-bluetooth (Ubuntu)
Medium
Mathieu Trudel-Lapierre
Trusty
Medium
Brian Murray

Bug Description

[Impact]
Currently gnome-bluetooth treats all devices with oui="7C:1E:52:" equally which makes the Microsoft Bluetooth Mobile Keyboard 6000 unable to be paired.

Without this fix, users cannot use this bluetooth keyboard at all.

[Test case]
The keyboard can't be paired without this fix, and can pair/connect to it with the fix. MS sculpt/wedge mice should work before and after the fix is in place.

[Regression Potential]
MS sculpt/wedge mice is affected, so they should be tested with the new fix.

Related branches

description: updated
description: updated
tags: added: blocks-hwcert-enablement
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

Uploaded to utopic for now. Sitting in the pre-release freeze queue.

Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-bluetooth - 3.8.2.1-0ubuntu5

---------------
gnome-bluetooth (3.8.2.1-0ubuntu5) utopic; urgency=low

  * debian/patches/99_add_microsoft_mice.patch: fix the problem that
    Microsoft Bluetooth Mobile Keyboard 6000 cannot be paired. (LP: #1312349)
 -- Anthony Wong <email address hidden> Fri, 25 Apr 2014 02:00:56 +0800

Changed in gnome-bluetooth (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-bluetooth (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Brian Murray (brian-murray)
Brian Murray (brian-murray) wrote :

I've uploaded this to the proposed queue for Trusty.

Hello Anthony, or anyone else affected,

Accepted gnome-bluetooth into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-bluetooth/3.8.2.1-0ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-bluetooth (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in hwe-next:
status: New → In Progress
Anthony Wong (anthonywong) wrote :

The previous patch makes Wedge Touch mouse unusable. Re-work it so that both Sculpt and Wedge Touch mice can be used. Please see https://code.launchpad.net/~anthonywong/ubuntu/utopic/gnome-bluetooth/lp1312349

tags: added: verification-failed
removed: verification-needed
Changed in gnome-bluetooth (Ubuntu):
status: Fix Released → Confirmed
Anthony Wong (anthonywong) wrote :

Seems the issue is intermittent, probably due to bluetooth device on this particular machine. I'm doing more testing now.

Anthony Wong (anthonywong) wrote :

Tested again with fresh 14.04 fresh install and gnome-bluetooth 3.8.2.1-0ubuntu4.1, both Sculpt and Wedge mice can be paired, connected and usable.
I don't have the keyboard though, so I am asking help from Tim Chen to test that.

Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → Fix Released
tags: added: verification-needed
removed: verification-failed
Changed in gnome-bluetooth (Ubuntu):
status: Fix Released → Confirmed
tags: added: verification-failed
removed: verification-needed
Anthony Wong (anthonywong) wrote :

Found out that the previous patch has problem to re-connect the mouse after it's disconnected, need the patch in lp:~anthonywong/ubuntu/utopic/gnome-bluetooth/lp1312349 to fix it. Could someone please help to upload to utopic?

Meanwhile, set the tag to verification-failed.

Sebastien Bacher (seb128) wrote :

Thanks for the work. Mathieu, do you think you could help reviewing those changes/getting them uploaded?

Changed in gnome-bluetooth (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-bluetooth - 3.8.2.1-0ubuntu6

---------------
gnome-bluetooth (3.8.2.1-0ubuntu6) utopic; urgency=medium

  * debian/patches/microsoft_device_reconnect.patch: allow more
    Microsoft bluetooth devices to reconnect successfully. (LP: #1312349)
 -- Anthony Wong <email address hidden> Tue, 17 Jun 2014 17:14:45 -0400

Changed in gnome-bluetooth (Ubuntu):
status: In Progress → Fix Released
Chris J Arges (arges) wrote :

Unsubscribing sponsors for now. Please resubscribe when a SRU patch is available. Thanks!

Changed in gnome-bluetooth (Ubuntu Trusty):
status: Fix Committed → In Progress

Anthony, your patch is still proposed for trusty, could you test it and tell us whether things are working properly now, and in which releases?

So I can see what was uploaded to trusty isn't the same code as what I sponsored to utopic; let's remove that package and reupload the same fix that got into utopic.

Uploaded the updated fix to Trusty; pending review.

Tim Chen (timchen119) wrote :

verified work on utopic gnome-bluetooth 3.8.2.1-0ubuntu9 with MS bluetooth keyboard 6000

Tim Chen (timchen119) wrote :

verified work on trusty gnome-bluetooth 3.8.2.1-0ubuntu4.1 with MS bluetooth keyboard 6000

tags: added: verification-done
removed: verification-failed
Mathew Hodson (mathew-hodson) wrote :

gnome-bluetooth 3.8.2.1-0ubuntu4.1 is the same version that failed due to comment #9.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-bluetooth - 3.8.2.1-0ubuntu4.1

---------------
gnome-bluetooth (3.8.2.1-0ubuntu4.1) trusty; urgency=low

  * debian/patches/99_add_microsoft_mice.patch: fix the problem that
    Microsoft Bluetooth Mobile Keyboard 6000 cannot be paired. (LP: #1312349)
 -- Anthony Wong <email address hidden> Fri, 25 Apr 2014 02:00:56 +0800

Changed in gnome-bluetooth (Ubuntu Trusty):
status: In Progress → Fix Released

The verification of the Stable Release Update for gnome-bluetooth has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in hwe-next:
status: In Progress → Fix Released
importance: Undecided → Medium

Hello Anthony, or anyone else affected,

Accepted gnome-bluetooth into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-bluetooth/3.8.2.1-0ubuntu4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Mathew Hodson (mathew-hodson) wrote :

This bug was fixed in the package gnome-bluetooth - 3.8.2.1-0ubuntu4.2

---------------
gnome-bluetooth (3.8.2.1-0ubuntu4.2) trusty-proposed; urgency=medium

  * Add ssp parameter fix, fix the parameter entered in agent dbus API,
    also fix the wizard's UI to show the pin code correctly.
    Fixed Logitech Bluetooth Keyboard K760, Logitech Bluetooth Keyboard K810,
    HP Bluetooth Keyboard K4000 secure simple pairing failed issue.
    (LP: #1035431)

gnome-bluetooth (3.8.2.1-0ubuntu4.1) trusty; urgency=low

  * debian/patches/99_add_microsoft_mice.patch: fix the problem that
    Microsoft Bluetooth Mobile Keyboard 6000 cannot be paired. (LP: #1312349)
 -- Jian-Ding Chen (timchen119) <email address hidden> Mon, 28 Apr 2014 17:40:00 +0800

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers