Logitech Ultrathin Touch Mouse needs to be repaired

Bug #1237355 reported by Ralph Meijer on 2013-10-09
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
GNOME Bluetooth
Fix Released
Medium
gnome-bluetooth (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

Similar to #1094744, the Logitech Ultra Touch Mouse fails to reconnect after powering off or switching channels (this mouse can be associated with two devices). Adding a line to the PIN code database (/usr/share/gnome-bluetooth/pin-code-database.xml, see attachment) and then removing and re-adding the device resolves the problem for me.

For completeness, the specific device model is t630 (for Windows), for which all other functionality (including all gestures and battery information) seems to be working quite well. Some gestures result in key combinations that have no default action bound to them. There is also a Mac version called t631. I am uncertain if the latter has the same pairing issue.

Ubuntu 13.04, gnome-bluetooth 3.6.1-0ubuntu3.1.

Ralph Meijer (ralphmeijer) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Ayberk Özgür (equilibriumtr) wrote :

I'm also having this issue on 12.04 and 14.04. For me, adding the manual 0000 pin solves the problem after power off/on but does NOT solve the problem after channel switch, where a manual reconnect is required.

Also, on both 12.04 and 14.04, I'm having occasional issues where I'm getting a keypress continuously (a regular key on the keyboard like a letter or a punctuation mark). I'm suspecting a gesture message somehow being misinterpreted by X, but I'm not able to reproduce it reliably. It's really annoying and it's fixed by turning the mouse on and off, which causes it to reconnect. I'm not sure if I should open another issue for this.

rjb (ron-buehler) wrote :

At least in Ubuntu 14.04 LTS, while pairing the mouse, you can set a fixed PIN (0000) instead of automatic PIN mode.

rjb (ron-buehler) wrote :

I can actually switch the channel and switch back and it's connected again. But when it's paired on channel 1 with Ubuntu 14.04 and I boot to Windows 7 and go to pair it for channel 2 then boot again to Ubuntu and switch to channel 1 the mouse LED is blinking fast (meaning it's in pairing mode again).
This also happens when I pair Windows first and Ubuntu afterwards, then the channel for Windows is blinking.
So for some reason the mouse always loses the first paring?

Ayberk: Is this the behaviour you describe with the channel switch?

Ayberk Özgür (equilibriumtr) wrote :

Yes, this is exactly the behavior I'm experiencing.

rjb (ron-buehler) wrote :

OK thanks.
As for the occasional continuous keypressses, I'm getting them too.
So far it was always a sequence of '^^^^^^^^^^'
I was able to stop this by hitting the backspace button.

Ayberk Özgür (equilibriumtr) wrote :

Good to know! I was getting more and more sure that my mouse had a manufacturing fault.

As for fixing this keypress issue, I'm guessing that the most sure way would be to monitor the bluetooth packet traffic?

Hervax (hervax1) wrote :

Hi everyone!
I also experience occasional unwanted keypresses. Usually, I stop it by pressing the ESC key on the keyboard. I suspect any key pressed on the keyboard would stop the process. It's much easier than resetting the mouse.
Otherwise, it's a great mouse for a small notebook (ASUS X202E).
Regards, RV.

Ayberk Özgür (equilibriumtr) wrote :

The random keypress bug is getting really annoying. Is someone using this mouse in Windows also? Chances are, this is a firmware bug and it also happens on Windows.

xz (webstuff011) wrote :

I use T630 on both Ubuntu and Windows. Yes, the random keypressing happens from time to time on Windows as well.

Ayberk Özgür (equilibriumtr) wrote :

I feel extremely stupid for having paid nearly 90 bucks for this heap of garbage: I'm getting keypresses every 15 minutes now.

Well, that's the last time I buy anything from Logitech.

Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in gnome-bluetooth (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-bluetooth - 3.8.2.1-0ubuntu7

---------------
gnome-bluetooth (3.8.2.1-0ubuntu7) utopic; urgency=medium

  * debian/control.in:
    - remove Build-Depends on nautilus-sendto.
    - add libudev-dev to Build-Depends.
  * debian/gnome-bluetooth.install:
    - stop installing the nautilus-sendto plugin, it's no longer being built
      due to nautilus-sendto not providing API.
    - don't try to install gconf settings.
  * debian/patches/git_add_vendor_attribute_support_49b84e8.patch,
    debian/patches/git_vendor_from_oui_helper_90423abf.patch: cherry-pick
    patches to allow specifying devices by vendor, and as such update the
    pin database.
  * debian/patches/logitech_ultrathin_touch_pin.patch: specify a default PIN
    for the Logitech Ultrathin Touch mice. Thanks to Ralph Meijer for the
    patch. (LP: #1237355)
  * debian/patches/pin_code_database_update.patch: update the PIN database
    from git.
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 10 Jul 2014 16:37:02 -0400

Changed in gnome-bluetooth (Ubuntu):
status: In Progress → Fix Released

thx @rjb for #4 works perfectly

Changed in gnome-bluetooth:
importance: Unknown → Medium
status: Unknown → New
Walter Lapchynski (wxl) wrote :

has anyone filed a bug for the extra input? if not, we should. honestly, i think this is an issue with the mouse than not, but i can't find any way to disable the gestures, which i might consider a bug.

Ralph Meijer (ralphmeijer) wrote :

If I remember correctly, those gestures actually come in as keyboard events. Unfortunately, I have no idea how to tell Xorg how to ignore such events for certain input devices.

Walter Lapchynski (wxl) wrote :

Indeed, they are keyboard events. I'm trying to see if anyone can help figure this issues out here:
http://askubuntu.com/questions/568228/how-do-you-disable-mouse-gestures

Changed in gnome-bluetooth:
status: New → Confirmed
Changed in gnome-bluetooth:
status: Confirmed → Fix Released
Jonathan Polak (jpolak) wrote :

Has this fix been pushed upstream to the main Debian fork?
I'm running Debian Jessie and all these issues are still present.

Ryan Frank (ryandlf) wrote :

I am also still experiencing the same issues using the Ultrathin Touch Mouse on Ubuntu 14.04. In addition the cursor gets extremely laggy at times. Not to the point where its unusable, but it is a noticeable drag.

Peter Bittner (peter-bittner) wrote :

I can confirm that automatically reconnecting still doesn't work out-of-the-box on Ubuntu 14.04.3 LTS. Adding the PIN code information to /usr/share/gnome-bluetooth/pin-code-database.xml alone won't do it either. I had to remove the paired device from the bluetooth settings, and pair the mouse anew (as suggested in the blog below). I used the "PIN options ..." button though to explicitly specify the 0000 PIN. This makes the mouse reconnect automatically after booting and wakeup (touching the mouse to activate battery flow is all that is needed).

Some useful links for configuring:

- Backlink to the blog post that lead me here: http://ralphm.net/blog/2013/10/10/logitech_t630 (description of the problems and solutions for this device)
- Neat overview of gestures: http://www.logitech.com/assets/50008/t630-touch-gestures-guide.pdf (most of them supported out-of-the-box in 14.04.3; from the blog)
- Activate natural scrolling for the mouse: https://ask.fedoraproject.org/en/question/10562/is-there-a-way-to-have-mac-like-natural-scrolling-in-fedora-15/ (only supported for touchpad via System Settings in 14.04.3)

Peter Bittner (peter-bittner) wrote :

I can also confirm the keypresses, which appear in input fields sometimes. Unfortunately, I have no idea how to reproduce the error.

I have dug through the Logitech forums, but without more findings. Here is the only relevant thread related to T630/T631 issues, Ubuntu or keypresses:
- Discussion "T630 Mouse on Ubuntu / Linux": (Logitech Forums)
http://forums.logitech.com/t5/Mice-and-Pointing-Devices/T630-Mouse-on-Ubuntu-Linux/m-p/1375610/highlight/false#M62867

giz manning (giz02) wrote :

I'll throw this in..

I've got the same mouse and get the random and irritating characters (it's a real *joy* when using google docs/sheets I'll tell you...)

it occures mostly on scrolling, but the mouse also occasionally spits out characters when my hand is still/near still.

I am on Debian Jessie running KDE, so different from you guys..

I've tried disconnecting BT and reconnecting, but to no avail.

I have found that rebooting the OS clears the issues.

So we have this issue across multiple desktop environments (KDE/GNOME)
The issue clears after reboot.

Could be this be OS related?

Claudio Denega (claudio-am) wrote :

Having the same issue with the random characters on 14.04.3 and 15.10.

It stops for several minutes after pressing the ESC key.

falko (mail-falko-menge) wrote :

I also have random "keyboard input" that seems to occur when I touch the touch surface. It's especially annoying when the mouse "hits" the Windows key and opens the Ubuntu menu. Is there a way to restrict the device to only send "mouse input" like moving the cursor, clicking and scrolling and block any "keyboard input"?

falko (mail-falko-menge) wrote :

I solved the pairing issue by running a shell script, each time I want to use the mouse in Ubuntu 14.04.4 LTS:

#!/bin/sh
bt-input -c 34:88:5D:47:7E:CF

Brandon Durepo (bdurepo) wrote :

Append
 <!-- Logitech Ultrathin Touch Mouse -->
 <device oui="34:88:5D:" name="Ultrathin Touch Mouse" pin="0000"/>

to /usr/share/gnome-bluetooth/pin-code-database.xml

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.