GDBus.Error:org.openobex:Error.Failed: Unable to request session

Bug #1148033 reported by serkanburda on 2013-03-05
802
This bug affects 175 people
Affects Status Importance Assigned to Milestone
Bluetooth Menu
New
Undecided
Unassigned
gnome-bluetooth (Ubuntu)
Medium
Ahmed Elgamal
indicator-bluetooth (Ubuntu)
Medium
Unassigned

Bug Description

I'm using 13.04 and i can't send file from my netbook to my phone via bluetooth. Worked on 12.10 (I use Lenovo 3000 N200) after installing Blueman Bluetooth Manager problem solved.

Also affects 13.10!

summary: - GDBus.Error:org.oopenobex:Error.Failed: Unable to request session
+ GDBus.Error:org.openobex:Error.Failed: Unable to request session
description: updated
VeryNewbie (sutcarey) wrote :

Ubuntu 12.10 is giving the same errors. PC can't send to phone and vice versa.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
David Shepherd (tophitter225-p) wrote :

Same happens to me. I can send from my phone to my PC but I cant receive files to my phone from the PC

Consumology (hgms72-4oneway) wrote :

I had this working on 12.10. I installed 13.04 from scratch two weeks ago and can receive files sent from phone but not sending from notebook, this gives me the above OBEX error.

Ali Najafi (alinajafi) wrote :

Me too had this working on all previous versions, but not in 13.04. I recieve the same error while sending from PC to phone. Attempting for browsing files on the phone doesn’t show up any windows or errors, nothing.
I’ve never been able to set my device visible to others with Ubuntu (I’ve tried all versions from 11.04 to 13.04).

Ego (egogratis) wrote :

I can confirm this.

Damon Hartman (area51pilot) wrote :

I can confirm the same error while trying to send a file from a laptop runing 130.04 to a paired smartphone. Fresh install of 13.04.

saansoft (spainshfriend) wrote :

Me also having same problem with 13.04,
was all working well with 12.10 and the problem arouse after upgrading.

Rocko (rockorequin) wrote :

I have the same problem. I installed bluetooth-manager (sudo apt-get install blueman) and then used it to send a file. This worked, and afterwards gnome-bluetooth manager was also able to send files. So gnome-bluetooth manager must be missing some important setup step.

Damon Hartman (area51pilot) wrote :

I can confirm that after install of blutooth-manager (sudo apt-get install blueman), I was able to send files via gnome-bluetooth and blueman

Hi. I tried Damon Hartman suggestion and it works. But it works only when blueman installed. When i remove (purge) blueman, the problem comes back. Thanks.

Thomas Hood (jdthood) wrote :

Running 12.10. Got the error message; installed blueman; problem gone.

Weitian Leung (timxx) wrote :

Thanks Thomas Hood (jdthood), just installed blueman, it works for me too.

Jose Padilla (sargepl) wrote :

I also can confirm this in Ubuntu 13.04. Installing blueman package and using it to send files to mobile works fine.

Since I was using ubuntu 12.04 I had this issue. The problem remains ou 13.04. I'll try installing blueman package too!

Aniket (djaniketster) wrote :

Installed blueman. but the problem remains in 13.04.

I also can confirm this in Ubuntu 13.04. Installing blueman package and using it to send files to mobile works fine.

Francisco Cribari (cribari) wrote :

I am having the same problem with Ubuntu 13.04 (64 bit). I am unable to transfer files to my Android phone. Installing blueman does not help.

bingorabbit (bingorabbit) wrote :

Confirming the same problem on 64-bit 13.04, the problem also affects Impress Remote Control, not just exchanging files. It was working in 12.10 (32-bit)

Vanamali (vanamalishastry) wrote :

I'm facing the same problem in my Compaq CQ40/Ubuntu 13.04 (32-bit).

Tarif Ezaz (tarif-ezaz) wrote :

After installing blueman my problem was solved, I use a dell vostro 3460.

pisartshik (pisartshik) on 2013-05-16
description: updated
description: updated
Mark Enriquez (enriquezmark36) wrote :

I could not send files but other options as browsing files using obex ftp and recieving files still works with blueman in this new 13.04 install

Mark Enriquez (enriquezmark36) wrote :

Hey guys I have found a workaround with this command:
obexftp -b [address of the phone] -p file.ext

Notes : You need obexftp to be installed
            : You need to know the address of your phone or bluetooth device by this command:
               hcitool scan
            : The address should be in this format xx:xx:xx:xx:xx:xx

PS : Correct me if I'm wrong still at 14

Mark Enriquez (enriquezmark36) wrote :

Oh yeah I forgot to mention that this command :
obexftp -b [address of the phone] -p file.ext
will send this file to the Phone memory. If any one knows how to fix these pls comment

Solario (lg-solario) wrote :

Hi guys, I solved this problem don't using blueman.
Bluetooth will send and receive data if you run the bluetooth-applet.
I didn't find any other solution.

StSav012 (stsav012) wrote :

I can't send files neither with gnome-bluetooth nor with Blueman. The latter sends some 1 MB and then aborts the transferring.
The same problem as Francisco Cribari mentioned (https://bugs.launchpad.net/ubuntu/+source/gnome-bluetooth/+bug/1148033/comments/18).
Computer: Samsung R505. OS: Ubuntu 13.04 64-bit.

Patrik Bubák (inoki) wrote :

I'm having the same issue on Ubuntu 13.04 x64 with an ASUS Bluetooth Dongle and my HTC Desire X.

Abdelaziz Yakout (yooozy) wrote :

having the same issue on Ubuntu 13.04 x64 on HP Proboob 4530s

Vladimir (volnes88) wrote :

i have the same bug, but i have xubuntu 13.04
Bug is i cannot send file with size bigger then 1mb....recieved all sizes
device : Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Bence Lukács (lukacs-bence1) wrote :

The bug also affects me on Ubuntu 13.04

Juha Jeronen (juha-jeronen) wrote :

Ubuntu 13.04, affects me too. Running on an ASUS EeePC 1005PE. Tried to transfer files between the PC and a smartphone running Android 4.1.

Tried installing blueman on the PC and using it instead of the default bluetooth applet, didn't help. Sometimes blueman could transfer small (30kB) files from the PC to the phone correctly, but large files (3MB) would randomly hang the transfer. When sending any file from the phone to the PC, the transfer would hang at the "connecting" stage.

However, while blueman is installed and running, it seems that the default bluetooth applet (but not blueman) can transfer files correctly. Such behaviour has also been reported by others.

So, as a temporary workaround, I followed the instructions here:

http://krazyabouttechnology.blogspot.fi/2013/05/solution-bluetooth-not-working-after_3.html

to have just one bluetooth icon even though both the default bluetooth applet and blueman are running at the same time. Now the transfer seems to work in both directions.

Would appreciate if this was fixed properly :)

Ali Najafi (alinajafi) wrote :

I can do something now that I’ve never tried before.
I can “browse the files” on the phone by copying the device address (for example 00:25:E7:B1:53:3E) and type in Files (Nautilus):
obex://[00:25:E7:B1:53:3E]/
After then, the phone is mounted like a USB drive and it’s possible to copy from or paste in it.
Still the Send To function doesn’t work.
But where I have the device address? From Bluetooth Settings after pairing the device.

I went further!
When mounted, instead of Send To, I selected Copy To, went to File System (/), pressed Ctrl+L and typed the above-mentioned device address. This time the file was sent to the phone just like the Send To command. The difference here is that the phone never asks to allow connection.

Can you please someone try these procedures to find if they work?

Jeremy Bicha (jbicha) wrote :

I'm marking as triaged. Sending files via Bluetooth works fine with GNOME Shell but something isn't working right when we try in Unity.

Changed in gnome-bluetooth (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Jeremy Bicha (jbicha) wrote :

bluetooth-sendto is used by both indicator-bluetooth and gnome-control-center to send files via Bluetooth. It does not work in Unity but it works in GNOME Shell as long as https://git.gnome.org/browse/gnome-shell/tree/js/ui/status/bluetooth.js is loaded.

Therefore I think this is something that needs to be fixed in indicator-bluetooth.

affects: gnome-bluetooth → indicator-bluetooth
Changed in indicator-bluetooth (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
chrmhoffmann (chrmhoffmann) wrote :

I am not sure why this works, but if I open shell and then run bluez-simple-agent, the file transfer works.

Jérôme Poulin (jeromepoulin) wrote :

As said in comment #36, running bluez-simple-agent works for me for sending files to my phone but I still can't receive any.

gamarra (gamarradez) on 2013-07-13
Changed in gnome-bluetooth (Ubuntu):
status: Triaged → New
status: New → In Progress
assignee: nobody → gamarra (gamarradez)
assignee: gamarra (gamarradez) → nobody
Consumology (hgms72-4oneway) wrote :

The OBEX error is also present on 13.10, bluez-simple-agent works for sending and receiving.

Another thing I noticed: when installing Blueman i can no longer use Bluetooth Audio (13.04, have not tried on 13.10 so far).

This error affects me too (13.04), but on both sides (computer to phone AND phone to computer)
using comment #38, ran "bluez-simple-agent" from terminal, and sending files (computer -> phone) is working.
If "bluez-simple-agent" is not running, the error raises again.

However, sending files from phone to computer still doesn't work, although both computer and phone are paired,
and phone is set to "always accept" for this device.
(phone is android 4.0.4, and computer is Dell Vostro 1510 with Bluetooth integrated device, but same behaviour with an
external dongle)

Hope this contributes to help...

ramble (ramble) wrote :

I have same problem with new insallation of 13.04

MD.sharif molla (sharif-shown) wrote :

Same happens to me. I can send from my phone to my PC but I cant receive files to my phone from the PC help me plzzz

we all know that installing "bluetooth manager" makes bluetooth work, after starting "bluetooth manager", sending and browsing files works, but not receiving.

The solution to receive files from phone is very simple:
1. Just start "Personal File Sharing"
2. deselect "Share public files over Bluetotth"; I also choose "Always" and selected "Notify about received files"

And everything should start working...

Ubuntu is the best!

inashdeen (inashdeen) wrote :

@Joao I did all u have adviced , still it is not working. I think this is an absolute bug.

Blueman working on Ubuntu 13.04 64 bit to Lumia 610 . Laptop : Acer aspire v5-471pg . TQ

Sean Watson (sean.watson) wrote :

bluez-simple-agent got around the bug with 13.04 64, at least with sending. Thanks to #36 chrmhoffmann!

Andre1ch (andre1ch) on 2013-09-10
Changed in gnome-bluetooth (Ubuntu):
assignee: nobody → Andre1ch (andre1ch)
assignee: Andre1ch (andre1ch) → nobody

I can confirm this too, Ubuntu 13.04.

Yes I too have same problem; the weird black screen with white lines of some info scrolling up the screen. I'm connecting a bluetooth GPS device using rfcomm and the system crashes randomly while connecting. I desperate need the fix!

Tomas (kvasnica-tomas) wrote :

Same problem ("GDBus.error.org.openobex.Error.Failed:Unable to request session") on 13.10.

Sergio Callegari (callegar) wrote :

just upgraded to 13.10. bluetooth is now totally useless.

adding device: timeouts if you tick for dun networking

selecting browse files from bluetooth indicator: does nothing at all. does not even open nautilus

sending files: GDBus.error.org.openobex.Error.Failed:Unable to request session

trying to send file from phone: fails

bluetooth-applet: missing from package

IMPORTANT:

to satya: do not try to use rfcomm. it's utterly broken, crashes the system and the crash happens in such a way that it is delayed wrt the actual issue causing it. for seconds, maybe minutes, your kernel works with data areas that may get rewritten with garbage. scary. may lead to severe data loss. now fixed in kernel 3.12 but fix will not be backported and ubuntu does not even ack that there is a bug and keeps resetting bug report to unconfirmed/incomplete state.

kmajaa (k-majaa) wrote :

I have the same bug in newly installed ubuntu 13.10 (clean install).
There was a problem with even pairing my Galaxy SII phone with my Dell Latitude E4300. When I tried to pair it via the phone, it did, but I couldn't send or receive files from and to any of the devices. But when I tried to pair it via my laptop, it wouldn't even pair. Just the message that it failed. Also in both cases no request or message was seen on any device.
I managed to pair it, however, trying to do it on both devices simultaneously. And then the message appears on both devices.
I still wasn't able to send or receive files because the connection was off according to my laptop. However, I found a workaround for this too - you have to establish the connection, e.g. try to connect from the phone (it establishes the connection for a few seconds) and while it's on, send the file(s). It works then. I only tried it with a small picture though. I hope it helps someone who needs it.
Previously, in ubuntu 12.04, I was able to use it with my previous phone (SE G502) but only through "browse files on the device" or sending files, it wouldn't receive files.
Anyway, it would be nice to be able to use bluetooth without any problems.

HRJ (harshad-rj) wrote :

bluez-simple-agent worked for me too (echoing #44) for sending files from PC to device. Haven't tried receiving files into the PC yet.

Øyvind (sieges) wrote :

Experiencing same bug. Clean Ubuntu 13.10 on Sony Vaio Pro Haswell and Sony Xperia Z1 phone.

GrandMA (penalscum) wrote :

Same issue here, with Nexus 7 and Ubuntu 13.10 on Asus 1215B.

August Quint (augustq) wrote :

I have the same problem: Ubuntu 13.10 (64bit) with a THL W200.

description: updated
Changed in gnome-bluetooth (Ubuntu):
assignee: nobody → Ahmed Elgamal (me-ahmedelgamal)
Mayank Suman (mayanksuman) wrote :

Just run "bluez-simple-agent" (terminal or Alt + F2) then you will be able send files.
It is better to add this in startup applications.

Manuel Xosé Lemos (mxlemos) wrote :

Run "bluez-simple-agent" and still not work (Ubuntu 13.10)

José Lou Chang (obake) on 2013-12-29
tags: added: bluetooth bluetooth-menu bluez-simple-agent connection gnome-bluetooth indicator-bluetooth unity

-- Partially solved --

I did a fresh install of Ubuntu 13.10 to Sony Vaio. I had bluetooth file transfer (both ways) working nicely before that in 12.04. Now I faced this problem.

I managed to partially fix the problem of transferring files from phone to computer by doing the following:
1. I installed the package "gnome-user-share"
2. Started "Personal File Sharing" from Ubuntu menu
3. Added ticks to following boxes
- Share public files over Bluetooth
- Require remote devices to bond with this computer
- Receive files in Downloads folder over Bluetooth
- Notify about received files

This solved the problem with receiving files from mobile device (Android in my case) to computer. Which is the most important part for me.

But I still can't send files from computer to the mobile through Bluetooth. If I try this, I get the error message: "GDBus. Error:org.openobex.Error.Failed: Unable to request session"

Sayantan Das (sayantan13) wrote :

Running bluez-simple-agent, as specified in #54 , does the trick in UBuntu 14.04

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1148033

tags: added: iso-testing
Ali Najafi (alinajafi) wrote :

I found this bug fixed on Trusty beta with the recent updates.

hazem (mostafa-esml) wrote :

as post #36 said , the command bluez-simple-agent works for dending files to smartphone , but not receiving

Royalist (royalist10-2) wrote :

I have installed Blueman also, but on pushing files and receiving the above error message, the system crashes with a black terminal/screen and reams of reading matter.

Royalist (royalist10-2) wrote :

Using Ubunu 12.10 on a Netbook and on Desktop machine when this happened. Also I have a Nexus 7 in the background on Android 4.3

mariano (mariano.j) wrote :

Sending files from notebook (Ubuntu 14.04) to smartphone (SG2, Android 4.1.2) worked yesterdays, does not today. Sending files now produces the error message in the subject. Nothing on the system was changed.

Running the command bluez-simple-agent produces this:

> user@box:~$ bluez-simple-agent
> Traceback (most recent call last):
> File "/usr/bin/bluez-simple-agent", line 138, in <module>
> adapter.RegisterAgent(path, capability)
> File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 70, in __call__
> return self._proxy_method(*args, **keywords)
> File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
> **keywords)
> File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
> message, timeout)
> dbus.exceptions.DBusException: org.bluez.Error.AlreadyExists: Already Exists

Installed package blueman. Sending files failed in 4 out of 5 cases.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions