Ubuntu

Bluetooth no longer working after upgrade to Feisty

Reported by useResa on 2007-04-26
46
Affects Status Importance Assigned to Milestone
gnome-bluetooth (Ubuntu)
Undecided
Bluetooth

Bug Description

Binary package hint: gnome-bluetooth

Since my upgrade to Feisty my mobile phone (SAMSUNG SGH-D900) can no longer connect to my laptop (DELL Latitude D620). It used to work flawlessly in Edgy.
What I used to do is go to Applications --> Accessories --> Bluetooth File Sharing, switch on bluetooth on my phone and I could transfer files between my laptop and my phone. Since the upgrade my phone cannot find my laptop anymore.

If I use hcitool (either scan or dev) no devices are found. If I issue the command "sudo hciconfig hci0 reset" and then try the command hcitool (both scan and dev) the devices are found.
However, transfer of files is impossible because the phone does not detect my laptop.

I have also made a thread about this, which can be found here: http://ubuntuforums.org/showthread.php?t=421466

If more information is required, please let me know

useResa (rdrijsen) wrote :
Andrew Fenn (andrewfenn) wrote :

I am also experiencing this problem. My built in Bluetooth is not being detected in 7.04 after upgrading. My Bluetooth was automatically detected in both Dapper and Edgy before.

My laptop specs: https://wiki.ubuntu.com/LaptopTestingTeam/SamsungR55
My Hardware Database id: 350252f289c4aa776cb168b159a2f6d2

WillSmith (undertakingyou) wrote :

Similar Problem, in Dapper and Edgy my bluetooth keyboard and mouse auto-connected. Right after feisty update I have to fight and get the keyboard/mouse working so I can login. When I try to run hcitool scan nothing comes up. No such devices, and I can't get the devices to reset. I am using the Logitech Dinovo Desktop Laser Keyboard, Mouse and Mediapad. With the Logitech Mini Bluetooth receiver plugged into USB.

useResa (rdrijsen) wrote :

In further search on how to get bluetooth working again, today I installed the package obexpushd.
This results in the fact that I no longer have to issue the command "sudo hciconfig hci0 reset", but that my phone is immediately detected when using "hcitool scan".

However, I still can not transfer files from my phone to my laptop.

Andrew Fenn (andrewfenn) on 2007-05-02
Changed in gnome-bluetooth:
status: Unconfirmed → Confirmed
Andrew Fenn (andrewfenn) wrote :

Did you try installing the other obex packages? Perhaps that would help?

useResa (rdrijsen) wrote :

I tried that and no success. Unfortunately.
Still don't understand how the upgrade could have stopped it from working.
Is a different package used?

Andrew Fenn (andrewfenn) wrote :

I have no idea either. I just upgraded to feisty and my Bluetooth just completely vanished.

Onkar Shinde (onkarshinde) wrote :

Someone ...
1. Make sure that bluez-gnome package is installed.
2. Please attach /etc/bluetooth/hcid.conf
3. Try installing package gnome-vfs-obexftp, relogin and try discovery & transfer by typing obex:// in nautilus location bar.

useResa (rdrijsen) wrote :

Regarding your suggestions, please find the results of my tests.
1. Confirmation of installation of bluez-gnome package
rdrijsen@rdrijsen-laptop:~$ sudo apt-get install bluez-gnome
Reading package lists... Done
Building dependency tree
Reading state information... Done
bluez-gnome is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

2. Attach /etc/bluetooth/hcid.conf
As requested

3. Try installing gnome-vfs-obexftp package
rdrijsen@rdrijsen-laptop:~$ sudo apt-get install gnome-vfs-obexftp
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  gnome-vfs-obexftp
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 44.3kB of archives.
After unpacking 152kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com feisty/universe gnome-vfs-obexftp 0.2-0ubuntu1 [44.3kB]
Fetched 44.3kB in 0s (115kB/s)
Selecting previously deselected package gnome-vfs-obexftp.
(Reading database ... 252684 files and directories currently installed.)
Unpacking gnome-vfs-obexftp (from .../gnome-vfs-obexftp_0.2-0ubuntu1_i386.deb) ...
Setting up gnome-vfs-obexftp (0.2-0ubuntu1) ...

useResa (rdrijsen) wrote :

Typed obex:// in the nautilus bar (which btw changes to obex:///), the result is attached.

Additional comment:
Initially hcitool scan gave the following result
Device is not available: No such device
And hcitool gave the result
Devices:

After issuing the command sudo hciconfig hci0 reset, the results altered.
For hcitool scan into:
Scanning ...
        00:17:D5:A6:6A:E4 SGH-D900
And for hcitool dev into:
        hci0 00:16:41:8F:C3:58

The attachment shows the result AFTER the command sudo hciconfig hci0 reset.

Andrew Fenn (andrewfenn) wrote :

After installing "bluez-gnome" package and then typing "sudo hciconfig hci0 reset" I was able to detect my Bluetooth again with "hcitool dev".

My Bluetooth is not coming up in "/dev/rfcomm0" though as it did before with the same configuration so I can not connect to my phone

Andrew Fenn (andrewfenn) wrote :

Typing either "sudo hciconfig hci0 up" or "sudo hciconfig hci0 reset" gets me my bluetooth device detected in "hcitool dev" but for some reason my internal bluetooth is displaying as a usb device?!

I still can't connect, but I can do "hcitool scan" works.

andrew@andrew-laptop:~$ hciconfig hci0 version
hci0: Type: USB
        BD Address: 00:16:CE:F2:B0:EB ACL MTU: 1017:8 SCO MTU: 64:0
        HCI Ver: 2.0 (0x3) HCI Rev: 0x2081 LMP Ver: 2.0 (0x3) LMP Subver: 0x4127
        Manufacturer: Broadcom Corporation (15)
andrew@andrew-laptop:~$ hciconfig hci0 features
hci0: Type: USB
        BD Address: 00:16:CE:F2:B0:EB ACL MTU: 1017:8 SCO MTU: 64:0
        Features: 0xff 0xff 0x8d 0xfe 0x9b 0xf9 0x00 0x80
                <3-slot packets> <5-slot packets> <encryption> <slot offset>
                <timing accuracy> <role switch> <hold mode> <sniff mode>
                <park state> <RSSI> <channel quality> <SCO link> <HV2 packets>
                <HV3 packets> <u-law log> <A-law log> <CVSD> <power control>
                <transparent SCO> <broadcast encrypt> <EDR ACL 2 Mbps>
                <EDR ACL 3 Mbps> <enhanced iscan> <interlaced iscan>
                <interlaced pscan> <inquiry with RSSI> <extended SCO>
                <EV4 packets> <EV5 packets> <AFH cap. slave>
                <AFH class. slave> <3-slot EDR ACL> <5-slot EDR ACL>
                <AFH cap. master> <AFH class. master> <EDR eSCO 2 Mbps>
                <EDR eSCO 3 Mbps> <3-slot EDR eSCO> <extended features>
andrew@andrew-laptop:~$ hciconfig hci0 name
hci0: Type: USB
        BD Address: 00:16:CE:F2:B0:EB ACL MTU: 1017:8 SCO MTU: 64:0
        Name: 'BCM2045'

andrew@andrew-laptop:~$ sudo hidd --connect 00:16:CE:F2:B0:EB
Can't get device information: No route to host

Andrew Fenn (andrewfenn) wrote :

I should also note that when I restart my laptop I have to type this every time.

andrew@andrew-laptop:~$ hcitool dev
Devices:
andrew@andrew-laptop:~$ sudo hciconfig hci0 reset
Password:
andrew@andrew-laptop:~$ hcitool dev
Devices:
        hci0 00:16:CE:F2:B0:EB
andrew@andrew-laptop:~$ sudo hcitool cc 00:19:2C:86:53:83
andrew@andrew-laptop:~$ sudo hcitool auth 00:19:2C:86:53:83
Not connected.

My laptop does NOT connect when issuing "sudo hcitool cc 00:19:2C:86:53:83" command as there is an indicator on my mobile to prove it.

manzano (manzano-vocamen) wrote :

On a fresh new install of Unbuntu 7.04 (on desktop machine, not laptop), I had to install all bluetooth packages I found in Synaptic (weren't there by default like in Edgy), then reboot and it works (well except for mounting my Nokia FS via Symbian).

Before I reboot it couldn't pair.

Andrew Fenn (andrewfenn) wrote :

Could you list which packages you had to install so that we can check that we haven't missed something.

linuxsurfer (linuxsurfer) wrote :

I am having the same trouble that everyone else has had...my bluetooth DUN connection with my Treo 650 worked fine in Edgy, but now in Feisty it no longer works. Any help anybody can give would be appreciated. Otherwise I am relegated to (shudder) Vista, where the Bluetooth DUN works without a hitch.

josh@josh-laptop:~$ hciconfig
hci0: Type: USB
        BD Address: 00:02:72:05:D3:C3 ACL MTU: 1017:8 SCO MTU: 64:0
        UP RUNNING PSCAN
        RX bytes:5367 acl:61 sco:0 events:186 errors:0
        TX bytes:2461 acl:71 sco:0 commands:88 errors:0

hcitool cc produces no output, but hcitool auth says "not connected".

Even with my DUN turned on on the treo:
josh@josh-laptop:~$ hcitool scan
Scanning ...
        00:07:E0:20:78:75 jstroup

my /etc/bluetooth/hcid.conf:
josh@josh-laptop:~$ cat /etc/bluetooth/hcid.conf
#
# HCI daemon configuration file.
#

# HCId options
options {
        # Automatically initialize new devices
        autoinit yes;

        # Security Manager mode
        # none - Security manager disabled
        # auto - Use local PIN for incoming connections
        # user - Always ask user for a PIN
        #
        security auto;
        #pin_helper /etc/bluetooth/feed-pin.sh;

        # Pairing mode
        # none - Pairing disabled
        # multi - Allow pairing with already paired devices
        # once - Pair once and deny successive attempts
        pairing multi;

        # Default PIN code for incoming connections
        passkey "0000";
}

# Default settings for HCI devices
device {
        # Local device name
        # %d - device id
        # %h - host name
        name "%h (%d)";

        # Local device class
        #class 0x50020c
        class 0x3e0100;
        #class 0x100;
        # Default packet type
        #pkt_type DH1,DM1,HV1;

        # Inquiry and Page scan
        iscan enable; pscan enable;
        discovto 0;

        # Default link mode
        # none - no specific policy
        # accept - always accept incoming connections
        # master - become master on incoming connections,
        # deny role switch on outgoing connections
        lm accept,master;

        # Default link policy
        # none - no specific policy
        # rswitch - allow role switch
        # hold - allow hold mode
        # sniff - allow sniff mode
        # park - allow park mode
        lp rswitch,hold,sniff,park;
        auth enable;
        encrypt enable;
}

my /etc/bluetooth/rfcomm.conf:

josh@josh-laptop:/etc/bluetooth$ cat rfcomm.conf
#
# RFCOMM configuration file.
#

rfcomm0 {
# # Automatically bind the device at startup
        bind yes;
#
# # Bluetooth address of the device
        device 00:07:e0:20:78:75;
# device 11:22:33:44:55:66;
#
# # RFCOMM channel for the connection
        channel 1;
#
# # Description of the connection
        comment "Treo650";
# comment "Example Bluetooth device";
}

Andrew Fenn (andrewfenn) on 2007-05-21
Changed in gnome-bluetooth:
assignee: nobody → bluetooth
Alex Freer (alex-freer) wrote :

Exact problem, but in kubuntu 7.04

Using generic usb bluetooth module, worked fine on dapper and edgy on Dell dimension.
SDP errors pop up on book until command:

# sudo hciconfig hci0 reset

Then

# hcitool scan

can find devices, but cannot connect with them. Other devices cannot discover computer. Trial-and-error test of addresses (to find undiscoverable bluetooth devices) could not be attempted. Has anyone tried?

yongwanee (e-man-88) wrote :

I think I have a similar problem. I have a Samsung D800, and I cannot send files from my phone to my hp dv5000 laptop (Feisty) which has bluetooth built-in.

hcitool dev:

Devices:
        hci0 00:16:41:7D:59:99

hcitool scan:

Scanning ...
        00:17:D5:37:EB:56 D800

So it seems the computer can detect both its bluetooth and my phone. But when I try to send a file from my phone, the Samsung is unable to detect my computer.

Is there any solution to this?

Matt Wallace (mmw-old) wrote :

This is also not working on any of my computers running 7.04 with generic USB dongles. It was working fine until the upgrade to Feisty.

The main issue I have is that hcitool can detect the phone after a scan, however when "hcitool cc" is issued I do not have enough time to type "hcitool auth". The BT icon on my phone changes for about 0.5 of a second to "connection active" ( the usual "B<" plus "<>") and then looses the connection again.

I have tried restarting, reinstalling and resetting the pairings (deleted everything in /var/lib/bluetooth), the hcid.conf, dbus and rfcomm.conf to no avail.

Does anyone have either further ideas for me to try or a patch for this? I have discovered that this seems to affect other distros, so I am wondering if this is an up-stream issue.

Cheers,

M.

Andrew Fenn (andrewfenn) wrote :

With regards to the issue of you not having enough time to auth...

I believe that is because there is "no route to host". Which is the error I am getting when I tired connecting to the phone in various ways.

Matt Wallace (mmw-old) wrote :

Andrew,

Which tools do you get this issue with? I seem to be able to do an OBEX-Push to the phone without it being paired (although I'm not at my PC right now to check this!) it just won't pair.

M.

I have bought a Dell Latitude D800 and when it had Windows, the Bluetooth was working. When I removed Windows and installed Ubuntu 7.04 Feisty Fawn, the Bluetooth stopped working. I checked out at my computer's BIOS and I found out that it was saying "Onboard bluetooth: Not installed". I have installed every single package I found in the repositories related to Bluetooth, but with no success.

I don't know if that helps, but some guys claimed to have their Bluetooth disabled right after enabling the Wireless, or installing some drivers for the Wireless. I don't know how much truth there is in that, but it may be connected with bug #122419. Anyway, I don't remember having Bluetooth since I installed Ubuntu 7.04 Feisty Fawn.

robin (robinch) wrote :

At one point, for no reason at all, the phone stops detecting my laptop. The laptop can detect the phone and send files, but the phone CANNOT detect the laptop.

Do: hciconfig -a
Look for "UP RUNNING" at the 3rd line
It shows exactly that on my feisty.

Do: sudo hciconfig hci0 piscan
Then it shows "UP RUNNING PSCAN ISCAN" and that's when the phone can see the computer again.

Hope it's relevant.

useResa (rdrijsen) wrote :

I have tried the above option. First I needed to do a sudo hciconfig hci0 reset.
Doing a hcitool scan shows that my phone is detected

0 rdrijsen@rdrijsen-laptop: ~
Sun Aug 12, 22:26 $ hcitool scan
Scanning ...
        00:17:D5:A6:6A:E4 SGH-D900

Next I did hciconfig -a

0 rdrijsen@rdrijsen-laptop: ~
Sun Aug 12, 22:26 $ hciconfig -a
hci0: Type: USB
        BD Address: 00:16:41:8F:C3:58 ACL MTU: 384:8 SCO MTU: 64:8
        UP RUNNING
        RX bytes:374 acl:0 sco:0 events:14 errors:0
        TX bytes:51 acl:0 sco:0 commands:10 errors:0
        Features: 0xff 0xff 0x9f 0xfe 0x9b 0xf9 0x00 0x80
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
        Link policy:
        Link mode: SLAVE ACCEPT
        Name: 'Dell Wireless 350 Bluetooth Internal Car'
        Class: 0x000000
        Service Classes: Unspecified
        Device Class: Miscellaneous,
        HCI Ver: 2.0 (0x3) HCI Rev: 0x976 LMP Ver: 2.0 (0x3) LMP Subver: 0x976
        Manufacturer: Cambridge Silicon Radio (10)

Indeed UP RUNNING is indicated in the 3rd line.
So I did -- as suggested -- hciconfig hci0 piscan
The result of hciconfig -a indeed altered

0 rdrijsen@rdrijsen-laptop: ~
Sun Aug 12, 22:27 $ hciconfig -a
hci0: Type: USB
        BD Address: 00:16:41:8F:C3:58 ACL MTU: 384:8 SCO MTU: 64:8
        UP RUNNING PSCAN ISCAN
        RX bytes:1295 acl:1 sco:0 events:34 errors:0
        TX bytes:132 acl:1 sco:0 commands:19 errors:0
        Features: 0xff 0xff 0x9f 0xfe 0x9b 0xf9 0x00 0x80
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
        Link policy:
        Link mode: SLAVE ACCEPT
        Name: 'Dell Wireless 350 Bluetooth Internal Car'
        Class: 0x000000
        Service Classes: Unspecified
        Device Class: Miscellaneous,
        HCI Ver: 2.0 (0x3) HCI Rev: 0x976 LMP Ver: 2.0 (0x3) LMP Subver: 0x976
        Manufacturer: Cambridge Silicon Radio (10)

However ... my phone still does NOT detect my laptop.
So for me this was no solution.

Curtis Nelson (stylebox) wrote :

I was having the same problem with a fresh feisty install on my Dell Inspiron 6400. Seemed I didn't have all the necessary bluetooth packages installed. I already had gnome-bluetooth and bluez-utils. After apt-get install bluetooth bluez-gnome, I was able to set the visibility of the notebook from the system preferences bluetooth config and from my phone I was finally able to pair with the computer. From there everything seemed fine and I used wammu to sync my contacts and transfer old contacts from my previous phone. Hope this helps a bit.

useResa (rdrijsen) wrote :

I have all four packages that you indicate already installed (checked with dpkg -s <package name>).
I indeed have heard that people were able to set their visibility through System --> Preferences --> Bluetooth Preferences.
However, see also attachment, I can only set the visibility of the icon not of my laptop.

I have tried a reinstall of the two packages that you mentioned (bluetooth and bluez-gnome), followed by a restart of my X session but that did not make a difference.

Robin, you should see if you, by mistake, disabled the Bluetooth of your computer, with a key combination.

balopat (patobalint) wrote :

Gromit, Andrew to the "timing issue":

The bluez packages and all the BT related packages I found are installed.

- hcitool scan recognizes the phone
- hcitool cc connects to the phone for about half a second (I can see ot my phone)
- if I call hcitool auth during the active connection, it throws an Authentication failed: Input/Output error (sg like that).
- if I call it _after_ the half second it throws: Not connected.

I can use the Obex File Transfer as well, without pairing.
I cannot use the Obex Bluetooth Chat: at the point of authentication, my phone asks for the pairing key but ubuntu doesn't show the dialog to enter it. I tried the default key 1234, what I found in the hciconfig but it was useless too.

I'm looking forward to the solution of this problem, or any workaround.

Steinar Bang (sb-dod) wrote :

I see this bug with a Dell Latitude D610 laptop, and a Sony Ericsson K600i phone:
 - hcitool scan shows the phone
 - hcitool cc registers the laptop with the phone
 - hcitool auth reports back
     Not connected

So it's a bug confirmation in case that's needed.

t3boyo (mr-mcclain-cdms) wrote :

I've got a similar bluetooth problem. I have a logitech bluetooth keyboard and mouse that worked great with 6.04, but when I boot 7.04 and start moving my mouse it will go dead. The little LCD screen on my keyboard says (no connection). I crawl behind the computer and disconnect the little square receiver and plug it back in, and it all starts working again and I can log in and start using it. It did the same thing when I booted from the live CD, but I figure an update would cure it. Unfortunately updates haven't addressed it, and I've got my computer set on dual boot, and as much as I want my wife to get comfortable with ubuntu, she's not savvy enough to do that every time the computer boots up, so for now I tell her to scroll down in GRUB and use XP until I can figure it out. Anyone know of a setting that is off by default that wasn't off by default in the last 2 releases.

Sir Nikon (omnineko) wrote :

Perhaps I should start a new bug...?

This issue has NOT been resolved with the recent Gutsy upgrade. In fact, it seems to be worse.

I no longer am able to use my DiNovo keyboard. The mouse still works but the same issue seems to occur.

Once the login screen is displayed, Bluetooth stops working and does not come back until I unplug the dongle and plug it in to a new port.

:( This is quite a bit frustrating. It was nice how well Ubuntu supported my hardware but it seems to have taken a step back with the latest release (I mean, come on, LOSE support for my KEYBOARD?!).

useResa (rdrijsen) wrote :

This might be a good suggestion ... the bluetooth issue is also not resolved for me.
If you do start a new bug, please provide the link here.
In that case all that have posted here can provide their info in the new bug as well.

So, it still seems that in Gutsy and Linux 2.6.22 this has not been fixed.

I can confirm I still have the problem on Gutsy, but it is not a kernel
issue; when running Fedora 8 bluetooth works flawlessly.

On Jan 7, 2008 12:23 PM, Indy <email address hidden> wrote:

> So, it still seems that in Gutsy and Linux 2.6.22 this has not been
> fixed.
>
>
>

Sir Nikon (omnineko) wrote :

Yes, it is still an issue with 7.10.

i have install my windows and was upgrading my dell bluetooth 350 module's driver. during installation , by mistake i restarted my laptop d510 latitude..

after restart my laptop is not detecting the internal bluetooth module neither in device manager nor in BIOS also...

please provide me a solution for this.

varun bakshi

<email address hidden>

spec10 (spectator) wrote :

is there anyone working on this? Considering how long gutsy is now "on the market" it's a shame that this still is an issue!

Many people who dual-boot Ubuntu and Windows, say that if you download and install the drivers from the DELL website, in Windows, bluetooth starts working in Ubuntu, as well. Obviously, the Windows drivers enable the bluetooth from BIOS, so, Ubuntu can recognize the onboard bluetooth. I think the solution is to make the Ubuntu drivers able to enable the onboard bluetooth in BIOS.

Alex Freer (alex-freer) wrote :

This certainly isn't true for me; bluetooth has always worked in windows with the generic windows xp drivers. However, there is good news - using the liveCD version of Kubuntu 8.04 Beta (KDE4 version). I'll be migrating to 8.04 soon.

I installed Gutsy x64 on my Macbook Pro 3.1 from the Live CD this week, then decided to do a reinstall from the Alt CD to take advantage of the LUKS drive encryption. Bluetooth worked like a charm under the Live CD, but I'm getting nothing after reinstalling. hcitool scan yields "no such device." It's a built-in bluetooth module. Bluetooth works fine in OS X. This is my first post here, so please let me know if there's more info needed.

zenith (lasse-bigum) wrote :

I have a Bluetooth USB dongle and the bluetooth module was loaded, however no bluetooth icon was shown in the notification area.

dmesg | less showed that the module was loaded correctly and lsusb showed that it found and correctly identified my dongle.

I had to install bluez-util before it started working for me.

So I think that either bluez-util needs to be installed always, or there is a bug/issue here.

useResa (rdrijsen) wrote :

Recently I have performed a clean install of Hardy (initially I upgraded).
It pleases me to indicate that now bluetooth is working as it should.

From my point of view this issue can be considered as solved.
I have also indicated this in the thread I had on this issue (see http://ubuntuforums.org/showthread.php?t=421466)

Mario Limonciello (superm1) wrote :

marking solved per user comment

Changed in gnome-bluetooth:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers