gnome-art doesn't show up when clicking it.

Bug #228552 reported by Sriram on 2008-05-09
46
Affects Status Importance Assigned to Milestone
gnome-art (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-art

Ubuntu 8.04
gnome-art just blinks and disappears when trying to run it.
The installed version is "0.2-8ubuntu2"

Here is the backtrace if i open gnome-art in a terminal:

sriram@sriram-desktop:~$ gnome-art
/usr/lib/ruby/1.8/net/protocol.rb:133:in `sysread': Connection reset by peer (Errno::ECONNRESET)
 from /usr/lib/ruby/1.8/net/protocol.rb:133:in `rbuf_fill'
 from /usr/lib/ruby/1.8/timeout.rb:56:in `timeout'
 from /usr/lib/ruby/1.8/timeout.rb:76:in `timeout'
 from /usr/lib/ruby/1.8/net/protocol.rb:132:in `rbuf_fill'
 from /usr/lib/ruby/1.8/net/protocol.rb:116:in `readuntil'
 from /usr/lib/ruby/1.8/net/protocol.rb:126:in `readline'
 from /usr/lib/ruby/1.8/net/http.rb:2020:in `read_status_line'
 from /usr/lib/ruby/1.8/net/http.rb:2009:in `read_new'
  ... 10 levels...
 from /usr/lib/ruby/1.8/open-uri.rb:30:in `open'
 from /usr/lib/ruby/1.8/gnome-art/gnome_art.rb:156:in `isConnected'
 from /usr/lib/ruby/1.8/gnome-art/gnome_art.rb:132:in `main'
 from /usr/bin/gnome-art:25

Uroš Gaber (uros-gaber) wrote :

This happens to me to in ubuntu 8.04 with all updates.

korvins (katarata) wrote :

exactly the same here with 8.04 and all the updates

Nicolas Diogo (nicolasdiogo) wrote :

Same here too

Same here, all updates on ubuntu 8.04
Tried reinstalling all related packages without success.

Joel Duncan (joelcduncan) wrote :

Same problem here. Just found this link http://linux.softpedia.com/get/Desktop-Environment/Tools/Gnome-Art-NG-37496.shtml I am going to try it out. Really hope this works!

Joel Duncan (joelcduncan) wrote :

No luck for me...it starts updating an XML file and then disappears before i can OK the error message. Hope you guys have it better, here's my output:

joel@eljoe1:~$ gnomeartng
dtUbuntu

(GnomeArtNg:13222): Gtk-CRITICAL **: gtk_window_resize: assertion `width > 0' failed

Unhandled Exception: System.IO.FileNotFoundException: Could not find file "/home/joel/.gnome2/gnome-art-ng/gnomeArt10.xml".
File name: '/home/joel/.gnome2/gnome-art-ng/gnomeArt10.xml'
  at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) [0x00000]
  at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share) [0x00000]
  at (wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare)
  at System.Xml.XmlUrlResolver.GetEntity (System.Uri absoluteUri, System.String role, System.Type ofObjectToReturn) [0x00000]
  at Mono.Xml2.XmlTextReader.GetStreamFromUrl (System.String url, System.String& absoluteUriString) [0x00000]
  at Mono.Xml2.XmlTextReader..ctor (System.String url, System.Xml.XmlNameTable nt) [0x00000]
  at System.Xml.XmlTextReader..ctor (System.String url, System.Xml.XmlNameTable nt) [0x00000]
  at System.Xml.XmlDocument.Load (System.String filename) [0x00000]
  at GnomeArtNG.CArtManager.parseXMLFile () [0x00000]
  at GnomeArtNG.CArtManager.getParseAndCreate (Boolean ForceReload) [0x00000]
  at GnomeArtNG.CArtManager.set_ArtType (ArtType value) [0x00000]
  at GnomeArtNgApp.OnSwitchPage (System.Object sender, Gtk.SwitchPageArgs s) [0x00000]
  at GnomeArtNgApp..ctor (System.String[] args) [0x00000]
  at GnomeArtNgApp.Main (System.String[] args) [0x00000]
joel@eljoe1:~$

Joel Duncan (joelcduncan) wrote :

And after a bit more diggin it seems to be a problem with the app:

http://ubuntuforums.org/showthread.php?p=4927639#post4927639

Tarnay Kálmán (tarnay-kalman) wrote :

same error, same version, hardy

Changed in gnome-art:
status: New → Confirmed

exactly the same error messages as you guys, both with the old art manager as originally reported and with gnomeartng as reported by duncan, same version (Hardy Heron 8.04 stable with compiz installed via git)

Retromingent (ray-rwalk2730) wrote :

I get the same error.

nabdan (nabil2) wrote :

Same error, same version (Ubuntu 8.04).

korvins (katarata) wrote :

gnome-art is not supported any more, but gnome-artng is the successor of it.

http://www.miketech.net/gnome-art/

I think Ubuntu should simply deprecate gnome-art and include gnome-artng which works perfectly well (with more features) in 8.04.

David Robert Lewis (afrodeity) wrote :

Why isn't it in the repos? Looking for a ppa to include it instead of having to download the deb.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers