Gnome-Applets (Invest) - ^DJI symbol stopped showing

Bug #635310 reported by sirald66 on 2010-09-10
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-applets (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-applets

DELL LATITUDE D600
UBUNTU 9.10 +proposed
GNOME 2.28.1
GNOME-APPLETS 2.28.0
INVEST 2.28.0

EXPECTED: Have been using stock symbols ^DJI, ^W1DOW, FXI, EWU - to pull Dow Jones Industrial Average, Dow Jones Global Index, iShares FTSE/Xinhua China 25 Index and iShares MSCI United Kingdom Index since February 2010 from the Yahoo Finance servers without problems.

ACTUAL: ^DJI shows under preferences, but no longer displays. Have tried: deleting/restoring ^DJI and/or all of the symbols; removing/restoring to panel; deleting ~/.gnome2/invest-applet/stocks.pickle

ProblemType: Bug
Architecture: i386
CheckboxSubmission: a4c8a5401b1e450828d3582bd9d33b9e
CheckboxSystem: efd05939b08abfe86caa44c3820f8e56
Date: Fri Sep 10 14:44:32 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: gnome-applets 2.28.0-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-22.64-generic
SourcePackage: gnome-applets
Uname: Linux 2.6.31-22-generic i686

sirald66 (sirald66) wrote :
Tom Wimbish (oldwismn) wrote :

I am running 10.04.1 and I am also affected by this bug.

VinDSL (perfect-pecker) wrote :

Marked as affects me - Maverick (updated hourly)

Here are my preferences:

CLV10.NYM (OIL)
^DJI (Dow Jones Ind)
GCU10.CMX (Gold)
^GSPC (S&P 500)
^IXIC (Nasdaq)
^TNX (10-Year Treasury)

Everything works, except ^DJI (Dow Jones Ind).

VinDSL (perfect-pecker) on 2010-09-12
tags: added: gnome-applets gnome-invest
VinDSL (perfect-pecker) wrote :

Okay, I figured it out. This is NOT a bug after all.

I was pouring over the gnome-invest code, and couldn't find anything wrong.

Performing some creative web searches, I discovered that Yahoo! is no longer sending Dow data through their .CSV feed.

Alternately, you can get the Dow Jones Industrial data feed by using the symbol INDU, instead of ^DJI.

Hopefully, this feed will continue to work... :)

VinDSL (perfect-pecker) wrote :

I thought I'd better attach a screenie, to exemplify the workaround I'm using...

Changed in gnome-applets (Ubuntu):
importance: Undecided → Low
sirald66 (sirald66) wrote :

Digging further, it turns out Yahoo Finance contractually can no longer provide ^DJI.

Maybe Invest needs a new feed such as Google.

Changed in gnome-applets (Ubuntu):
status: New → Invalid
Johniac (jvaccaro-gmail) wrote :

After removing ^DJI and adding INDU, Invest now reports the "No stock quotes are currently available". After adding back ^DJI and having INDU in preferences, INDU displays correctly

sirald66 (sirald66) wrote :

Interesting observation, John.

I had added the INDU symbol without removing the ^DJI symbol, so had not noticed. So I tried this:

Add symbol ^DJI with label DOW-1, and add symbol INDU with label DOW-2. My popup shows DOW-1, but only if INDU is present; the applet gives a 'No stock quotes available' dialog error if ^DJI is not present.

Somehow INDU is only qualified if ^DJI is present, and then ^DJI displays -- not INDU. {weird}

sirald66 (sirald66) wrote :

It seems to me that Ubuntu needs to provide a different applet/feed, as the Dow Jones Industrial Average is a rather "major" for the United States market.

sirald66 (sirald66) wrote :

As of a few days ago, the solution (including symbols ^DJI and INDU) has stopped working. It is a bit over a year since this happened last time, so I suspect Yahoo Finance once again has closed the feed. [not like the Dow Industrial Average isn't important]

Ubuntu needs to select a better stock ticker applet.

sirald66 (sirald66) on 2011-09-26
Changed in gnome-applets (Ubuntu):
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers