Ubuntu

All sticky notes are erased when out of disk space

Reported by Mariano Dupont on 2006-09-21
38
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-applets
Fix Released
Critical
gnome-applets (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-applets

If disk usage reaches 100%, when you exit your gnome session, all your sticky notes will be erased. Next time you log in, they're all gone.

(Ubuntu Dapper)

Sebastien Bacher (seb128) wrote :

Thanks for your bug and for forwarding it upstream

Changed in gnome-applets:
assignee: nobody → desktop-bugs
importance: Untriaged → Medium
status: Unconfirmed → Confirmed
Changed in gnome-applets:
status: Unknown → Unconfirmed
Changed in gnome-applets:
status: Unconfirmed → Rejected
Sebastien Bacher (seb128) wrote :

from the upstream comments that should be fixed to feisty, closing. Feel free to reopen if you face the problem again

Changed in gnome-applets:
status: Confirmed → Fix Released
Changed in gnome-applets:
status: Rejected → Fix Released
florinn (florinnaidin) wrote :

I had this problem in Hardy one I did not know why at that time and now it happened again in Intrepid
Reaching out of disk space I lost all my sticky notes (along with other settings such as Nautilus bookmarks)

Jean-Paul Calderone (exarkun) wrote :

This just happened to me.

Description: Ubuntu 8.04.2
Release: 8.04

gnome-applets:
  Installed: 2.22.2-0ubuntu2
  Candidate: 2.22.2-0ubuntu2

So this does not appear to be fixed.

Changed in gnome-applets:
status: Fix Released → Confirmed
Pedro Villavicencio (pedro) wrote :

is anybody having this issue with jaunty? if so please comment upstream so the bug can be reopened, thanks.

Changed in gnome-applets:
status: Confirmed → Incomplete
Changed in gnome-applets:
status: Incomplete → Triaged
status: Triaged → New
Changed in gnome-applets (Ubuntu):
status: New → Triaged
xak (zach-xak) wrote :

This just happened to me upgrading from 8.10 Intrepid to 9.04 Jaunty. I installed root partition from scratch but left /home, but somehow my stickynotes got erased. This is bad since I lost some important recent changes that are not in my backup.

The /home partition is heavily used (92%), but was never completely full (about 4 GiB free).

freakalad (freakalad) wrote :

Still running 64 Hardy LTS

Issue just occurred to me; lost lots of important notes.

Notes are stored XML file ~/.gnome2/stickynotes_applet

There's no good reason why this should happen; overwriting some arbitrary files in home when space runs out

Jaunty 64bit. I've lost all of my notes numerous times, but it does not appear to be related to disk space. My /home partition is 50% free. Those experiencing this in Jaunty, please ensure it's related to disk space. If not, it's a different bug.

Alfonso Rodriguez (euoar) wrote :

Happens to me too, in jaunty 64 bits version. No relation with disk space for me...

Alfonso Rodriguez (euoar) wrote :

Have checked the file related by freakalad ~/.gnome2/stickynotes_applet and nothing is being stored there when I write a note.

Leo (linux-fractal) wrote :

This is also happens to me in 64-bit 9.04. No relation to disk space though. ./gnome2/sticknotes_applet is written to at logon when the note contents disappear. Does sticky_notes normally write to this file at log on?

I have the same experience as Leo, ./gnome2/stickynotes_applet is overwritten at logon. Notes are still retained but their contents are blanked (also the note size is altered). File details show that it was altered at logon.

This has just happened today, I have been using sticky notes and they have been retained after a reboot until now.

Sorry, forgot to mention I have 50Gb free space on my HDD.

CyJambo (cyjambo) wrote :

happened to me just now, using ubuntu 9.10. Just updated to kernel 2.6.31-19-generic... Not sure if that is why it happened, but all the notes are gone. Is there a way to recover them? I had some pretty important info on them... Thx!

Alfonso Rodriguez (euoar) wrote :

Usually those notes are stored in a folder called ".tomboy", in your home directory (eg. "/home/CyJambo/.tomboy") . You can look there if they're still stored and open them with a text editor. The folder is hidden -all the folders started with "." are, so just select in nautilus "View/Show hidden folders" -if you don't use directly use the shell, of course-.

Sebastien Bacher (seb128) wrote :

no, tomboy and the gnome-applet stickynotes are different softwares and those notes are not stored in the tomboy directory

Alfonso Rodriguez (euoar) wrote :

That's true, sorry. Don't know why I was thinking in tomboy. Never answer to anything before you have had the first coffee of the day...

simon (swht) wrote :

running 10.04 - during original distro update told me I'd used all 12 gigabyte of my partition - and then the same thing yesterday, also lost connectivity, was told that all 12 gig had been used, although only 8 were in use - and my sticky notes have all gone! Extremely annoying.
I did not have copies of that material anywhere else.

Changed in gnome-applets:
importance: Unknown → Critical
Leeteq (leeteq) wrote :

This just happened to me too on 10.04 LTS, but seemingly not related to disk space.

I had several notes, and while not using them for several weeks (maybe months), when I re-opened the application today, it shows zero notes. Numerous normal system updates have occurred since last time I used that application, and the system is completely updated with latest stable patches, last time this week.

During this period, I have not run out of disk space entirely, although I have had some warnings about disk space getting low, less than 2GB free etc., and on one point briefly down to 750mb available disk space on the /home drive due to reorganizing a lot of data, and then I freed up the space again right afterwards. The normal is having between 5-15GB free space there. Can that temporary drop that is not even close to zero still cause this?

How can such a bug remain unresolved across so many Ubuntu versions? This report is over 4 years old.

Can the title of this bug report be changed?
I think it is misleading as it seems not to be solely related to disk space problems, and that title may cause it to not be regarded as a high-priority case?
Data loss is indeed a critical issue.

(Fortunately, I have a manual backup of the text in those notes, stored in my favorite tool, TreePad Business Edition (secure Windows shareware tool that also have a server version) which I run nicely through Wine, as I am careful about securing my work, so I have basically not "lost" my information.)

Leeteq (leeteq) wrote :

Not long ago, this issue was given "critical" status _here_, while still pointing to a several years old fix over at bubzilla.gnome.org - where that related issue has the status of "completed".

I have posted a comment here:
https://bugzilla.gnome.org/show_bug.cgi?id=340766#c12

- and asked if the status should be updated.

Leeteq (leeteq) wrote :

This one does not seem to be resolved.
Ref. https://bugzilla.gnome.org/show_bug.cgi?id=340766#c12
I think this issue should be reopened, it was recently given "critical" priority, but the status was not adjusted accordingly.

Oscar Sosa (oscar-americo) wrote :

This had just happened to me right now, very frustrating, I lost important notes, I have Ubuntu 10.10 Linux 2.6.35-28-generic-pae #50-Ubuntu SMP i686 GNU/Linux.

Apparently this happened after a Firefox 4 crash when all my applets stop working, including for example SystemMonitor, so I rebooted my laptop and then all the notes were lost.

giffel (xgiffel) wrote :

This issue occurred on my machine too. I accidentally run out of disk space (0Bytes left) two days ago and now I find out all notes are gone. "stickynotes_applet" file is empty. Ubuntu 10.10 Linux 2.6.35-29-generic x86_64

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.