Invest-chart does not start

Bug #54701 reported by mvandeg on 2006-07-31
4
Affects Status Importance Assigned to Milestone
gnome-applets (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Invest-chart in gnome-applets 2.15.2-0ubuntu1 crashes with:

Data Dir: ${prefix}/share/gnome-applets

(invest-chart:14603): libglade-WARNING **: could not find glade file '${prefix}/share/gnome-applets/glade/financialchart.glade'
Traceback (most recent call last):
  File "/usr/bin/invest-chart", line 6, in ?
    win = invest.chart.show_chart(sys.argv[1:])
  File "/usr/lib/python2.4/site-packages/invest/chart.py", line 216, in show_chart
    ui = gtk.glade.XML(os.path.join(invest.GLADE_DATA_DIR, "financialchart.glade"))
RuntimeError: could not create GladeXML object

Gert Kulyk (gkulyk) wrote :

Can confirm this. To fix this without recompiling, change in /usr/lib/python2.4/site-packages/invest/defs.py the line

DATA_DIR = "${prefix}/share/gnome-applets"

into

DATA_DIR = "/usr/share/gnome-applets"

Changed in gnome-applets:
status: Unconfirmed → Confirmed
Martin Pitt (pitti) wrote :

Also, it's generally unclear from the menu what this thingy is supposed to do. It looks so financial business-ish and at first it caused a pretty allergic reaction. :)

Sebastien Bacher (seb128) wrote :

Fixed with this upload:

 gnome-applets (2.15.3-0ubuntu1) edgy; urgency=low
 .
   * New upstream version:
     Changes:
     - Fix trashapplet/drivemount .server files
     - gswitchit fixes
     - libgweather: check for NULL pointers
     - mixer: set ATK names
     - multiload: update tooltip only when needed
     - multiload: use inbuild panel transparency API
     - drivemount: use GNOME-VFS to determine if a drive needs ejecting or
       unmounting
     - gweather: make applet display properly on vertical panels
       (Ubuntu: #27812)
   * debian/patches/05_no_invest_menu_item.patch:
     - don't create an invest-applet menu item by default since that's not
       really a desktop user application
   * debian/patches/06_fix_invest_gconf_definition.patch:
     - fix GCONF_CLIENT not being defined
   * debian/patches/07_system_tools_pc_update.patch:
     - new patch, fix the system-tools-backend pc file name
   * debian/patches/09_invest_applet_shared_data_directory.patch:
     - fixed some issues with that patch (Ubuntu: #54701)
   * debian/patches/15_gnomevfs_query_eject.patch:
     - fixed with the new version

Changed in gnome-applets:
assignee: nobody → desktop-bugs
status: Confirmed → Fix Released
importance: Untriaged → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers