In Ubuntu Karmic, trash bin icon not showing trash when it contains trash

Bug #480439 reported by Adrien Lamothe on 2009-11-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-applets (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by madbiologist

Bug Description

This is the same bug as the one in Kubuntu, only it is occurring in Ubuntu and it didn't start happening until today (Nov 10, 2009) after I applied the latest upgrades.

Although the icon doesn't show trash, it does delete the trash when right-clicking and selecting "Empty Trash", so this is just a cosmetic problem.

Chris Johnston (cjohnston) wrote :

I am unable to replicate on two different machines both running 9.10.. Is this happening in the panel or somewhere else? What is the Kubuntu bug # for reference? Marking incomplete awaiting further info.

Changed in ubuntu:
status: New → Incomplete
Adrien Lamothe (a-lamothe) wrote :

The problem stopped occurring. Very strange. I'll let you know if it happens again. I can't find the Kubuntu bug again, in the future I'll note the bug number.

madbiologist (me-again) wrote :

I've just seen this on the Lucid Lynx 10.04 alpha 2, running from the live CD. I've previously upgraded gnome-panel to the latest 2.29.5.1-0ubuntu2 version if that matters.

Uname: Linux 2.6.32-10-generic i686

Steps to reproduce:

1. Open Nautilus and navigate to directory (Downloads in my case).
2. Delete file and close Nautilus.
3. Note that the trash bin icon does not show trash.
4. Mouse over trash bin icon and note that the tooltip says "No Items in Trash".
5. Click trash bin icon to open Trash - File Browser. Note that deleted file is present in trash.
6. Click the "Empty Trash" button and the file will be deleted.
7. Note that the trash bin icon does not show trash.

Changed in ubuntu:
status: Incomplete → Confirmed

I cannot reproduce this behavior. Marking as Invalid.

affects: ubuntu → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
status: Confirmed → Invalid
madbiologist (me-again) wrote :

@Mohamed - what version of Ubuntu are you using? Also what is the output of uname -srm on your system?

@madbiologist: I'm running Maverick. Maybe this has been fixed between Lucid and Maverick?
btw, uname -srm doesn't serve any purpose here - we're talking about a desktop bug, not about kernel bugs.

madbiologist (me-again) wrote :

It is possible that this has been fixed between Lucid and Maverick, but don't forget that Lucid desktop is supported until April 2013. Invalid may not be completely appropriate - we may need to create multiple targets/versions for this bug.

uname -srm is useful as a rough, initial way of knowing the state of someone's system. However since you seem competent with Ubuntu, what versions of the packages relevant to this bug are you using?

devildante@devildante-laptop:~$ apt-cache policy nautilus
nautilus:
  Installed: 1:2.31.90-0ubuntu3
  Candidate: 1:2.31.90-0ubuntu3
  Version table:
 *** 1:2.31.90-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
     1:2.31.3-0ubuntu7~ppa96 0
        500 http://ppa.launchpad.net/am-monkeyd/nautilus-elementary-ppa/ubuntu/ maverick/main i386 Packages
(I don't think the elementary team would have fixed that bug without notifying upstream)
Anyway, I think this should be Fix Released, since it was just fixed in Maverick.

Changed in nautilus (Ubuntu):
status: Invalid → Fix Released
madbiologist (me-again) wrote :

Thanks. What version of gnome-applets are you using. I'm booted into the Maverick alpha 3 Live CD at the moment, but will try to remember to report my gnome-applets version the next time I boot Lucid.

affects: nautilus (Ubuntu) → gnome-applets (Ubuntu)

devildante@devildante-laptop:~$ apt-cache policy gnome-applets
gnome-applets:
  Installed: 2.30.0-3ubuntu2
  Candidate: 2.30.0-3ubuntu2
  Version table:
 *** 2.30.0-3ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

It seems to not have changed since Lucid.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers