sound applet and notification icon create duplication

Bug #401294 reported by William Bohn on 2009-07-19
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-applets (Ubuntu)
High
Unassigned
Karmic
High
Unassigned
gnome-panel (Ubuntu)
Low
Sebastien Bacher
Karmic
Low
Sebastien Bacher

Bug Description

Asus EEE PC 1000HE running Ubuntu 9.10 Karmic.

Recently, the volume has been able to be increased to audible levels - this is good.

However, after a round of recent updates (the one that made the sound audible) also made two GNOME sound applets appear, one of which being gnome-volume-control-applet, and the other is mixer_applet2.

The problems are:

1. The sound keeps getting reset to lower levels while using Audacious or other applications that use sound. It happens right after it moves to the next song or a new sound-producing file is opened.

2. The GNOME Keyboard shortcuts for adjusting the sound seems to have no effect on these mixers/ volume controls. I believe it's controlling a different device, despite specifying preferences otherwise in the gnome-volume-control-applet.

3. Two sound applets is confusing, and they seem to be competing with each other.

Theo Nolte (theo-nolte) wrote :

same here on medion akoya md-96970 laptop 64bit.
First noticed the second sound-applet yesterday (sat, july 18)

caillean (caillean) wrote :

same here on karmic 64bit.
when i start ubuntu the sound applet is muted, i have to remove the hook at the option "mute" and then the sound is working well.
i uninstalled pulseaudio and the problem disappeared.
but uninstalling pulseaudio cant be the solution .

Anders Kaseorg (andersk) on 2009-07-19
affects: ubuntu → gnome-applets (Ubuntu)
Changed in gnome-applets (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

thank you for your bug report, one bug should describe on issue though, using this one for the duplicate issue

Changed in gnome-applets (Ubuntu):
importance: Undecided → Low
summary: - Karmic - 2 Sound Applets, No Keyboard Shortcuts, Sound Resetting
+ sound applet and notification icon create duplication
Martin Pitt (pitti) on 2009-07-22
Changed in gnome-applets (Ubuntu Karmic):
importance: Low → High
Changed in gnome-panel (Ubuntu Karmic):
importance: Undecided → Low
status: New → Fix Committed
assignee: nobody → Sebastien Bacher (seb128)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:2.27.4-0ubuntu3

---------------
gnome-panel (1:2.27.4-0ubuntu3) karmic; urgency=low

  * debian/patches/04_default_panel_config.patch:
    - don't add a mixer applet to the default configuration since gnome-media
      has a notification area icon for that now (lp: #401294)

 -- Sebastien Bacher <email address hidden> Wed, 22 Jul 2009 16:35:22 +0200

Changed in gnome-panel (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2009-07-22
Changed in gnome-applets (Ubuntu Karmic):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-applets - 2.27.3-0ubuntu3

---------------
gnome-applets (2.27.3-0ubuntu3) karmic; urgency=low

  * debian/control.in, debian/gnome-applets.manpages, debian/rules:
    - don't build the mixer applet since the gnome-media one is used now
      (lp: #401294)
  * debian/control.in:
    - suggests typo fix
  * debian/patches/81_silent_applet_cleaning:
    - don't display a dialog about the applet configuration cleaning since
      that's something which should be transparent for the users

 -- Sebastien Bacher <email address hidden> Wed, 22 Jul 2009 15:21:39 +0200

Changed in gnome-applets (Ubuntu Karmic):
status: Triaged → Fix Released
Luca Ferretti (elle.uca) wrote :

Just a question: are you sure that the new volume control (the one in notification area) works if you disable PulseAudio?

If not, isn't a better solution keep the old one, but don't add in default panel configuration (or remove from panel if you upgrade from 9.04)?

This bug effects me as well, Ubuntu 9.10 64bit RC on an Acer M7720

Changed in gnome-panel (Ubuntu Karmic):
status: Fix Released → Confirmed
status: Confirmed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers