Ubuntu

cpufreq applet doesn't draw anything (white square) in gnome-panel

Reported by Olivier Cortès on 2008-09-06
84
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-applets
Fix Released
Medium
gnome-applets (Ubuntu)
Low
Ubuntu Desktop Bugs
Nominated for Intrepid by David Tombs

Bug Description

Hi,
When my session opens, sometimes cpufreq-applet doens't draw itself on the panel (see attachment).
Left/Right button click and changing preferences (which work perfectly per se) doesn't help : at best the white square gets bigger if I choose to display "graphic and text" instead of just "graphic".
Removing the applet and adding an identically configured new one to the panel is a workaround, but not acceptable for a standard user I think.
On my machine this bug appears 50% of time (this is a rough estimation).

Hardware info can be found at http://deep-ocean.net/files/sony/
I'm on up-to-date intrepid, and this behaviour as been seen from alpha 4, when I joined the lucky-alpha-debuggers because my video card was not supported under hardy ;-)

My WM is compiz. If I switch to metacity (System→Preferences→Appearance → No effects), the white square turns into a transparent one : applet is stills here (i can click, change governor, etc), but invisible.
If I switch back to compiz, the applet stays transparent.

Sebastien Bacher (seb128) wrote :

thank you for your bug report. what applet do you try to add exactly? do you have any error in the .xsession-errors about this issue?

Changed in gnome-applets:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Olivier Cortès (olive) wrote :

It's all about cpufreq-applet.
It's not when I try to add it to the panel. The applet was already added to the panel, long time (months) before (because I restored my $HOME from Hardy When I installed the new machine with the alpha4 CD)…
The problem is only when my GNOME session opens, that the applet doesn't draw itself, and its only 50% of the time (approximately).

Olivier Cortès (olive) wrote :

I didn't think to .xsession-errors, so now i don't know because it gets overwritten every time session opens, and now my applet is OK in the current session. I'll look next time the applet doesn't draw itself.
regards,

Olivier Cortès (olive) wrote :

Hi,

here is my .xsession-errors when the applet is white. Sadly, I crawled it and didn't find anything related to the CPU Freq Applet. Since I reported the bug, the applet has been 5 times all-white, out of approximately 15 times I opened my GNOME session (a little more than once a day).

I'm sorry I do not know exactely how to reproduce the conditions of this bug.
I will try to open the session directly with metacity for the next days, to see if it can be compiz related (a wild guess related to window painting on the screen).

rekado (rekado) wrote :

I've got the same situation each time GNOME starts after a reboot.

rekado (rekado) wrote :

I do not use Compiz by the way. It has been completely removed. Instead I seem to use the gtk-window-decorator.

rekado (rekado) wrote :

This issue didn't come up since a while now. Seems that it has been fixed silently with one of the last updates.

dhenry (tfc-duke) wrote :

I don't think so, it just happened to me with intrepid...

Bart Kroon (bart-kroon) wrote :

Same for me. Excact same sympthoms.

AMD 64 3500+
nVidia nForce3
nVidia GeForce 6200
compiz
emerald

John Carlyle-Clarke (jpcc) wrote :

I have the same in intrepid. It generally worked OK in 8.04 (although I did see this bug once or twice in 8.04 but it was a very rare thing). I 8.10 it is grey after every reboot, although it is still working as the menus respond and so on. Removing and re-adding it to the panel fixes the problem - until the next boot.

Sven Hoffmeister (schaumkeks) wrote :

Do you have any background settings other than "None (use system theme)" set in the properties of the host panel? I had solid color with some "transparency" enabled. When changed to "None" the applet was drawn correct immediately. I left this setting on "None" and didn't experience any display problems since then (hardy).
Of course, I would like to have "transparency" back, so I'm still looking for a solution.

John Carlyle-Clarke (jpcc) wrote :

Sven, was just coming back to post the same finding. I switched from a transparency setting to "None (use system theme)" and the applet draws correctly since then.

Changed in gnome-applets:
status: Incomplete → New
fir3fly (fir3fly) wrote :

Same Problem here on a ASUS K6AM Laptop. Transparency in the Panel as well. I'll try the "None" Setting when im home today. Just writing here to confirm the bug and looking for a solution other than disabeling the transparency.

Tim Cole (timothy-j-cole) wrote :

I have the same issue in Intrepid. Worked fine with Hardy. I have the panel set with a background image. PNG with transparency.

Andreas Berger (andi-berger) wrote :

Same here:
-About (random) 50% of the time, after reboot, cpufreq-applet draws nothing
-Hardy as well as Intrepid
-Panel totally transparent (solid color with 0% opacity)

Celeblin (celeblin) wrote :

Same problem here:
- For me it's about 90% of time, the applets doesn't appear correctly.
- I use Intrepid Ibex
- Panel with system theme and no transparency.

Sebastien Bacher (seb128) wrote :

could somebody having the issue send that to bugzilla.gnome.org where people writting the software will read it rather than commenting on this distribution bug?

Nicolas Turcot (nico.nc) wrote :

Same problem for me (Hardy and Intrepid, transparent color background), but setting the background to "none" does not change anything. I've got to change the panel height to 25px to get it drawn correctly (and then back to 24px without any problem).

Tim Cole (timothy-j-cole) wrote :

Linking relevant bug from bugzilla.gnome.org

http://bugzilla.gnome.org/show_bug.cgi?id=556099

Pedro Villavicencio (pedro) wrote :

thanks for the link.

Changed in gnome-applets:
status: New → Triaged
Andrej Zirko (dixon85) wrote :

Same problem here on intrepid. Panel background is set to PNG image with no transparency.

Alex Nava (alessandronava83) wrote :

Similar problem here:
The cpufreq applet randomly display garbage. Practically, when something is drawn over the area (for example a tooltip label) it remains there.
Panel background is set to solid color with transparency. Turning transparency off do not resolve the issue, but will occasionally clear the applet area, making it disappear as if it is not on the panel (the panel has the correct color, even with transparency applied. No color blocks)
The applet always remain functional: the tooltip shows the correct policy and frquence, and it is posible to set them.

Screenshots attached for more clarity. The applet should be on the left of the volume icon.
I am using intrepid i386, installed from cd over a previous Hardy install, in the case it's relevant.

Alex Nava (alessandronava83) wrote :

Additional screenshot to show the applet behaviour when its area is cleared

Changed in gnome-applets:
status: Unknown → Confirmed
Jesper de Jong (jespdj) wrote :

I have the same problem on Hardy (x86_64), running on a Dell XPS M1530 (Intel Core 2 Duo T9300), nVidia proprietary driver, Compiz enabled.

Most of the time it works normally, but occasionally it doesn't draw itself directly after login and I get a white square.

Riccardo 'c10ud' (c10ud) wrote :

bug still present with intrepid's latest updates too.

randomly, the applet becomes a grey rectangle or invisible (!) sometimes it shows correctly

panoz (panos-t) wrote :

Yeap, still present, with transparency and compiz.
only on boot though...

Changed in gnome-applets:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :

fixed upstream, thanks for reporting.

Changed in gnome-applets:
status: Triaged → Fix Committed

The same bug for me, sometimes the grey rectangle appears above the cpufreq applet at boot time. I have to restart X to fix that...I have set a blue background color for the panel, but it paints the system one "above" the anyway working applet!

Sebastien Bacher (seb128) wrote :

the new version is in jaunty

Changed in gnome-applets:
status: Fix Committed → Fix Released
mb74 (mrb74) wrote :

I've found the problem now. If this bug ever appears again the following addition would fix it:
In file cpufreq-applet.c at line 881 add the following line:
    if (0 == label_size) return;
Then compile and install the new applet.
The problem source is that gnome sometimes calls the callback- and init-functions in the wrong order.

Jiri Trnka (jiri-trnka-79) wrote :

The same problem is still present in Lucid:

On my laptop with fresh installation of Lucid, all updates, the white square appears with more than 50% probability. On the other hand, on my dektop, which was upgraded from Interpid to Lucid recently, everything works fine...

PAB (ubuntu-angiebecker) wrote :

Still present also for me in Lucid.
You can see in the screenshot one broken instance (CPU1) showing some damaged area of its own tooltip help and one working instance (CPU0) at the same time.
I would say in 30% of the cases the control applet is broken.
Would be nice, if someone can fix this, since this is quiet annoying...

PAB (ubuntu-angiebecker) on 2010-07-11
Changed in gnome-applets (Ubuntu):
status: Fix Released → New
PAB (ubuntu-angiebecker) on 2010-07-11
Changed in gnome-applets (Ubuntu):
status: New → Confirmed
Changed in gnome-applets:
importance: Unknown → Medium

I can confirm this behaviour for "10.04 LTS - Lucid Lynx".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.