[SRU] Update gnome-applets to 3.36.4

Bug #1884383 reported by Sebastian Geiger on 2020-06-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-applets (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

[Impact]

This is a bug fix release that includes:
- translation updates;
- bug fix updates for netspeed, drivemount and window-picker applets;

NEWS

Change log for 3.63.4:
https://gitlab.gnome.org/GNOME/gnome-applets/-/commit/ea8ec983c8d5e285c341b7a9448e0bf20d43d363
Change log for 3.63.3:
https://gitlab.gnome.org/GNOME/gnome-applets/-/commit/2d5de2dff49a520f4b4fbed81d94841441729344

Fixes:

- A bug fix for the netspeed applet to ensure that dialogs are destroyed when an applet is destroyed:
  https://bugs.launchpad.net/ubuntu/+source/gnome-applets/+bug/1884375

- A bug fix for the window-picker applet to ensure that task icons are correctly removed when a
windows is closed:
  https://bugs.launchpad.net/ubuntu/+source/gnome-applets/+bug/1879140

- A change for the drivemount applet to ensure errors are properly cleared:
  https://bugs.launchpad.net/ubuntu/+source/gnome-applets/+bug/1884381

Besides the above bug fixes the release contains the following two minor changes:

An change for the drivemount applet to update the nautilus desktop id, without this change the drivemount applet will fail to open the GNOME Nautilus file manager.
https://gitlab.gnome.org/GNOME/gnome-applets/-/commit/5445406a1257bc33b3b531d398748e311c6d93f6

An update for the netspeed applet to remove an unused variable:
https://gitlab.gnome.org/GNOME/gnome-applets/-/commit/29272f65a4fce9049aa9c519752eead39127dab9

[Test Cases]
- See the three linked bug reports for test cases of each individual issue that was fixed.
- The other two changes are minor code cleanups that cannot be validated with a test case.

[Regression Potential]

netspeed:
The removal of an unused private variable has no regression potential since it is not part of a public interface.

drivemount:
The change to clear an error variable is only a minor cleanup in the code with minimal regression potential.

[Other Info]

None.

affects: gnome-flashback (Ubuntu) → gnome-applets (Ubuntu)
description: updated
Changed in gnome-applets (Ubuntu):
status: New → Fix Released

Hello Sebastian, or anyone else affected,

Accepted gnome-applets into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-applets/3.36.4-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-applets (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed verification-needed-focal
Sebastian Geiger (lanoxx) wrote :

I can confirm that the linked issues are fixed with version 3.36.4-0ubuntu1 that is currently in proposed.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers