Ubuntu

trashcan does not report files it contains

Reported by gspat on 2008-01-24
20
Affects Status Importance Assigned to Milestone
gnome-applets
Fix Released
High
gnome-applets (Ubuntu)
High
Ubuntu Desktop Bugs
nautilus (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: nautilus

When using the open "Move to trash" checking the trashcan does not report files are there.

ie: move two files to trashcan via "Move to Trash" in right click menu > hover over trash icon in panel > "No items in trash" is displayed

using hardy with latest updates (gvfs)

same issue using delete key on highlighted item

also:

right click trash icon and clicking "empty trash" does nothing opening the nautilus window and clicking the "delete trash" button does work, but left one item in the trash window (this item WAS deleted from trash, but was still displayed) refreshing the window with F5 cleared the file listing out.

I had attempted to delete the file again by highlighting and pressing the delete button, but received a dialog stating the file did not exist.

Nic (ntetreau) wrote :

I can confirm that the trash panel applet does not report items in trash. However, I haven't yet experienced the bug where items are still displayed in nautilus trashcan after emptying it.

Sebastien Bacher (seb128) wrote :

Thank you for your bug, that's because the applet doesn't use gvfs yet, there is a patch upstream and that will be fixed in ubuntu next week when the new GNOME is uploaded

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → High
milestone: none → ubuntu-8.04
status: New → Fix Committed
Matthew Woerly (nattgew) on 2008-01-25
Changed in nautilus:
status: New → Fix Released
status: Fix Released → Fix Committed
Sebastien Bacher (seb128) wrote :

that's not a nautilus bug

Changed in nautilus:
status: Fix Committed → Invalid
Changed in gnome-applets:
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-applets - 2.21.4-0ubuntu3

---------------
gnome-applets (2.21.4-0ubuntu3) hardy; urgency=low

  * debian/control.in:
    - updated libglib requirement
  * debian/patches/81_from_bugzilla_trash_applet_use_gio.patch:
    - change from bugzilla, switch to trash applet code to gio (LP: #185633)
  * debian/patches/98_autoreconf.patch:
    - updated due to the gio changes

 -- Sebastien Bacher <email address hidden> Mon, 04 Feb 2008 15:32:09 +0100

Changed in gnome-applets:
status: Fix Committed → Fix Released
Changed in gnome-applets:
status: New → Fix Released
Changed in gnome-applets:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.