notes doesn't delete only if empty

Bug #1703110 reported by Roland Boros on 2017-07-08
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-applets (Ubuntu)
Undecided
Unassigned
Zesty
Undecided
Unassigned

Bug Description

[Impact]

Unnesessary work for the user as he is forced to clear the note from text in order to delete it. It makes it more difficult that selecting text isn't possible with mouse.

[Test Case]

- Write anything in a note
- Try to select text in a note
- Try to delete it with 'x' or with 'delete notes' menu item

[Proposed Fix]

The fix is a backport of three upstream commits:
- https://git.gnome.org/browse/gnome-applets/commit/?id=85041d6567c78b4a “sticky-notes: make sure that notes are really saved”
- https://git.gnome.org/browse/gnome-applets/commit/?id=0c4e0c4fed0c61bf “sticky-notes: fix path to resource file for delete dialog”
- https://git.gnome.org/browse/gnome-applets/commit/?id=e189ba213c0f8db8
“sticky-notes: fix text selection”

[Regression Potential]

The fix definitely improves the Sticky Notes applet because without ability to save notes that applet is mostly unusable. It does not touch other applets so no regression expected there.

[Other Info]

System configuration:

 roland@roland-Lenovo-ideapad-110-15I
        `:+ssssssssssssssssss+:` ------------------------------------
      -+ssssssssssssssssssyyssss+- OS: Ubuntu 17.04 x86_64
    .ossssssssssssssssssdMMMNysssso. Model: 80T7 Lenovo ideapad 110-15IBR
   /ssssssssssshdmmNNmmyNMMMMhssssss/ Kernel: 4.10.0-26-generic
  +ssssssssshmydMMMMMMMNddddyssssssss+ Uptime: 4 hours, 45 mins
 /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/ Packages: 2360
.ssssssssdMMMNhsssssssssshNMMMdssssssss. Shell: bash 4.4.7
+sssshhhyNMMNyssssssssssssyNMMMysssssss+ Resolution: 1366x768
ossyNMMMNyMMhsssssssssssssshmmmhssssssso DE: GNOME-Flashback:GNOME
ossyNMMMNyMMhsssssssssssssshmmmhssssssso WM: Compiz
+sssshhhyNMMNyssssssssssssyNMMMysssssss+ WM Theme: Adwaita
.ssssssssdMMMNhsssssssssshNMMMdssssssss. Theme: Adwaita [GTK2/3]
 /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/ Icons: Ubuntu-mono-light [GTK2/3]
  +sssssssssdmydMMMMMMMMddddyssssssss+ Terminal: gnome-terminal
   /ssssssssssshdmNNNNmyNMMMMhssssss/ CPU: Intel Pentium N3710 (4) @ 2.5GH
    .ossssssssssssssssssdMMMNysssso. GPU: Intel HD Graphics 405
      -+sssssssssssssssssyyyssss+- Memory: 1674MiB / 3862MiB
        `:+ssssssssssssssssss+:`
            .-/+oossssoo+/-.

Stickynotes version: 3.22.0

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-applets - 3.24.1-1ubuntu1

---------------
gnome-applets (3.24.1-1ubuntu1) artful; urgency=medium

  * Backport two upstream fixes for the stickynotes applet (LP: #1703110).

 -- Dmitry Shachnev <email address hidden> Sat, 08 Jul 2017 23:56:20 +0300

Changed in gnome-applets (Ubuntu):
status: New → Fix Released
Brian Murray (brian-murray) wrote :

The Ubuntu SRU template in the bug description is missing information about the regression potential of this fix.

Changed in gnome-applets (Ubuntu Zesty):
status: New → Incomplete
Dmitry Shachnev (mitya57) wrote :

Brian: sorry, fixed now.

description: updated
Changed in gnome-applets (Ubuntu Zesty):
status: Incomplete → Confirmed

Hello Roland, or anyone else affected,

Accepted gnome-applets into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-applets/3.22.0-2ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-applets (Ubuntu Zesty):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-zesty
description: updated
tags: added: verification-failed-zesty
removed: verification-needed verification-needed-zesty
Dmitry Shachnev (mitya57) wrote :

I just made a new upload which fixes one more issue with that applet: text selection did not work. The new test case is added to the description.

Download full text (3.9 KiB)

Hello Brian,

I'm very grateful for your work, but I can't compile it. Terminal says this after the "./configure" command: bash: ./configure: Engedély megtagadva

It means permission is denied.
I can't figure it out. But I hope one day it will work.

Thank you again,

Roland

2017. júl. 28., p 0.50-kor-kor, Brian Murray <email address hidden> írta:
Hello Roland, or anyone else affected, Accepted gnome-applets into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome- applets/3.22.0-2ubuntu0.1 in a few hours, and then in the -proposed repository. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users. If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance! ** Changed in: gnome-applets (Ubuntu Zesty) Status: Confirmed => Fix Committed ** Tags added: verification-needed verification-needed-zesty
--
You received this bug notification because you are subscribed to the bug report. https://bugs.launchpad.net/bugs/1703110 Title: notes doesn't delete only if empty Status in gnome-applets package in Ubuntu: Fix Released Status in gnome-applets source package in Zesty: Fix Committed Bug description: [Impact] Unnesessary work for the user as he is forced to clear the note from text in order to delete it. It makes it more difficult that selecting text isn't possible with mouse. [Test Case] Write anything in a note and it can't be deleted with 'x' or with 'delete notes' menu item. [Proposed Fix] The fix is a backport of two upstream commits: - https://git.gnome.org/browse/gnome-applets/commit/?id=85041d6567c78b4a “sticky-notes: make sure that notes are really saved” - https://git.gnome.org/browse/gnome-applets/commit/?id=0c4e0c4fed0c61bf “sticky-notes: fix path to resource file for delete dialog” [Regression Potential] The fix definitely improves the Sticky Notes applet because without ability to save notes that applet is mostly unusable. It does not touch other applets so no regression expected there. [Other Info] System configuration: roland@roland-Lenovo-ideapad-110-15I `:+ssssssssssssssssss+:` ------------------------------------ -+ssssssssssssssssssyyssss+- OS: Ubuntu 17.04 x86_64 .ossssssssssssssssssdMMMNysssso. Model: 80T7 Lenovo ideapad 110-15IBR /ssssssssssshdmmNNmmyNMMMMhssssss/ Kernel: 4.10.0-26-generic +ssssssssshmydMMMMMMMNddddyssssssss+ Uptime: 4 hours, 45 mins /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/ Packages: 2360 .ssssssssdMMMNhsssssssssshNMMMdssssssss. Shell: bash 4.4.7 +sssshhhyNMMNyssssssssssssyNMMMysss...

Read more...

Roland, you should not compile it yourself! You should install update from proposed and test it, but... Please wait until new upload / version will be accepted. New upload will also fix text selection. :)

Hello Roland, or anyone else affected,

Accepted gnome-applets into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-applets/3.22.0-2ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-zesty
removed: verification-failed-zesty

Hi everyone,

Sticky Notes is such a useful tool I just can't do my work without it. But haven't been able to get the latest version work because of my poor skills in Linux. I managed to do a ton of stuff but everything is a first try.
Could you help me if this new fix doesn't work on my system or it is not even installed properly.

I installed the latest proposed version of gnome-applets(3.22.0-2ubuntu0.2) which has the latest Sticky Notes fixes.
But I'm not sure if I really installed it because it doesn't seem to work, notes still can't be closed and text selected.
Here's a picture of Synaptic showing it's installed in the attachment.
I followed this and set selective upgrading for proposed packages. And I installed the latest gnome-applets from terminal.

Cheers,
Roland

Your screenshot shows that you have installed only gnome-applets-data form proposed. gnome-applets is still at 3.22.0-2 version, but it should be also 3.22.0-2ubuntu0.2.

It works now I figured how to set it to install in synaptic. Thank you!

2017. aug. 22., k 14.34-kor-kor, Alberts Muktupāvels <email address hidden> írta:
Your screenshot shows that you have installed only gnome-applets-data form proposed. gnome-applets is still at 3.22.0-2 version, but it should be also 3.22.0-2ubuntu0.2.
--
You received this bug notification because you are subscribed to the bug report. https://bugs.launchpad.net/bugs/1703110 Title: notes doesn't delete only if empty Status in gnome-applets package in Ubuntu: Fix Released Status in gnome-applets source package in Zesty: Fix Committed Bug description: [Impact] Unnesessary work for the user as he is forced to clear the note from text in order to delete it. It makes it more difficult that selecting text isn't possible with mouse. [Test Case] - Write anything in a note - Try to select text in a note - Try to delete it with 'x' or with 'delete notes' menu item [Proposed Fix] The fix is a backport of three upstream commits: - https://git.gnome.org/browse/gnome-applets/commit/?id=85041d6567c78b4a “sticky-notes: make sure that notes are really saved” - https://git.gnome.org/browse/gnome-applets/commit/?id=0c4e0c4fed0c61bf “sticky-notes: fix path to resource file for delete dialog” - https://git.gnome.org/browse/gnome-applets/commit/?id=e189ba213c0f8db8 “sticky-notes: fix text selection” [Regression Potential] The fix definitely improves the Sticky Notes applet because without ability to save notes that applet is mostly unusable. It does not touch other applets so no regression expected there. [Other Info] System configuration: roland@roland-Lenovo-ideapad-110-15I `:+ssssssssssssssssss+:` ------------------------------------ -+ssssssssssssssssssyyssss+- OS: Ubuntu 17.04 x86_64 .ossssssssssssssssssdMMMNysssso. Model: 80T7 Lenovo ideapad 110-15IBR /ssssssssssshdmmNNmmyNMMMMhssssss/ Kernel: 4.10.0-26-generic +ssssssssshmydMMMMMMMNddddyssssssss+ Uptime: 4 hours, 45 mins /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/ Packages: 2360 .ssssssssdMMMNhsssssssssshNMMMdssssssss. Shell: bash 4.4.7 +sssshhhyNMMNyssssssssssssyNMMMysssssss+ Resolution: 1366x768 ossyNMMMNyMMhsssssssssssssshmmmhssssssso DE: GNOME-Flashback:GNOME ossyNMMMNyMMhsssssssssssssshmmmhssssssso WM: Compiz +sssshhhyNMMNyssssssssssssyNMMMysssssss+ WM Theme: Adwaita .ssssssssdMMMNhsssssssssshNMMMdssssssss. Theme: Adwaita [GTK2/3] /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/ Icons: Ubuntu-mono-light [GTK2/3] +sssssssssdmydMMMMMMMMddddyssssssss+ Terminal: gnome-terminal /ssssssssssshdmNNNNmyNMMMMhssssss/ CPU: Intel Pentium N3710 (4) @ 2.5GH .ossssssssssssssssssdMMMNysssso. GPU: Intel HD Graphics 405 -+sssssssssssssssssyyyssss+- Memory: 1674MiB / 3862MiB `:+ssssssssssssssssss+:` .-/+oossssoo+/-. Stickynotes version: 3.22.0 To manage notifications about this bug go to: https://bugs.launchpad.net/ubuntu/+source/gnome-applets/+bug/1703110/+subscriptions

tags: added: verification-done-zesty
removed: verification-needed verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-applets - 3.22.0-2ubuntu0.2

---------------
gnome-applets (3.22.0-2ubuntu0.2) zesty; urgency=medium

  * Extend sticky_notes_fixes.diff with one more upstream commit to
    fix text selection (LP: #1703110).

 -- Dmitry Shachnev <email address hidden> Mon, 31 Jul 2017 20:29:17 +0300

Changed in gnome-applets (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-applets has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Download full text (3.2 KiB)

I recently found out that text selecting only works if the color of the note is set to default.

2017. aug. 23., sze 2.58-kor-kor, Chris Halse Rogers <email address hidden> írta:
The verification of the Stable Release Update for gnome-applets has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.
--
You received this bug notification because you are subscribed to the bug report. https://bugs.launchpad.net/bugs/1703110 Title: notes doesn't delete only if empty Status in gnome-applets package in Ubuntu: Fix Released Status in gnome-applets source package in Zesty: Fix Released Bug description: [Impact] Unnesessary work for the user as he is forced to clear the note from text in order to delete it. It makes it more difficult that selecting text isn't possible with mouse. [Test Case] - Write anything in a note - Try to select text in a note - Try to delete it with 'x' or with 'delete notes' menu item [Proposed Fix] The fix is a backport of three upstream commits: - https://git.gnome.org/browse/gnome-applets/commit/?id=85041d6567c78b4a “sticky-notes: make sure that notes are really saved” - https://git.gnome.org/browse/gnome-applets/commit/?id=0c4e0c4fed0c61bf “sticky-notes: fix path to resource file for delete dialog” - https://git.gnome.org/browse/gnome-applets/commit/?id=e189ba213c0f8db8 “sticky-notes: fix text selection” [Regression Potential] The fix definitely improves the Sticky Notes applet because without ability to save notes that applet is mostly unusable. It does not touch other applets so no regression expected there. [Other Info] System configuration: roland@roland-Lenovo-ideapad-110-15I `:+ssssssssssssssssss+:` ------------------------------------ -+ssssssssssssssssssyyssss+- OS: Ubuntu 17.04 x86_64 .ossssssssssssssssssdMMMNysssso. Model: 80T7 Lenovo ideapad 110-15IBR /ssssssssssshdmmNNmmyNMMMMhssssss/ Kernel: 4.10.0-26-generic +ssssssssshmydMMMMMMMNddddyssssssss+ Uptime: 4 hours, 45 mins /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/ Packages: 2360 .ssssssssdMMMNhsssssssssshNMMMdssssssss. Shell: bash 4.4.7 +sssshhhyNMMNyssssssssssssyNMMMysssssss+ Resolution: 1366x768 ossyNMMMNyMMhsssssssssssssshmmmhssssssso DE: GNOME-Flashback:GNOME ossyNMMMNyMMhsssssssssssssshmmmhssssssso WM: Compiz +sssshhhyNMMNyssssssssssssyNMMMysssssss+ WM Theme: Adwaita .ssssssssdMMMNhsssssssssshNMMMdssssssss. Theme: Adwaita [GTK2/3] /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/ Icons: Ubuntu-mono-light [GTK2/3] +sssssssssdmydMMMMMMMMddddyssssssss+ Terminal: gnome-terminal /ssssssssssshdmNNNNmyNMMMMhssssss/ CPU: Intel Pentium N3710 (4) @ 2.5GH .ossssssssssssssssssdMMMNysssso. GPU: Intel HD Graphics 405 -+sssssssssssssssssyyyssss+- Memory: 1674MiB / 3862MiB `:+ssssssssssssssssss+:` .-/+oossssoo+/-. Stickynotes version: 3.22.0 To manage notifications about this bug go t...

Read more...

Roland, that is different bug. Text selection works, but there are problems with colours... If I remember correctly then selection colour is same as sticky notes background.

I have fixed this in gnome-applets and fix will be available in 3.26 release. Unfortunately I think that this fix is not something that I would backport to older releases as there might be new regressions that I have not noticed.

Commits that should fix this:
https://git.gnome.org/browse/gnome-applets/commit/?id=141d03c861e988b680d93c445c43cf6d528cf02d
https://git.gnome.org/browse/gnome-applets/commit/?id=a48212eb3af54d64b75eeadfe29f84d66074c76a

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers