The panel encountered a problem while loading "TrashAppletFactory::TrashApplet".

Bug #1574841 reported by ernsteiswuerfel on 2016-04-25
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-applets (Ubuntu)
Undecided
Unassigned
mate-applets (Ubuntu)
Undecided
Unassigned

Bug Description

Shortly after reaching the desktop, the "The panel encountered a problem while loading "TrashAppletFactory::TrashApplet"." error box appears.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: mate-applets 1.12.1-1
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.376
CurrentDesktop: MATE
Date: Mon Apr 25 20:03:05 2016
ExecutablePath: /usr/lib/mate-applets/trashapplet
LiveMediaBuild: Ubuntu-MATE 16.10 "Yakkety Yak" - Alpha amd64 (20160425)
ProcEnviron:
 SHELL=/bin/bash
 XDG_RUNTIME_DIR=<set>
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: mate-applets
UpgradeStatus: No upgrade log present (probably fresh install)
XsessionErrors:
 mate-session[2273]: WARNING: Unable to find provider '' of required component 'dock'
 (nm-applet:2714): Gdk-CRITICAL **: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed
 (deja-dup-monitor:2737): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

ernsteiswuerfel (erhard-f) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1574841

tags: added: iso-testing
Vlad Orlov (monsta) on 2016-08-13
Changed in mate-applets (Ubuntu):
status: New → Incomplete
ernsteiswuerfel (erhard-f) wrote :

On todays daily amd iso I don't get this bug. So I am going to mark it as invalid.

Changed in mate-applets (Ubuntu):
status: Incomplete → Invalid
Paul (twonotes) wrote :

I just got this condition on my Raspberry Pi 3, running Ubuntu MATE 16.04, once I installed a new Eyoyo HDMI display. Previously I was using an Acer DVI display through an adaptor cable. On each login the failing applet is different. So far I have seen the Notification and Trash applet fail.

Guy Rouillier (guy-rouillier) wrote :

I recently upgraded to 18.04 Mate AMD64, and I'm now getting this error. I wasn't getting this on 17.10. Please let me know what information you'd like me to provide.

Changed in mate-applets (Ubuntu):
status: Invalid → Confirmed
Ken Sharp (kennybobs) wrote :

I used to get this on Trusty and Gnome, and now it has reappeared on Xenial and MATE. For a while it didn't appear but there's clearly something wrong.

Sadly, the log is rather useless.

** (mate-panel:3282): WARNING **: Failed to load applet TrashAppletFactory::TrashApplet:

tags: added: xenial
tags: added: i386
tags: added: arm64
Ken Sharp (kennybobs) wrote :

I should add… this doesn't happen EVERY time, it seems to occur randomly during log-in.

Changed in gnome-applets (Ubuntu):
status: New → Confirmed
tags: added: bionic
Guy Rouillier (guy-rouillier) wrote :

Still getting this error on 19.04 Mate. I don't use the applet often, and I'm tried of seeing this popup, so I'm going to simply delete it. I can test if anyone is interested.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers