Weather report can't set unit preferences

Bug #1067110 reported by Kyle Spyksma on 2012-10-15
96
This bug affects 20 people
Affects Status Importance Assigned to Milestone
gnome-applets (Ubuntu)
Undecided
Unassigned

Bug Description

Been using weather report successfully for years.

But installed 12.10 gnome remix beta2, and got issues:

Successfully changed location in weather report to Hamilton, ON. But then...

Any changes made in the "Preferences/General" tab are ignored. All units that I set are reset blank when I return to the preferences window later, and the units shown in the applet remain F, mmHG, and miles, despite me having set them to C, kPa, km.

The custom address I chose for the radar map stays listed, but the map never loads. The check-box stating "use custom address for radar map" is un-checked when I return to the preferences window.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-applets 3.5.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Mon Oct 15 18:05:45 2012
ExecutablePath: /usr/lib/gnome-applets/gweather-applet-2
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Beta amd64(20120926)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
SourcePackage: gnome-applets
UpgradeStatus: No upgrade log present (probably fresh install)

Kyle Spyksma (kspyksma) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-applets (Ubuntu):
status: New → Confirmed

The same for me, with Quantal final version.

JoseStefan (josestefan) on 2012-10-22
description: updated
Jose Gómez (adler-dreamcoder) wrote :

The temperature stays in Farenheit, regardless of what I set in the preferences.

kenjiru (kenjiru) wrote :

Please do something about this bug. It's really embarrassing for the distribution, as this should be really easy to fix.

sergsero (sergsero) wrote :

The same for me with Quantal release x64 desktop. Can not switch to metric values. Temperature stays in Farenheit, no Centigrade and so on...

Same here. Ubuntu 12.10 x64.
Can I at least switch these units with in some config file or by some command in console? I need my beloved cm's...
Locale is globally set to German.

Piotr Materny (piotr-materny) wrote :

There is a woraround for this bug. You have to open dconf-editor and in the tree org-> gnome -> Gweather you can change default values for each of these : temperature, wind, pressure & distance.

Hope this helps
Piotr

2Piotr: Thanks for info! This parameter modification worked well for me!
The last question remains - why doesn't widget do it himself?

cccccccc (cccccccc) wrote :

Loool, I am started to think that there is something wrong with Ubuntu... Almost one year and they did not fixed it? Dudes, what is wrong with you?

Aleksi-ajp (aleksi-ajp) wrote :

Same bug in Fedora 19, I found accidentally workaround where if you use gnome shell weather extension (h ttps://extensions.gnome.org/extension/613/weather/ ) and change its settings on which unit you want to see, it affects Gnome Weather's units as well :P probably due to changing same configs as Piotr mentioned in his workaround. (funny though the weather extension itself doesn't work for me :P )

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers