daily live comes with crash report - pre-populated!

Bug #80589 reported by Peter Whittaker on 2007-01-19
28
Affects Status Importance Assigned to Milestone
gnome-app-install (Ubuntu)
High
Michael Vogt

Bug Description

Feisty daily live 20070118 arrives with a pre-populated crash report (attached). Odd...!

But it does install a-ok.

Peter Whittaker (pwwnow) wrote :
Emilio Pozuelo Monfort (pochu) wrote :

Can you try the 20070119 daily live? Or a newer one.

On Fri, 2007-01-19 at 13:06 +0000, Emilio Pozuelo wrote:
> Can you try the 20070119 daily live? Or a newer one.

Tried today's (20070120), crash file still present,
dated 20070119 7h09.

UBfusion (ubfusion) wrote :

As I reported in http://www.ubuntuforums.org/showthread.php?t=341532 the crash exists in 20070120 amd64 desktop (as a VM guest).

In previous daily builds installing the available distribution updates permanently removed this particular crash, on subsequent reboots.

The crash notification says "Sorry, Add/Remove... closed unexpectedly".

The generated crash report is very similar to bug #79619 (same crash when adding/removing programs on Feisty). In the bug thread it is said that gnome-app-install 0.3.6 fixes the bug, so I guess we have to wait until the new iso builds incorporate it.

UBfusion (ubfusion) wrote :

I hope there is still time to fix this before Herd3 is released for testing. Still persists in 20070201 amd64 desktop

Is it possible that this is not a real bug but an artifact, i.e. a file in /var/crash that gets by accident into the iso distribution and gets detected by the crash report routine upon boot?

-rw------- 1 root root 11604 2007-02-01 07:15 _usr_sbin_update-app-install.0.crash

Martin Pitt (pitti) wrote :

Confirmed on 20070201.02

Martin Pitt (pitti) wrote :

Affects all live systems, as it seems.

Changed in gnome-app-install:
importance: Undecided → High
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This should be fixed with the upload of 0.3.13 of today.

Cheers,
 Michael

Changed in gnome-app-install:
assignee: nobody → mvo
status: Confirmed → Fix Committed
UBfusion (ubfusion) wrote :

Confirmed in herd3 amd64, which by the way is identical to 20070201.2 so it has the same bugs.

Emilio Pozuelo Monfort (pochu) wrote :

Could you try to do "sudo aptitude update && sudo aptitude install gnome-app-install" before installing?

Regards
Pochu

Peter Whittaker (pwwnow) wrote :

Pochu, I'm puzzled: What do we hope to learn from running the update and installing gnome-app-install?

The live CDs work fine (at least recent ones do), so there are no installation problems. The bug described in this report is that there is a crash file on the live CD itself - an artifact of a bug in the build process.

The CD contents will not be changed by anything the end-user does, and the live CD works fine, so no additional end-user action is required.

Not trying to be difficult, just hoping to understand the suggestion....

Emilio Pozuelo Monfort (pochu) wrote :

Hi Peter.

Sorry, I though the crash was in the installed system, once you've reboot into it, because I also had that problem. So, if the problem would be that, running that command before installing the system will install the new package (with the fix), so once you reboot into it, you won't have the crash report.

However, if the crash is in the LiveCD, the command won't solve it, because it won't write the CD.

Regards
Pochu

cstrippie (ctfreedom) wrote :

Installed via live CD in both VM guest and naitive install on Herd 3. In both cases app-install reported crash at startup on CD and on initial startup for installed system. Running update installed app-install fix and problem disappeared on both installs.

Emilio Pozuelo Monfort (pochu) wrote :

Fix on the repos, and work fine. Thanks Michael!

Changed in gnome-app-install:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers