OO.o's desktop files contain an error: X-AppInstall-Package=openoffice.org-writer-experimental

Bug #64677 reported by Ricardo Pérez López on 2006-10-08
2
Affects Status Importance Assigned to Milestone
gnome-app-install (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: gnome-app-install

g-a-i says that I can't install OpenOffice.org (Database, Presentantion and Word Processor), because:

"This application is provided by the Ubuntu community.

OpenOffice.org Database cannot be installed on your computer type (i386). Either the application requires special hardware features or the vendor decided to not support your computer type."

However, I have OpenOffice.org installed.

As I say in a comment, this is due to incorrect data in /usr/share/app-install/desktop/ooo-*.desktop files.

Ricardo Pérez López (ricardo) wrote :

g-a-i says I can't install OpenOffice.org

Ricardo Pérez López (ricardo) wrote :

I have OpenOffice.org installed, as you can see in my Applications menu

Ricardo Pérez López (ricardo) wrote :

As you can see in the first screenshot, the checkbox next to the OpenOffice.org Database is unchecked; however, it must be checked (I have OpenOffice.org Database installed).

Ricardo Pérez López (ricardo) wrote :

This is my /etc/apt/sources.list

Ricardo Pérez López (ricardo) wrote :

It seems the problem is in app-install-data.

The file /usr/share/app-install/desktop/ooo-writer.desktop contains (among others) the following lines:

X-AppInstall-Package=openoffice.org-writer-experimental
X-AppInstall-Section=universe
X-AppInstall-Architectures=amd64

Each of the above lines are incorrect:

1. The openoffice.org-writer-experimental doesn't exists in my 386 installation.
2. OpenOffice.org is a main package, not a universe one.
3. My architecture is 386, not amd64.

The same problem is in ooo-base.desktop, ooo-calc.desktop, ooo-draw.desktop, ooo-impress.desktop and ooo-math.desktop.

description: updated

Thanks, Ricardo. Taking a look at the amount of bugs you run into, I get a bad conscience :)

Changed in gnome-app-install:
assignee: nobody → mvo
status: Unconfirmed → Confirmed
Ricardo Pérez López (ricardo) wrote :

:D

I would like to add: the OOo desktop files not only contains one error, but three (at least), as I said in my previous comment:

1. openoffice.org-writer-experimental doesn't exists.
2. universe instead of main.
3. amd64 architecture, instead of 386.

So I don't know if your new bug title ("OO.o's desktop files contain an error") is adequate. Maybe it's incomplete :)

Thanks.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

It turns out that there is a package called "broffice.org" that contains the same set of desktop files as openoffice.org and that confused the gnome-app-install menu data extraction. I blacklisted that package and it should be corrected when the next extraction run finishes.

Cheers,
 Michael

Changed in gnome-app-install:
importance: Undecided → Medium
status: Confirmed → In Progress
Michael Vogt (mvo) on 2006-10-09
Changed in gnome-app-install:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers