gnome-app-install crashed with GError in push_back()

Bug #406850 reported by Matej Kenda on 2009-07-30
92
This bug affects 18 people
Affects Status Importance Assigned to Milestone
gnome-app-install (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: gnome-app-install

Application didn't start on xubuntu Karmic at all.

ProblemType: Crash
Architecture: i386
Date: Thu Jul 30 14:07:43 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gnome-app-install
InterpreterPath: /usr/bin/python2.6
Package: gnome-app-install 0.5.51-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gnome-app-install
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.23-generic
PythonArgs: ['/usr/bin/gnome-app-install']
SourcePackage: gnome-app-install
Title: gnome-app-install crashed with GError in push_back()
Uname: Linux 2.6.31-4-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Matej Kenda (matejken) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Mario Limonciello (superm1) wrote :

Same thing on Mythbuntu karmic A4 candidate 2009-08-12.1

Renate (yollywau) wrote :

I have xubuntu in virtualbox and 2.6.31-5-generic kernel. Gnome-app-install crashes.

starslights (starslights) wrote :

when try to start "add/remove" application, it open and crash directly.

a rapport are send by my system

kubuntu karmic alpha4 x86 64

05.60.1 gnome-app-install

I can reproduce as well.

Changed in gnome-app-install (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
Michael Vogt (mvo) on 2009-09-04
Changed in gnome-app-install (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-app-install - 0.5.60.1ubuntu1

---------------
gnome-app-install (0.5.60.1ubuntu1) karmic; urgency=low

  * AppInstall/Menu.py:
    - do not crash if a Icon can not be loaded (LP: #406850)
  * fix crash when opening with specific activation style
    (LP: #391555)

 -- Michael Vogt <email address hidden> Fri, 04 Sep 2009 13:28:00 +0200

Changed in gnome-app-install (Ubuntu):
status: In Progress → Fix Released
starslights (starslights) wrote :

Hello,

i am sorry but the new package don't fix anything by me. It crash exactly same when it open.

kubuntu karmic alpha 5 , x86 64

My best and hope will good for the next up ;)

starslights (starslights) wrote :

this is strange, the package are update one more time with same version ref....

Well now it's work for me. Thanks very much

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers