Listed application names and descriptions are not translatable

Bug #219288 reported by Gabor Kelemen on 2008-04-18
4
Affects Status Importance Assigned to Milestone
gnome-app-install (Ubuntu)
Undecided
Michael Vogt

Bug Description

Binary package hint: gnome-app-install

The application names and descriptions, which are coming from gnome-app-install-data package, are not translatable in LP, altough they should, as these strings are highly visible.

Artem Popov (artfwo) wrote :

Hi, Gabor!

Thank you for taking the time to report this bug and trying to help make Ubuntu better. The translation for package names and descriptions are actually translatable here:
https://translations.edge.launchpad.net/ddtp-ubuntu

Thus, I'm closing the bug :)

Changed in gnome-app-install:
status: New → Invalid
Artem Popov (artfwo) wrote :

Oops, sorry, the URL is beta. For the stable Launchpad, please use:
https://translations.launchpad.net/ddtp-ubuntu

Gabor Kelemen (kelemeng) wrote :

Reopening.
No, I'm not talking about ddtp names, these ones are coming from the app-install-data package:
https://launchpad.net/app-install-data-ubuntu/
 which contains lots of .desktop files. Source is here:
http://bazaar.launchpad.net/~ubuntu-core-dev/app-install-data-ubuntu/ubuntu/files
These .desktop files are not translatable via LP, but they should.

Changed in gnome-app-install:
status: Invalid → New
Artem Popov (artfwo) wrote :

I still think this is not a bug, just looked at the README from here:
http://bazaar.launchpad.net/~ubuntu-core-dev/app-install-data-ubuntu/ubuntu/files

"The package information based on Freedesktop .desktop files. This is due to all end-user applications already having a .desktop file which can be extended with a small amount of metadata for use by the application install tool. These .desktop files will be extracted from the Hoary archive automatically and a package solely containing .desktop files and the relevant icons created."

When installing packages by Apps->Install/Remove, or codes directly from Totem, or extenstions directly from Firefox, I actually see the translated strings from ddtp. The purpose of these desktop files is all about the icons, so I suggest closing the bug anyway.

Gabor Kelemen (kelemeng) wrote :

Sorry for late reply, I had some trouble with my mail. Anyway...

Thanks for quoting the README, it also lists the problematic area:

"The Name, Comment and Icon keys will be used in the interface."

Which is, the method itself of extracting the non-translatable .desktop files. These contain names and descriptions of the applications, exactly as they are shown in the menu. When packaging the applications, the template desktop.in files will be populated with translations of the names/descriptions, if available in the po file, then these packaged .desktop files will be extracted for use in app-install. The list of available applications is made from these .desktop files, so some names/description _may_ show up translated, but there is no guarantee for this. Also this process ignores translations made in Launchpad and packaged in the langpacks.

I'm attaching a screenshot with some untranslated strings, hope you see the problem.

Michael Vogt (mvo) wrote :

This is translatable now via the app-install-data package that contains all the strings of the desktop files.

Changed in gnome-app-install:
assignee: nobody → mvo
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers