volume control/mixer interface unusable

Bug #187848 reported by DaveAbrahams on 2008-01-31
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME media utilities
Fix Released
High
gnome-alsamixer (Ubuntu)
Wishlist
Unassigned
gnome-media (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

The volume controls provided by default are incredibly complex and explained nowhere AFAICT. Using it to produce a given result is a total crapshoot for me.

For example, on my machine (Gutsy Thinkpad T60p):

* In the "File" menu there is a "change device" item that lets me select "HDA Intel (Alsa Mixer)" or "Analog Devices AD 1981 (OSS Mixer)." How am I supposed to know which one to use? After a great deal of experience with Ubuntu I see that most things seem to favor using Alsa, so I chose that, but it's really a shot in the dark.

* Under "Preferences" I get to "Select Tracks to be visible" and I can choose among:

  - Master (OK, I assume that's the overall playback volume)

  - PCM (? Seems to have an effect on various things)

  - CD (Presumably this controls an amplifier between the CD drive's DAC and the rest of the system?)

  - CD Capture (? I'm clueless)

  - Microphone
  - Microphone Capture
  - Mic Boost

     These three are an enigma. None are enabled by default IIRC, and when I find myself unable to record, I switch them on in various combinations. Switching on either Microphone or Microphone Capture makes a "Microphone" slider appear in the graphical mixer, but turning either one of these off, even if the other one is still on, makes that slider disappear

  - IEC958 (?)
  - IEC958 Playback Source (?)

  - Capture (? an overall recording level?)
  - Mix (??)
  - Digital (??)

Then, depending on what I have enabled, there may be a "recording" tab (note that it's not visible by default -- don't you think people will be doing sound input by default?) What's with the name "recording?" People use sound in for all kinds of things like Skype that don't involve recording. On the recording tab there are sliders with a pair of icons below them. One is a microphone, but one is a speaker. I assume (?) clicking the microphone enables/disables the input. What does it mean to click the speaker? BTW, for the longest time, because these icons were positioned directly below the left and right faders, I thought that the speaker was associated with the left fader and the microphone with the right one, but that appears to have been an illusion.

Also, depending on what I have enabled, there's a "Switches" tab that may contain "CD Capture," "Microphone Capture," and "Mix," all of whose meaning escapes me. Apparently I can only have one selected at a time. Huh?

It might help if there were somewhere a signal routing diagram.

Ralph Janke (txwikinger) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in gnome-alsamixer.

Ralph Janke (txwikinger) wrote :

Thanks for submitting this report.

After examining this information, we feel that this might rather be a support request than a bug report. Have you tried to get an answer for this in the support tracker?

How would you like this information to be implemented into the software?

Thanks

Changed in gnome-alsamixer:
assignee: nobody → txwikinger
status: New → Incomplete
DaveAbrahams (boostpro) wrote :

No I have not tried to get an answer in the support tracker.

I consider the problem a usability bug. In other words, although I would of course like the system to be explained to me (that's a typical support response), I can't imagine that any explanation of this interface will be simple enough to make it transparent and easily grasped to most people, so I want the usability to be fixed.

... of course I could be wrong about most people ... ;-)

I will post an explanation request in the support tracker, but I hope this issue is still addressed as though it were a bug.

Thanks

Ralph Janke (txwikinger) wrote :

Thanks for the co-operation.

It would be helpful to know how this can be addressed in regards to improving the software (which is what the bug report would be for). How can the usability be improved? Is it purely a documentation problem, or are there other steps required. If it is documentation, how and where should the documentation be available.

Thanks

DaveAbrahams (boostpro) wrote :

It's hard to prescribe specific improvements with confidence until I understand what the software does, and I still don't. So you could start with documentation, but my feeling is that documentation alone is inadequate, because a reasonably sophisticated user should not have to read docs to make some sense of the mixer GUI. As I mentioned in my initial post, a "circuit diagram" that shows how the various controls and components are connected would probably help a lot. A circuit diagram where the user can directly manipulate controls would probably be better. You can find such interfaces in digital audio recording packages, for example. That said, again, it's hard to be very sure of any of this until I understand the software.

Prashant Vaibhav (mercurysquad) wrote :

I would very much consider this a usability bug in gnome-alsamixer. AlsaMixer shows all channels exposed by Alsa directly, much of which depends on the hardware, and is rather unintelligible for casual users.

I propose replacing Alsa Mixer with something simpler, perhaps creating two 'modes' of operation, a simple mode and an advanced mode (which can be the current implementation).

The simple mode should only have 2 sliders : playback, and record level, and a mute button.

The playback slider should control Master and Headphone outputs. All other levels should be set to either maximum, or some other default like 80%, and unmuted.

The record slider should control the Capture channel. The capture should by default be set to Microphone. There could be an additional "Mic level boost" check box for those who need it.

Starting with Hardy, since PulseAudio will be used to control per-application audio levels, just two sliders, one for overall playback and one for record level, should be sufficient for most users. Pro-audio or amateur audio enthusiasts will probably know their configuration better and avoid using PulseAudio at all.

DaveAbrahams (boostpro) wrote :

Prashant Vaibhav wrote:

  "I propose replacing Alsa Mixer with something simpler, perhaps creating two 'modes' of operation, a simple mode and an advanced mode (which can be the current implementation)."

I don't think this will fix the problem. I am a sophisticated user (among other things, it used to be my job to write digital audio recording software), and I will need the control of whatever "advanced mode" is provided. Not to mention which even novice users will need the advanced mode when something goes wrong mysteriously (like no sound input -- happens to me every few days).

Furthermore, I don't know what would possibly clue me in to the idea that if I am a sophisticated user I should avoid using PulseAudio at all. Piling more layers of abstraction on this system in an attempt to give novices a simpler UI will not solve the underlying issue.

ttoine (ttoine) wrote :

Perhaps the main problem is how alsa drivers give the information to the gnome-alsa mixer ?

Toine

Ralph Janke (txwikinger) wrote :

I would suggest that a blueprint will be created for this, since this seems to be a substantial additional feature as described here https://wiki.ubuntu.com/SpecSpec

Ralph Janke (txwikinger) wrote :

Another possibility is to create an entry of this in http://brainstorm.ubuntu.com/. However, since this is not really a bug, and needs more discussion before implementation is possible, I would like to close this report.

Thanks

DaveAbrahams (boostpro) wrote :

Does any specification exist for this feature?

If not then I guess you can claim it's not a bug on the grounds that it doesn't fail to meet its spec. At the same time, the feature doesn't succeed in meeting any spec that I know of. That really sounds like a fundamental design bug to me.

Does this community have any formal definition of "bug" that it relies on?

Also, just so this issue doesn't get dropped on the floor, who is supposed to create such a blueprint/brainstorm?

BTW, I didn't mean to seem entirely hostile to what Prashant wrote: giving novices a simpler UI is a really, really good idea. It's just not enough. It has to be possible to understand what the system is really doing without reading the source code.

Ralph Janke (txwikinger) wrote :

Confirmed due to its relationship to the blueprint https://blueprints.edge.launchpad.net/ubuntu/+spec/cleanup-audio-jumble

Changed in gnome-alsamixer:
assignee: txwikinger → nobody
status: Incomplete → Confirmed
DaveAbrahams (boostpro) wrote :

FYI: the result of entering this in the support tracker is not encouraging: https://answers.launchpad.net/ubuntu/+question/24030

era (era) wrote :

Isn't the applet you are referring to called gnome-volume-control (as of Intrepid, in package gnome-media)? That's the applet I get when I right-click on the speaker in the top menu bar and select "open volume control" from the menu.

Here's a screenshot of gnome-alsamixer: http://dollarunderscore.wordpress.com/2007/05/29/gnome-alsa-mixer/ -- it's fairly similar, but not identical to gnome-volume-control.

I concur that this is a serious usability problem which should definitely be fixed.

era (era) wrote :

Adding insult to injury, the big friendly Help button in the lower left corner of gnome-volume-control brings up a friendly "Unable to load page" -- "The requested URI "ghelp:///gnome-volume-control" is invalid" error message. This will apparently be fixed in Jaunty (LP bug #259945).

era (era) wrote :

The next version of gnome-volume-control will allegedly bring some relief. Here is an overview: http://www.phoronix.com/scan.php?page=article&item=gnome_sound_control&num=1 (note the article has two pages, all the real meat is on the second page [grr]).

Sebastien Bacher (seb128) wrote :

do you have any issue which is not already described in an another bug? bugs are to describe specific issues

Changed in gnome-media:
importance: Undecided → Low
status: New → Incomplete
era (era) wrote :

My concrete problem is that the front panel mic input doesn't seem to work. While troubleshooting this, I have read enough to actually almost understand the interface jumble that is the gnome-volume-control applet, but nowhere near enough to understand whether the actual problem is already reported.

In any event, I feel that one of the things which makes this inordinately hard to sort out is that the g-v-c user interface hides away relevant controls and displays irrelevant controls. If it were better designed, I would not have to Google to find out which controls I can ignore, and which ones I will need to enable in the Preferences so I can twiddle them.

Changed in gnome-media:
status: Incomplete → New
era (era) wrote :

Upstream bug http://bugzilla.gnome.org/show_bug.cgi?id=350667 holds some promise for a less zany interface if it ever gets implemented.

Changed in gnome-media:
status: Unknown → New
Changed in gnome-media:
assignee: nobody → desktop-bugs
status: New → Triaged
era (era) wrote :

Also http://bugzilla.gnome.org/show_bug.cgi?id=329923 outlines some fundamental issues to be resolved.

era (era) wrote :

Because I posted the Phoronix link, I should also post this correction:
http://www.hadess.net/2009/01/nb-it-doesnt-actually-look-like-that.html

Changed in gnome-media:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in gnome-media (Ubuntu):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

The new version is in karmic now

Changed in gnome-media (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-media:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.