Ubuntu

Zeitgeist doesn't restart after upgrade (Unknown method name: GetHistogramData)

Reported by Marek Zdražil on 2010-09-14
794
This bug affects 156 people
Affects Status Importance Assigned to Milestone
GNOME Activity Journal
Low
Siegfried Gevatter
gnome-activity-journal (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-activity-journal

Application crashed after started. Version 3.*.* started normally.

Message from terminal:

** Message: pygobject_register_sinkfunc is deprecated (GstObject)
Traceback (most recent call last):
  File "/usr/bin/gnome-activity-journal", line 99, in <module>
    from src.main import PortalWindow
  File "/usr/share/gnome-activity-journal/src/main.py", line 30, in <module>
    from activity_widgets import MultiViewContainer, TimelineViewContainer, ThumbViewContainer
  File "/usr/share/gnome-activity-journal/src/activity_widgets.py", line 35, in <module>
    from store import ContentStruct, CLIENT
  File "/usr/share/gnome-activity-journal/src/store.py", line 504, in <module>
    STORE = Store()
  File "/usr/share/gnome-activity-journal/src/store.py", line 367, in __init__
    days_population = ZeitgeistDBusInterface().get_extension("Log", "journal/activity").GetHistogramData()
  File "/usr/local/lib/python2.6/dist-packages/zeitgeist/client.py", line 82, in __getattr__
    raise TypeError("Unknown method name: %s" % name)
TypeError: Unknown method name: GetHistogramData

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: gnome-activity-journal 0.5.0+tb1-1
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
Architecture: i386
Date: Tue Sep 14 18:39:19 2010
ExecutablePath: /usr/bin/gnome-activity-journal
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100113)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: python /usr/bin/gnome-activity-journal
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=cs_CZ.utf8
PythonArgs: ['/usr/bin/gnome-activity-journal']
SourcePackage: gnome-activity-journal
Title: gnome-activity-journal crashed with TypeError in __getattr__()
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare

Marek Zdražil (sliver17) wrote :
tags: removed: need-duplicate-check
visibility: private → public
summary: - gnome-activity-journal crashed with TypeError in __getattr__()
+ Unknown method name: GetHistogramData

Thank you for your bug report and helping improve Ubuntu.

Is this still reproducible after restarting the Zeitgeist engine? You can do that by running "zeitgeist-daemon --replace".

"zeitgeist-daemon --replace" worked.
So, is zeitgeist-daemon not starting on boot? Shouldn't it be starting automatically by default?

Marek Zdražil (sliver17) wrote :

It doesn't help for me. I have two version of gnome-activity-journal in system. Old version (3.*.*) works normally, but new doesn't.

Siegfried Gevatter (rainct) wrote :

Here goes my theory:

Zeitgeist was running (because you had used GNOME Activity Journal, Sezen, Unity, an application with Zeitgeist integration or whatever) at the point you installed the GNOME Activity Journal update.

The latest GNOME Activity Journal includes (and requires) an extension for Zeitgeist which provides the GetHistogramData method. However, since Zeitgeist was already running (and extensions are only loaded when Zeitgeist starts) it wasn't being used yet when you tried to launch the Activity Journal.

After restarting Zeitgeist (manually / closing your session / rebooting the computer / whatever) the extension gets picked up the next time Zeitgeist starts and so this problem shouldn't be happening again.

Can you (and the people from the duplicates) please confirm if I am correct?

Siegfried Gevatter (rainct) wrote :

Yup, that's indeed the problem. So, for everyone getting this: just restart the Zeitgeist daemon.

I'll look into a fix for this (restarting Zeitgeist automatically every time it gets updated), but that probably won't go in until Ubuntu Natty.

Changed in gnome-activity-journal (Ubuntu):
importance: Undecided → Low
status: New → Triaged
summary: - Unknown method name: GetHistogramData
+ Zeitgeist doesn't restart after upgrade (Unknown method name:
+ GetHistogramData)

Hi,

zeitgeist-daemon --replace did not solve the problem for me.

I pulled the latest code for both gaj and zeitgeist and tested it. GetHistogramData seems to have been defined in gnome-activity-journal/extension/gnome_activity_journal.py . If I move this file to zeitgeist/_zeitgeist/engine/extensions then I no longer get the "TypeError: Unknown method name: GetHistogramData". Now I get an error like

** Message: pygobject_register_sinkfunc is deprecated (GstObject)
Traceback (most recent call last):
  File "./gnome-activity-journal", line 99, in <module>
    from src.main import PortalWindow
  File "/home/neo/temp/gaj/gnome-activity-journal/src/main.py", line 30, in <module>
    from activity_widgets import MultiViewContainer, TimelineViewContainer, ThumbViewContainer
  File "/home/neo/temp/gaj/gnome-activity-journal/src/activity_widgets.py", line 35, in <module>
    from store import ContentStruct, CLIENT
  File "/home/neo/temp/gaj/gnome-activity-journal/src/store.py", line 504, in <module>
    STORE = Store()
  File "/home/neo/temp/gaj/gnome-activity-journal/src/store.py", line 370, in __init__
    day = Day(date, days_population)
  File "/home/neo/temp/gaj/gnome-activity-journal/src/store.py", line 202, in __init__
    self.insert_events(None, fact.get_events())
  File "/home/neo/temp/gaj/gnome-activity-journal/src/external.py", line 243, in get_events
    events.append(self._make_event(int(self.start_time), Interpretation.ACCESS_EVENT.uri))
  File "/home/neo/temp/gaj/gnome-activity-journal/src/external.py", line 235, in _make_event
    subject_interpretation = Interpretation.COMMENT.uri,
  File "/home/neo/temp/gaj/gnome-activity-journal/../zeitgeist/zeitgeist/datamodel.py", line 185, in __getattr__
    raise AttributeError("'%s' object has no attribute '%s'" %(self.__class__.__name__, name))
AttributeError: 'Symbol' object has no attribute 'COMMENT'

Andres (andres-erbsen) wrote :

This happened to me with version: 0.5.0.1-0ubuntu1 and 0.5.0.0. zeitgeist-daemon --replace soleved the problem, at least for now

Siegfried Gevatter (rainct) wrote :

The problem here is that Zeitgeist needs to be restarted after installing the latest GNOME Activity Journal version for it to work, so after running "zeitgeist-daemon --replace" or restarting the session/computer you'll be fine.

Saravanan: That is bug #641148 which has already been solved.

Changed in gnome-activity-journal (Ubuntu):
milestone: none → ubuntu-11.04

Working with the latest bzr code, I get this error too. I have tried updating both zeitgeist and gaj repos, and --restart. I'm using ubuntu 10.04, but has already removed *zeitgeist* packages. Any idea what the problem is?

Error:
...
  File "/my/repo/gnome-activity-journal/../zeitgeist/zeitgeist/client.py", line 82, in __getattr__
    raise TypeError("Unknown method name: %s" % name)
TypeError: Unknown method name: GetHistogramData

@ Behnam: If you want to run GAJ from the bzr repository you have to
manually install its Zeitgeist extension, by copying
extension/gnome_activity_journal.py into
~/.local/share/zeitgeist/extensions (and then restarting Zeitgeist).

Oh, I see. Thanks, now it's working. So the README file needs some update.

mr. Ed (mred) wrote :

this bug affect ubuntu 10.10

Erick Lopez (ericklopez76) wrote :

I have the same problem in ubuntu 10.10.

Pavol Klačanský (pavolzetor) wrote :

natty also

Peterson Silva (petersonsilva) wrote :

It's working now in Natty after my last upgrade a couple of hours ago.

Johan Linde (johanlinde) wrote :

Just got this in Natty. Just installed activity journal too, wouldn't even start.

The workaround of restarting the daemon took care of it for me.

the problem solve for me with $./zeitgeist-daemon --replace

Changed in gnome-activity-journal (Ubuntu):
milestone: ubuntu-11.04 → natty-updates
Aaron Bentley (abentley) wrote :

I installed Gnome Activity Journal on natty and immediately tried to use it. Of course, it failed due to the missing extension. I can understand not wanting to fix the upgrade case, but the fresh install case looks pretty bad.

Luca Mina (luca-mina) wrote :

I have a fresh Natty installation. My bug is slightly similar, it changes only some of the lines numbers.

As others users, this command solve the problem:

zeitgeist-daemon --replace

Wolf Rogner (war-rsb) wrote :

restart obviously fixed the problem for me.

Recommend to restart zeitgeist in post-install of deb.

Timo Witte (spacefish) wrote :

restarting zeitgeist-daemon in the postinstall of the .deb package would be great.

Hey, I was having the same problem also, it looks like the problem is to authenticate into the zeitgeist. I couldn't solve the problem using the command:

zeitgeist-daemon --replace

Because it looks like that the problem is over authenticating into zeitgeist with user+passwd. So I reseted the whole confiurations and it worked for me. I had to put all my passwd's again for the all others programs but I guess is the price to pay for dont entering a default passwd in the ubuntu key-ring from a fresh install

What I did to fix it was to re-install the whole zeitgeist packages and the gnome-activity-journal and deleted the config files from

zeitgeist:

~/.local/share/zeitgeist

activity-journal:

~/.local/share/gnome-activity-journal

and deleted the default gnome key-ring in:

 ~/.gnome2/keyrings/

In the next log-out/restart it will prompt for a new default gnome key-ring passwd and entering in it I could run activity-journal without a problem. I hope this info can help someone else out there that running the replace for zeitgeist-daemon dont work

sorry for posting this comment twice, i accidentially posted it in the duplicated version of the bug ....sorry for that
I have the same problem here (but no 64-system), and I found a workaround (if one of the above solutions works for you, just ignore this one):
You have to start the System-Administration-Terminal, that gives you root privilegs.
now you can run gnome-activity-journal.
This should work. But zeitgeist, which is, i guess the reason you need activity journal for, depends on executing user.
So i tried a bit, and found a trick.
For example, if you want to set a blacklist, set the blacklist in the with root rights started activity journal, then close it.
now run nautilus with root, open /root/.locale/zeitgeist/ and copy the blacklist.prickle file to /home/your_name/.locale/zeitgeist/
now set the file ownage and the rights to your username (easy with nautilus, rightclick properties...you know how to)
you can now close all terminals, i dont know if zeitgeist has to be restarted, i just rebooted and if you now open a file, you have blacklisted with the trick, it will not be shown in the recently used documents.
hope it works with you!

Th3Pr0ph3t (th3pr0ph3t) wrote :

In my case, the line number is 94:

  File "/usr/bin/gnome-activity-journal", line 94, in <module>
    from src.main import PortalWindow
  File "/usr/share/gnome-activity-journal/src/main.py", line 30, in <module>
    from activity_widgets import MultiViewContainer, TimelineViewContainer, ThumbViewContainer
  File "/usr/share/gnome-activity-journal/src/activity_widgets.py", line 35, in <module>
    from store import ContentStruct, CLIENT
  File "/usr/share/gnome-activity-journal/src/store.py", line 504, in <module>
    STORE = Store()
  File "/usr/share/gnome-activity-journal/src/store.py", line 367, in __init__
    days_population = ZeitgeistDBusInterface().get_extension("Log", "journal/activity").GetHistogramData()
  File "/usr/lib/pymodules/python2.7/zeitgeist/client.py", line 108, in __getattr__
    raise TypeError("Unknown method name: %s" % name)
TypeError: Unknown method name: GetHistogramData

And still the program doesn't start.

This program has been broken for months.
I think a bug that makes a program useless should not be triaged, you should remove this program from the repos instead.

Alexander Nolting (a-nolting) wrote :

For me was neither zeitgeist-daemon --replace nor re-installing the whole packages necessary. Only deleting the data in

~/.local/share/zeitgeist

and

~/.local/share/gnome-activity-journal

did the trick.

Changed in gnome-activity-journal:
assignee: nobody → Siegfried Gevatter (rainct)
importance: Undecided → Low
milestone: none → 0.8.0
status: New → Fix Committed
Changed in gnome-activity-journal:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-activity-journal - 0.8.0-1

---------------
gnome-activity-journal (0.8.0-1) unstable; urgency=low

  [ Siegfried-Angel Gevatter Pujals ]
  * New upstream releases (Closes: #621011) (LP: #643795, #722227, #734412,
    #743054, #743125, #650917).
  * debian/postinst:
     - Restart zeitgeist-daemon after installation, to ensure that
       the extension gets loaded (LP: #638217).
  * debian/control:
     - Bump Zeitgeist dependency to 0.8.0.
     - Remove Tracker from Suggests, support for it has been disabled
       for now.
     - Bump Standards-Version to 3.9.2.
  * debian/rules:
     - Remove build/ directory on clean.
  * debian/copyright:
     - Update copyright years and add Stefano Candori and Collabora.

  [ Manish Sinha ]
  * debian/control:
     - Add Recommends on gstreamer0.10-plugins-base (LP: #705545).

gnome-activity-journal (0.5.0.1-1) experimental; urgency=low

  * New upstream bug-fix release:
     - Updated Hamster-specific code to use the new ontology from Zeitgeist
       0.5.0 (LP: #641148, Closes: #591267).
     - Catch exception trying to extract a non-existant thumbnail from an
       OpenDocument file (LP: #535440).
     - Other minor fixes and removed superfluous debugging output.
     - Updated several translations.
  * debian/control:
     - Add Tracker to Suggests, now that Tracker 0.7+ is available in the
       repositories (LP: #612732).
  * Remove debian/patches/disable-version-check, incorporated upstream.
 -- Siegfried Gevatter <email address hidden> Wed, 27 Jul 2011 14:31:24 +0000

Changed in gnome-activity-journal (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.