Starting up gaj makes it crash

Bug #625343 reported by Ted Gould
106
This bug affects 57 people
Affects Status Importance Assigned to Milestone
GNOME Activity Journal
Undecided
Unassigned
gnome-activity-journal (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gnome-activity-journal

Crashes on startup.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: gnome-activity-journal 0.3.3-1
ProcVersionSignature: Ubuntu 2.6.35-19.26-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
NonfreeKernelModules: nvidia wl
Architecture: amd64
Date: Fri Aug 27 09:17:49 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/share/gnome-activity-journal/gnome-activity-journal
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: python /usr/bin/gnome-activity-journal
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.utf8
PythonArgs: ['/usr/bin/gnome-activity-journal']
SourcePackage: gnome-activity-journal
Title: gnome-activity-journal crashed with AttributeError in __getattr__()
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse libvirtd lpadmin netdev plugdev sambashare tape video

Revision history for this message
Ted Gould (ted) wrote :
tags: removed: need-duplicate-check
Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

Good enough to go public

visibility: private → public
Changed in gnome-activity-journal (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Seif Lotfy (seif) wrote : Re: [Bug 625343] Re: Starting up gaj makes it crash

can some1 come online and let me help you fix this issue :/

On Mon, Sep 6, 2010 at 6:11 PM, Bilal Akhtar <email address hidden>wrote:

> Good enough to go public
>
> ** Visibility changed to: Public
>
> ** Changed in: gnome-activity-journal (Ubuntu)
> Importance: Undecided => High
>
> ** Changed in: gnome-activity-journal (Ubuntu)
> Status: New => Confirmed
>
> ** Also affects: gnome-activity-journal
> Importance: Undecided
> Status: New
>
> --
> Starting up gaj makes it crash
> https://bugs.launchpad.net/bugs/625343
> You received this bug notification because you are subscribed to The
> Zeitgeist Project.
>
> Status in GNOME Activity Journal: New
> Status in “gnome-activity-journal” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: gnome-activity-journal
>
> Crashes on startup.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.10
> Package: gnome-activity-journal 0.3.3-1
> ProcVersionSignature: Ubuntu 2.6.35-19.26-generic 2.6.35.3
> Uname: Linux 2.6.35-19-generic x86_64
> NonfreeKernelModules: nvidia wl
> Architecture: amd64
> Date: Fri Aug 27 09:17:49 2010
> EcryptfsInUse: Yes
> ExecutablePath: /usr/share/gnome-activity-journal/gnome-activity-journal
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
> InterpreterPath: /usr/bin/python2.6
> PackageArchitecture: all
> ProcCmdline: python /usr/bin/gnome-activity-journal
> ProcEnviron:
> SHELL=/bin/bash
> LANG=en_US.utf8
> PythonArgs: ['/usr/bin/gnome-activity-journal']
> SourcePackage: gnome-activity-journal
> Title: gnome-activity-journal crashed with AttributeError in __getattr__()
> UserGroups: adm admin audio cdrom dialout dip fax floppy fuse libvirtd
> lpadmin netdev plugdev sambashare tape video
>
>
>

--
This is me doing some advertisement for my blog http://seilo.geekyogre.com

Revision history for this message
Pete Goodall (pgoodall) wrote :

I worked through this with @seif today. This seems to already be fixed upstream. Need new zeitgeist and gnome-activity-journal from bzr.

Revision history for this message
Siegfried Gevatter (rainct) wrote :

This should be fixed by GNOME Activity Journal 0.5.0 which is now available in Ubuntu Maverick.

Changed in gnome-activity-journal (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Extender (msveshnikov) wrote :

Yes, confirm, that bug fixed now. Thanks.

Changed in gnome-activity-journal:
status: New → Fix Released
Revision history for this message
Saravanan Thirumuruganathan (saravanan-thirumuruganathan) wrote :

Hi,

I am in Maverick beta amd64 and have have the latest versions (0.5.0-0ubuntu2). I get attributeerror when I start gaj but not the exact one specified in this ticket. I pulled the latest code using bzr and I could reproduce the error there too. The error I get is :

Traceback (most recent call last):
  File "/usr/bin/gnome-activity-journal", line 99, in <module>
    from src.main import PortalWindow
  File "/usr/share/gnome-activity-journal/src/main.py", line 30, in <module>
    from activity_widgets import MultiViewContainer, TimelineViewContainer, ThumbViewContainer
  File "/usr/share/gnome-activity-journal/src/activity_widgets.py", line 35, in <module>
    from store import ContentStruct, CLIENT
  File "/usr/share/gnome-activity-journal/src/store.py", line 504, in <module>
    STORE = Store()
  File "/usr/share/gnome-activity-journal/src/store.py", line 370, in __init__
    day = Day(date, days_population)
  File "/usr/share/gnome-activity-journal/src/store.py", line 202, in __init__
    self.insert_events(None, fact.get_events())
  File "/usr/share/gnome-activity-journal/src/external.py", line 243, in get_events
    events.append(self._make_event(int(self.start_time), Interpretation.ACCESS_EVENT.uri))
  File "/usr/share/gnome-activity-journal/src/external.py", line 235, in _make_event
    subject_interpretation = Interpretation.COMMENT.uri,
  File "/usr/lib/pymodules/python2.6/zeitgeist/datamodel.py", line 185, in __getattr__
    raise AttributeError("'%s' object has no attribute '%s'" %(self.__class__.__name__, name))
AttributeError: 'Symbol' object has no attribute 'COMMENT'

Revision history for this message
Saravanan Thirumuruganathan (saravanan-thirumuruganathan) wrote :

I am willing to do additional diagnostics/experiments. I am also a decent Python code but I got stuck here with zeitgeist's datamodel.py file.

Revision history for this message
Seif Lotfy (seif) wrote :

fix is in trunk

On Fri, Sep 17, 2010 at 11:42 PM, Saravanan Thirumuruganathan <
<email address hidden>> wrote:

> I am willing to do additional diagnostics/experiments. I am also a
> decent Python code but I got stuck here with zeitgeist's datamodel.py
> file.
>
> --
> Starting up gaj makes it crash
> https://bugs.launchpad.net/bugs/625343
> You received this bug notification because you are subscribed to The
> Zeitgeist Project.
>
> Status in GNOME Activity Journal: Fix Released
> Status in “gnome-activity-journal” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: gnome-activity-journal
>
> Crashes on startup.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.10
> Package: gnome-activity-journal 0.3.3-1
> ProcVersionSignature: Ubuntu 2.6.35-19.26-generic 2.6.35.3
> Uname: Linux 2.6.35-19-generic x86_64
> NonfreeKernelModules: nvidia wl
> Architecture: amd64
> Date: Fri Aug 27 09:17:49 2010
> EcryptfsInUse: Yes
> ExecutablePath: /usr/share/gnome-activity-journal/gnome-activity-journal
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
> InterpreterPath: /usr/bin/python2.6
> PackageArchitecture: all
> ProcCmdline: python /usr/bin/gnome-activity-journal
> ProcEnviron:
> SHELL=/bin/bash
> LANG=en_US.utf8
> PythonArgs: ['/usr/bin/gnome-activity-journal']
> SourcePackage: gnome-activity-journal
> Title: gnome-activity-journal crashed with AttributeError in __getattr__()
> UserGroups: adm admin audio cdrom dialout dip fax floppy fuse libvirtd
> lpadmin netdev plugdev sambashare tape video
>
>
>

--
This is me doing some advertisement for my blog http://seilo.geekyogre.com

Revision history for this message
Saravanan Thirumuruganathan (saravanan-thirumuruganathan) wrote :

Cool. Can confirm that the fix works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers