gnomad2 needs superuser access

Bug #354 reported by John Griffin
16
Affects Status Importance Assigned to Milestone
gnomad2 (Ubuntu)
Medium
MOTU

Bug Description

After gnomad2 is installed an entry is added to the gnome application menu under Sound & Video

After gnomad2 is installed an entry is added to the gnome application menu under Sound & Video. This launcher's command needs to be prefixed with 'gksudo' for it to talk to the mp3 player.

Changed in gnomad2:
assignee: nobody → motu
Revision history for this message
Ante Karamatić (ivoks) wrote :

What permissons are on that device?

Revision history for this message
Barry deFreese (bddebian) wrote :

Anymore news on this bug? If the original poster doesn't reply we will close it. Thank you.

Revision history for this message
Hervé Cauwelier (hcauwelier-deactivatedaccount) wrote :

Please don't. if gnomad2 still needs root access, I'll prepend gksudo as stated.

Lukas Fittl (lfittl)
Changed in gnomad2:
status: New → NeedInfo
Revision history for this message
bowill (bowill) wrote :

gnomad2 should not require superuser access.

When run with hotplug support, the /etc/hotplug/usb/nomadjukebox script adds group audio permission to the correct "file" under /proc/bus/usb/. It also adds world write permission, which I think is incorrect, but that's another issue.

The problem here is that with the switch to udev, the device (now under /dev/bus/usb/) is not set with either the correct group or the correct permission to match the model that was used before. The udev config appears to indicate that the nomadjukebox should be run for the device, but it isn't. I don't see any indication that udevd has received an event from the kernel when the nomad was plugged in. And even if it did receive the event and run the script, it won't work because the script expects the device file to be a regular file (which it was under /proc/bus/usb/) rather than a character file (which it is under /dev/bus/usb/).

Revision history for this message
bowill (bowill) wrote :

Oh ... and since you had asked ...

The device under /dev/bus/usb/ is owned by root, the group is root, and the permissions are 664, which appear to be the defaults for USB devices.

Revision history for this message
bowill (bowill) wrote : modified nomadjukebox script

Here is my modified /etc/hotplug/usb/nomadjukebox script.

It works for me on Dapper with udev, but should also work on a system that still uses hotplug.

Revision history for this message
Phil Bull (philbull) wrote :

Confirming, as there's a patch that would fix this.

Changed in gnomad2:
status: Needs Info → Confirmed
Revision history for this message
bowill (bowill) wrote :

The version of libnjb5 in Debian Testing (2.2.5-3) has a udev fix. It sets the group for the njb device as audio and the perms as 0660 instead of running /etc/hotplug/usb/nomadjukebox.

This is a cleaner solution, I think, and it doesn't require the hotplug script for udev systems (though the script will always be installed, now that it's been moved into the main libnjb5 package).

Unfortunately, the new method will break current installations that have customized the nomadjukebox script in order to more carefully limit permissions.

Revision history for this message
Dr.Felix Raekson (felix-raekson) wrote : Re: [Bug 354] Re: gnomad2 needs superuser access

Thank you
On Sun, 2006-04-09 at 21:23 +0000, bowill wrote:
> The version of libnjb5 in Debian Testing (2.2.5-3) has a udev fix. It sets the group for the njb device as audio and the perms as 0660 instead of running /etc/hotplug/usb/nomadjukebox.
>
> This is a cleaner solution, I think, and it doesn't require the hotplug script for udev systems (though the script will always be installed, now that it's been moved into the main libnjb5 package).
>
> Unfortunately, the new method will break current installations that have customized the nomadjukebox script in order to more carefully limit permissions.
--
Dr.Felix Raekson <email address hidden>

Revision history for this message
pbeeson (pbeeson) wrote :

In edgy, I was having this problem. Instead of trying all the hotplug stuff above, I simply rebooted my machine and I could use gnomad2 as any user.

Revision history for this message
Dr.Felix Raekson (felix-raekson) wrote :

Thank you very much

On 11/28/06, pbeeson <email address hidden> wrote:
>
> In edgy, I was having this problem. Instead of trying all the hotplug
> stuff above, I simply rebooted my machine and I could use gnomad2 as any
> user.
>
> --
> gnomad2 needs superuser access
> https://launchpad.net/bugs/354
>

--
Best Regards
Dr.Felix Raekson

Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :

appears to be fixed (in debian and ubuntu)?

Please reopen if this is not the case

Changed in gnomad2:
status: Confirmed → Fix Released
Revision history for this message
Dr.Felix Raekson (felix-raekson) wrote :

yes, it's fixed

On 3/16/07, Sarah Hobbs <email address hidden> wrote:
>
> appears to be fixed (in debian and ubuntu)?
>
> Please reopen if this is not the case
>
> ** Changed in: gnomad2 (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> gnomad2 needs superuser access
> https://launchpad.net/bugs/354
>

--
Best Regards
Dr.Felix Raekson

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions