gnocchi 3.1.0 needs to depend on oslo.utils >= 3.18.0

Bug #1665625 reported by Dr. Jens Harbott on 2017-02-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnocchi (Ubuntu)
Low
Unassigned

Bug Description

The package only depends on

python-oslo.utils (>= 3.3.0)

but with 3.16.0 from Newton UCA installed I get:

# gnocchi-api -h
Traceback (most recent call last):
  File "/usr/bin/gnocchi-api", line 6, in <module>
    from gnocchi.rest.app import build_wsgi_app
  File "/usr/lib/python2.7/dist-packages/gnocchi/rest/__init__.py", line 23, in <module>
    from oslo_utils import dictutils
ImportError: cannot import name dictutils

The requirements.txt from upstream specifies oslo.utils >= 3.18.0 so we need an updated dependency here.

James Page (james-page) on 2017-06-16
Changed in gnocchi (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnocchi - 3.1.2-0ubuntu7

---------------
gnocchi (3.1.2-0ubuntu7) artful; urgency=medium

  * d/control: Bump minimum oslo.utils version to 3.18.0 (LP: #1665625).

 -- James Page <email address hidden> Fri, 16 Jun 2017 12:22:26 +0100

Changed in gnocchi (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers