gnocchi 3.1.0 needs to depend on oslo.utils >= 3.18.0

Bug #1665625 reported by Dr. Jens Rosenboom on 2017-02-17
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnocchi (Ubuntu)

Bug Description

The package only depends on

python-oslo.utils (>= 3.3.0)

but with 3.16.0 from Newton UCA installed I get:

# gnocchi-api -h
Traceback (most recent call last):
  File "/usr/bin/gnocchi-api", line 6, in <module>
    from import build_wsgi_app
  File "/usr/lib/python2.7/dist-packages/gnocchi/rest/", line 23, in <module>
    from oslo_utils import dictutils
ImportError: cannot import name dictutils

The requirements.txt from upstream specifies oslo.utils >= 3.18.0 so we need an updated dependency here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers