gtk-gnash crashed with SIGABRT in mempool_slot_idx()

Bug #920544 reported by Michael Zywek on 2012-01-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnash (Ubuntu)
Medium
Unassigned

Bug Description

uname -a
... 3.2.0-10-generic-pae #17-Ubuntu SMP Thu Jan 19 20:56:14 UTC 2012 i686 i686 i386 GNU/Linux

lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

I tried to look a video on www.web.de. For a second I saw a picture and a kind of movement, and there was a sound, too. After that: black-screen in the video-window. Then I took the direct-link to youtube: the same result.

Since days it seems to me, that the multimedia-performance is going to get worse. Another example: OpenShot does not start (launch).

Wouldn't it be fine to have a look at this problems?

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnash 0.8.10~git20111001-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-10.17-generic-pae 3.2.1
Uname: Linux 3.2.0-10-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Mon Jan 23 17:35:57 2012
ExecutablePath: /usr/bin/gtk-gnash
InstallationMedia: Xubuntu 12.04 "Precise Pangolin" - Alpha i386 (20111129.1)
ProcCmdline: /usr/bin/gtk-gnash -u http://s.ytimg.com/yt/swfbin/cps-vflHaZtPx.swf -U http://www.youtube.com/embed/Nq1sIoOWv-E -x 107001257 -j 463 -k 330 -F 32:33 -P allowfullscreen=true -P allowscriptaccess=always -P bgcolor=#000000 -P flashvars=el=embedded&fexp=907612%2C904446%2C901700&is_html5_mobile_device=false&allow_ratings=1&allow_embed=1&tabsb=0&sendtmp=1&hl=de_DE&use_tablet_controls=0&eurl=http%3A%2F%2Flinuxundich.de%2F&iurl=http%3A%2F%2Fi3.ytimg.com%2Fvi%2FNq1sIoOWv-E%2Fhqdefault.jpg&view_count=1738&title=DriveScribe&avg_rating=2.33333333333&video_id=Nq1sIoOWv-E&length_seconds=160&iurlmaxres=http%3A%2F%2Fi3.ytimg.com%2Fvi%2FNq1sIoOWv-E%2Fmaxresdefault.jpg&enablejsapi=1&sk=LeAQIoGuer-fMbzame2WdjpaimM-c07bC&use_native_controls=false&rel=1&playlist_module=http%3A%2F%2Fs.ytimg.com%2Fyt%2Fswfbin%2Fplaylist_module-vflNkocNQ.swf&watch_xlb=http%3A%2F%2Fs.ytimg.com%2Fyt%2Fxlb%2Fwatch%2Fstrings-de_DE-vfl1YjQ1y.xlb&iurlsd=http%3A%2F%2Fi3.ytimg.com%2Fvi%2FNq1sIoOWv-E%2Fsddefault.jpg&jsapicallback=ytPlayerOnYouTubePlayerReady&playerapiid=player1&framer=http%3A%2F%2Flinuxundich.de%2F -P height=100% -P id=video-player-flash -P src=http://s.ytimg.com/yt/swfbin/cps-vflHaZtPx.swf -P type=application/x-shockwave-flash -P width=100% -
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: gnash
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 pa_memblock_unref () from /usr/lib/i386-linux-gnu/libpulsecommon-1.1.so
 pa_memexport_process_release () from /usr/lib/i386-linux-gnu/libpulsecommon-1.1.so
 ?? () from /usr/lib/i386-linux-gnu/libpulsecommon-1.1.so
Title: gtk-gnash crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to precise on 2011-12-13 (41 days ago)
UserGroups: adm audio cdrom dip lightdm lpadmin netdev plugdev sambashare scanner sudo vboxusers video

Michael Zywek (mzpc) wrote :
visibility: private → public

StacktraceTop:
 mempool_slot_idx (ptr=<optimized out>, p=<optimized out>) at pulsecore/memblock.c:290
 mempool_slot_by_ptr (ptr=<optimized out>, p=<optimized out>) at pulsecore/memblock.c:299
 memblock_free (b=0xaae58000) at pulsecore/memblock.c:558
 pa_memblock_unref (b=0xaae58000) at pulsecore/memblock.c:595
 pa_memexport_process_release (e=0xb2c75800, id=7) at pulsecore/memblock.c:1110

Changed in gnash (Ubuntu):
importance: Undecided → Medium
summary: - gtk-gnash crashed with SIGABRT in raise()
+ gtk-gnash crashed with SIGABRT in mempool_slot_idx()
tags: removed: need-i386-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers